1.203. yum-rhn-plugin

1.203.1. RHBA-2011:0998: yum-rhn-plugin bug fix update

An updated yum-rhn-plugin package that fixes various bugs is now available for Red Hat Enterprise Linux 5.
The yum-rhn-plugin package provides support for connecting to Red Hat Network (RHN). Systems registered with RHN are able to update and install packages from Red Hat Network.
This update fixes the following bugs:
* When running the "yum --help" command with rhnplugin installed, command line options for other plug-ins were not listed in the output, although the plug-in options were still working. This error has been corrected: plug-in options are now listed. (BZ#614138)
* Due to rhnplugin not considering the value of Yum's "metadata_expire" variable, all channels used the default expiration time (21,700 seconds). This prevented a user from updating a system using RHN Satellite. rhnplugin now respects Yum's global settings. (BZ#666534)
* When using RHN Classic or RHN Satellite to schedule an installation or update on the client system with outdated Yum's metadata cache, the "rhn_check" utility incorrectly reported success. This error has been fixed and the scheduled action fails if Yum does not find any new packages to install or update. (BZ#667135)
* When a system registered by the Subscription Manager tool was updated with Yum and rhnplugin was enabled, the following message appeared:
This system is not registered with RHN. RHN support will be disabled.
The problem has been fixed: rhnplugin is now disabled by default, and is only enabled when registering with RHN Classic. If the system is registered with Subscription Manager, rhnplugin is not used and the message does not appear. (BZ#675220)
* The version of yum-rhn-plugin released with Red Hat Enterprise Linux 5.7 Beta did not print the progress bar during the download of packages. This has been fixed by correctly setting callbacks. (BZ#707241)
All users of yum-rhn-plugin are advised to upgrade to this updated package, which fixes these bugs.