1.121. pcre

1.121.1. RHBA-2011:0344: pcre bug fix update

Updated pcre packages that resolve an issue are now available for Red Hat Enterprise Linux 5.
PCRE is a Perl-compatible regular expression library.
These updated pcre packages fix the following bug:
* The pcre package update for Red Hat Enterprise Linux 5.6, the RHEA-2011:0022 enhancement advisory linked to in the References section of this advisory, enabled Unicode properties to support \p{..}, \P{..}, and \X escape sequences. However, compiling certain regular expressions which contained extended classes under a non-UTF-8 PCRE mode failed due to the compilation entering an infinite loop. This has been fixed in this update so that compiling such regular expressions completes as expected. (BZ#669413)
All users of pcre are advised to upgrade to these updated packages, which resolve this issue.