1.146. system-config-lvm

1.146.1. RHBA-2011:0103: bug fix update

An updated system-config-lvm package that fixes several bugs is now available for Red Hat Enterprise Linux 5.
system-config-lvm is a utility for graphically configuring logical volumes.
This update fixes the following bugs:
* Prior to this update, using the system-config-lvm utility to edit the properties of a logical volume may have changed the order of lines in the /etc/fstab file. To prevent potential errors upon a subsequent system startup, system-config-lvm has been updated to preserve the original line order. ( BZ#548057)
* Under certain circumstances, an attempt to remove a snapshot of a logical volume may have failed with an error. With this update, an upstream patch to target this issue has been applied, and such snapshots can now be removed as expected. ( BZ#567464)
* Due to an error in the implementation, deactivating an existing snapshot of a logical volume rendered the system-config-lvm utility unable to start. This error no longer occurs, and unused snapshots no longer prevent the utility from starting. ( BZ#569498)
* Due to the use of incorrect utilities, system-config-lvm was unable to resize ext4 partitions. This error has been fixed, and system-config-lvm now correctly uses the ext4 utilities. ( BZ#571995)
* When running a non-English translation of the application, the initial window was not completely translated and still contained English messages. With this update, the underlying source code has been corrected to respect the localization settings, and all messages are now translated as expected. ( BZ#578827)
* Previously, extending a logical volume may have caused the relevant line in the /etc/fstab file to be duplicated. This no longer occurs, and /etc/fstab is now processed as expected. ( BZ#586553)
* Prior to this update, an attempt to adjust the size of a logical volume failed, and a traceback was written to standard error. With this update, the size changes are applied, and relevant volumes are correctly remounted. ( BZ#586555)
Users of system-config-lvm are advised to upgrade to this updated package, which resolves these issues.