1.118. python-virtinst

1.118.1. RHBA-2011:0078: bug fix and enhancement update

An updated python-virtinst package that fixes bugs and adds enhancements is now available for Red Hat Enterprise Linux 5.
The python-virtinst utility is a module that helps build and install libvirt based virtual machines.
This update fixes the following bugs:
* Previously, the command "rpmbuild -bp" failed if a recent rpm was used and the patch flags were changed so that patch backup files were not created in some backup directory, because 0.400.3-unicode-fix.patch modified the backup file of previous patches. With this update, rpmbuild -bp works as expected. ( BZ#579976)
* Previously, the virt-install man page wrongly showed the default QEMU/KVM MAC address as beginning with 54:52... . With this update, the correct sequence 52:54 ... is shown. ( BZ#620838)
This update also adds the following enhancement:
* Previously, virt-install ignored the passed arguments when the -x option was used with local install media instead of URL installs. This update adds the ability for virt-install to recognize passed arguments in the -x option with local install media and prints errors for these. ( BZ#593410)
All users of python-virtinst are advised to upgrade to this updated python-virtinst package which resolves these issues.

1.118.2. RHBA-2010:0763: bug fix update

An updated python-virtinst package that fixes a bug in the virt-clone tool, is now available for Red Hat Enterprise Linux 5.
python-virtinst is a module that helps build and install libvirt based virtual machines. virt-clone is a command line tool that clones existing virtual machine images with the "libvirt" library.
* Previously, the virt-clone tool prevented cloning existing virtual machines to a block device. This was caused by a flawed validation check of the clone destination that would exit the virt-clone tool with an error if the clone destination file already existed. With this update, virt-clone skips this check if the clone destination is a block device. ( BZ#628458)
Users of python-virtinst, who clone virtual machines to a block device, are advised to upgrade to this updated package, which resolves this issue.