1.92. nss

1.92.1. RHBA-2010:0526: bug fix update

Updated nss packages that resolve an issue are now available.
NSS is a set of libraries designed to support cross-platform development of security-enabled client and server applications. Applications built with NSS can support SSL v2 and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other security standards.
These updated nss packages fix the following bug:
* a header, 'prlink.h', caused compiler warnings when it was included in an application built with the strict prototype checking enabled (i.e. when "-Wstrict-prototypes" was included in the 'CFLAGS'). If such warnings were treated as errors in the compiler flags (i.e. if "-Werror" was used), the affected application would not compile. The affected applications did not, in fact, need 'prlink.h', they were including it indirectly via another header. This update fixes the header so that it does not expose the faulty header and enables nss client software to build with strict prototype checking enabled, as expected. ( BZ#587546)
All users of NSS are advised to upgrade to these updated packages, which resolve this issue.