Red Hat CodeReady Studio 12.21

Installation Guide

Installing Red Hat CodeReady Studio
Installing Red Hat CodeReady Studio

Eva-Lotte Gebhardt
egebhard@redhat.com

Levi Valeeva
levi@redhat.com

Yana Hontyk
yhontyk@redhat.com
Abstract

This document describes the process of installing, upgrading, and uninstalling Red Hat CodeReady Studio.
# Table of Contents

**MAKING OPEN SOURCE MORE INCLUSIVE**  ................................................................. 3

**CHAPTER 1. MINIMAL REQUIREMENTS**  ................................................................. 4

**CHAPTER 2. INSTALLING OPENJDK**  ............................................................... 5
  2.1. INSTALLING OPENJDK ON WINDOWS  ...................................................... 5
    2.1.1. Additional resources  .............................................................................. 5
  2.2. INSTALLING OPENJDK ON RHEL  ............................................................ 5
    2.2.1. Additional resources  .............................................................................. 6

**CHAPTER 3. INSTALLING CODEREADY STUDIO**  ........................................... 7
  3.1. INSTALLING CODEREADY STUDIO IN ECLIPSE  ...................................... 7
    3.1.1. Installing CodeReady Studio in Eclipse when online  ......................... 7
    3.1.2. Installing CodeReady Studio in Eclipse when offline  ....................... 10
  3.2. INSTALLING CODEREADY STUDIO STAND-ALONE USING THE INSTALLER  12
  3.3. PERFORMING ADVANCED INSTALLATION TASKS  ...................................... 13
    3.3.1. Installing CodeReady Studio using a script  .................................... 13
    3.3.2. Building the CodeReady Studio stand-alone Installer from source  .... 13

**CHAPTER 4. UPGRADING CODEREADY STUDIO**  .......................................... 15
  4.1. UPGRADING MAJOR VERSIONS OF CODEREADY STUDIO  .................... 15
  4.2. UPDATING MINOR VERSIONS OF RED HAT CODEREADY STUDIO  .......... 16

**CHAPTER 5. UNINSTALLING CODEREADY STUDIO**  ....................................... 19
  5.1. UNINSTALLING RED HAT CODEREADY STUDIO USING ECLIPSE  .......... 19
  5.2. UNINSTALLING CODEREADY STUDIO USING THE INSTALLER  ............... 21

**CHAPTER 6. REPORTING ISSUES**  ................................................................. 22
Red Hat is committed to replacing problematic language in our code, documentation, and web properties. We are beginning with these four terms: master, slave, blacklist, and whitelist. Because of the enormity of this endeavor, these changes will be implemented gradually over several upcoming releases. For more details, see our CTO Chris Wright’s message.
CHAPTER 1. MINIMAL REQUIREMENTS

CodeReady Studio 12.21 is compatible with a range of operating systems, architectures, and Java Development Kit combinations. For a complete list, see Supported Configurations and Components.

Hardware requirements

- 2 GB RAM
  - 4 GB RAM is strongly recommended.
- 2 GB hard disk space

Software requirements

- OpenJDK is installed.
  - Red Hat OpenJDK is strongly recommended.

Operating system requirements

- For Linux (x86_64)
  - Red Hat Enterprise Linux 7 or 8
  - Fedora 31 or 32
  - Ubuntu 20.04 LTS or 19.10
- For Windows (x86_64)
  - Microsoft Windows 8 or 10
- For macOS (x86_64)
  - Catalina (10.15) or Mojave (10.14)

NOTE

On Windows: If you want the CodeReady Studio instance to be available to all users, install it in a folder accessible to all users (C:\codereadystudio). If it is not possible for the given user to write this main installation folder, any newly installed features and updates will be saved inside the home directory of the user.
CHAPTER 2. INSTALLING OPENJDK

The following sections describe how to install OpenJDK on Microsoft Windows and Red Hat Enterprise Linux (RHEL).

2.1. INSTALLING OPENJDK ON WINDOWS

The following section describes how to install OpenJDK 11 on Windows using the MSI-based installer.

Procedure

1. Download the MSI-based Installer from the Red Hat Developer Portal .
2. Run the installer and follow the on-screen installation instructions.
3. Configure CodeReady Studio to use OpenJDK by following the instructions for Working with Java Runtime Environments.

2.1.1. Additional resources

For more information on how to install OpenJDK 11, see the Installing and Using OpenJDK 11 for Windows Guide.

2.2. INSTALLING OPENJDK ON RHEL

The following section describes how to install OpenJDK 11 on RHEL.

Prerequisites

- Root access.
- A registered system with attached subscriptions.
  For more information, see the Registering the system and managing subscriptions Guide.

Procedure

- To install OpenJDK RPMs, run:

  # yum install java-11-openjdk-devel

Optionally, you can install the java-11-openjdk-src and the java-11-openjdk-demo packages. The java-11-openjdk-src package contains the complete OpenJDK 11 class library source code you can use with IDE indexers and debuggers. The java-11-openjdk-demo package contains Java runtimes for OpenJDK (demos and examples).

- To install java-11-openjdk-demo and java-11-openjdk-src, run:

  # yum install java-11-openjdk-src java-11-openjdk-demo

Troubleshooting
If you encounter the following error message while attempting to log in to the OpenShift cluster, configure your Java to use TLSv1.2. This problem only occurs in Java JDK versions prior to Java 11.0.7 and OpenShift cluster 4.4.0 or higher.

**Unable to execute request to request url https://<openshift-cluster-oauth-authorization-server>**

- To configure Java to use TLSv1.2:
  1. Open the file `codereadystudio.ini` located in the `studio` directory inside of the CodeReady Studio installation directory.
  2. Add the following line under the `-vmargs` section:

```
-Djdk.tls.client.protocols=TLSv1.2
```

**2.2.1. Additional resources**

- For more information on how to install, run, and switch between two parallel installed major OpenJDK versions on RHEL, see [How to install Java 8 and 11 on Red Hat Enterprise Linux 8](#).
CHAPTER 3. INSTALLING CODEREADY STUDIO

The following section describes how to install CodeReady Studio:

- Using Eclipse.
- Using the Installer.
- Using a script.
- From source.

Note that you can have multiple versions of CodeReady Studio installed on your system with Installer or Eclipse, provided you have these versions located in different directories.

3.1. INSTALLING CODEREADY STUDIO IN ECLIPSE

CodeReady Studio for Eclipse packages the CodeReady Studio plug-ins for your existing Eclipse instance.
You can install CodeReady Studio from Eclipse Marketplace when you are online. This installation method is referred to as Bring Your Own Eclipse (BYOE).
Alternatively, you can use the Update Site Zip to install CodeReady Studio when you are offline.

The following sections describe how to install CodeReady Studio when online and offline.

3.1.1. Installing CodeReady Studio in Eclipse when online

The following section describes how to install CodeReady Studio BYOE from Eclipse Marketplace.

Procedure

1. Start the Eclipse IDE.

2. Click Help → Eclipse Marketplace.
The Eclipse Marketplace window appears.

3. Locate Red Hat CodeReady Studio 12.21 GA
4. Click **Install**.

5. Follow the on-screen instructions to complete the installation process.

**IMPORTANT**

When prompted to select additional features to install, select the **Fuse Tooling** feature for creating, testing, and debugging integration applications.

If you receive warnings about installing unsigned content, review the details of the content and, if satisfied, click **Install Anyway** to continue with the installation.
6. Restart Eclipse.
   When prompted to restart the Eclipse IDE, click **Restart Now**. Note that the changes do not take effect until you restart Eclipse.

### 3.1.2. Installing CodeReady Studio in Eclipse when offline

The following section describes how to install CodeReady Studio with the **Update Site Zip**.

**Prerequisites**

- Download the **Red Hat CodeReady Studio 12.21 Update Site Zip** from the Red Hat Developer Portal.

**Procedure**

1. Start the Eclipse IDE.
2. Click **Help → Install New Software**.

   ![Install New Software](image)

   The **Available Software** window appears.
3. Click **Add**.
The **Add Repository** window appears.

![Add Repository Window](image)

4. Click **Archive** and locate the **Update Site Zip** file.

5. Click **Add**.


   ![Install Window](image)

   - **Available Software**
     - Check the items that you wish to install.
     - Work with: `jar:file:/home/user/Downloads/codereadystudio-12.16.0.GA-updatesite-core.zip/`
     - Select the required check boxes:
       - Red Hat CodeReady Studio - Bring Your Own Eclipse
       - Red Hat Fuse Tooling
     - 47 items selected

   - **Details**
     - Tools to allow you to create Apache Camel routes in a graphical editor, launch them locally and deploy them to runtimes like Apache Karaf.
     - Show only the latest versions of available software
     - Contact all update sites during install to find required software
     - What is **already installed**?

7. Click **Next**.

8. Follow the on-screen instructions to complete the installation process.
   - If you receive warnings about installing unsigned content, review the details of the content and, if satisfied, click **Install Anyway** to continue with the installation.
9. Restart Eclipse.
   When prompted to restart the Eclipse IDE, click **Restart Now**. Note that the changes do not take effect until you restart Eclipse.

3.2. INSTALLING CODEREADY STUDIO STAND-ALONE USING THE INSTALLER

The Installer contains CodeReady Studio stand-alone, which packages the CodeReady Studio plug-ins with Eclipse and dependent third-party plug-ins. The Installer is compatible with all operating systems and is available from a variety of sources, including the Red Hat Customer Portal.

The following section describes how to install CodeReady Studio using the Installer.

**Procedure**

1. Download the **Red Hat CodeReady Studio 12.21 Installer** from the Red Hat Developer Portal.

2. Go to the directory that contains the **codereadystudio-12.21.0.GA-installer-standalone.jar** file you downloaded.

3. Start the Installer:

   ```
   $ java -jar codereadystudio-12.21.0.GA-installer-standalone.jar
   ```

4. Follow the on-screen instructions to complete the installation process.

**IMPORTANT**

When prompted to select additional features to install, select the **Fuse Tooling** feature for creating, testing, and debugging integration applications.
3.3. PERFORMING ADVANCED INSTALLATION TASKS

The following sections describe how to install CodeReady Studio using a script and how to build the Red Hat CodeReady Studio Installer from source code.

3.3.1. Installing CodeReady Studio using a script

The following section describes how to install CodeReady Studio using a script.

Procedure


2. Go to the directory that contains the codereadystudio-12.21.0.GA-installer-standalone.jar file you downloaded.

3. Start the Installer:

   $ java -jar codereadystudio-12.21.0.GA-installer-standalone.jar

4. Follow the on-screen instructions to complete the installation process.

   IMPORTANT

   When prompted to select additional features to install, select the Fuse Tooling feature for creating, testing and debugging integration applications.

   After the installation is complete, an InstallConfigRecord.xml file is generated in the CodeReady Studio installation directory.

5. Run the following command:

   $ java -jar codereadystudio-12.21.0.GA-installer-standalone.jar /path-to/InstallConfigRecord.xml

6. Replace path-to with the path to the InstallConfigRecord.xml file.

   NOTE

   The generated InstallConfigRecord.xml file is machine-specific and uses Java Development Kit (JDK) and installation paths of your system. To use the InstallConfigRecord.xml file for other operating systems, JDKs, or paths, you must manually modify the file.

3.3.2. Building the CodeReady Studio stand-alone Installer from source

The following section describes how to build the CodeReady Studio stand-alone Installer from source.

Prerequisites

- Maven 3.3 or later with Java 11 is installed. To obtain and configure Maven, see the Apache Maven Project.
Procedure

1. Clone the CodeReady Studio Git repository:
   
   ```
   $ git clone https://github.com/jbdevstudio/jbdevstudio-product.git
   ```

2. Navigate to the `jbdevstudio-product` directory:
   
   ```
   $ cd jbdevstudio-product
   ```

3. Checkout `master`:
   
   ```
   $ git checkout master
   ```

4. Follow the instructions in the `README.adoc` file.

When the build is complete, the `.jar` file for the CodeReady Studio stand-alone Installer is located in the `/jbdevstudio-product/installer/target` directory.
CHAPTER 4. UPGRADING CODEREADY STUDIO

The following section describes the possibilities of upgrading your version of CodeReady Studio to the latest major and minor versions.

4.1. UPGRADING MAJOR VERSIONS OF CODEREADY STUDIO

Each major version of CodeReady Studio is based on a different version of Eclipse. As a result, it is not possible to upgrade an older major version of CodeReady Studio to a newer major version. For example, it is not possible to update a CodeReady Studio 10.x installation to 11.x. However, it is possible to use the workspaces created using CodeReady Studio 11.x with CodeReady Studio 12.x.

Note that you can have multiple versions of CodeReady Studio installed on your system with Installer or Eclipse, provided you have these versions located in different directories.

The following table details the Eclipse versions supported with each major version of Red Hat CodeReady Studio:

Table 4.1. Eclipse Version Support Matrix

<table>
<thead>
<tr>
<th>Red Hat CodeReady Studio Version</th>
<th>Base Eclipse Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>CodeReady Studio 12.21</td>
<td>Eclipse IDE 2021-09</td>
</tr>
<tr>
<td>CodeReady Studio 12.19.1</td>
<td>Eclipse IDE 2021-03</td>
</tr>
<tr>
<td>CodeReady Studio 12.19</td>
<td>Eclipse IDE 2021-03</td>
</tr>
<tr>
<td>CodeReady Studio 12.18</td>
<td>Eclipse IDE 2020-09</td>
</tr>
<tr>
<td>CodeReady Studio 12.17</td>
<td>Eclipse IDE 2020-09</td>
</tr>
<tr>
<td>CodeReady Studio 12.16</td>
<td>Eclipse IDE 2020-06</td>
</tr>
<tr>
<td>CodeReady Studio 12.15</td>
<td>Eclipse IDE 2020-03</td>
</tr>
<tr>
<td>CodeReady Studio 12.14</td>
<td>Eclipse IDE 2019-12</td>
</tr>
<tr>
<td>CodeReady Studio 12.13</td>
<td>Eclipse IDE 2019-09</td>
</tr>
<tr>
<td>CodeReady Studio 12.11</td>
<td>Eclipse SimRel 2019-03 GA</td>
</tr>
<tr>
<td>CodeReady Studio 12.9</td>
<td>Eclipse SimRel 2018-09 GA</td>
</tr>
<tr>
<td>CodeReady Studio 12.0</td>
<td>Eclipse 4.8 (Photon)</td>
</tr>
<tr>
<td>CodeReady Studio 11.x</td>
<td>Eclipse 4.7 (Oxygen)</td>
</tr>
<tr>
<td>Red Hat CodeReady Studio 10.x</td>
<td>Eclipse 4.6 (Neon)</td>
</tr>
</tbody>
</table>
### 4.2. UPDATING MINOR VERSIONS OF RED HAT CODEREADY STUDIO

It is possible to update Red Hat CodeReady Studio to the latest minor versions within the major release. For example, you can update your Red Hat CodeReady Studio 12.0 installation to 12.9.

You may be automatically notified by the IDE when the latest Red Hat CodeReady Studio update is available, depending on your IDE settings for automatic updates.

**IMPORTANT**

Back up your workspace before updating. In addition to your project files, your workspace contains metadata about customized settings and preferences for the IDE. To back up your workspace, either copy the workspace directory to a backup location, or save it as a compressed file.

**Procedure**

1. Start the Eclipse IDE.

2. Click **Window → Preferences**.

   ![Preferences window](image)

   The *Preferences* window appears.

3. Select **Install/Update → Available Software Sites**.
4. Ensure that the URL https://devstudio.redhat.com/12/stable/updates/ is listed in enabled locations. If it is not listed, add it.

5. Click **Apply and Close**.

6. Click **Help → Check for Updates**.
Note that the search for updates might take some time.

7. Follow the on-screen instructions to apply available updates. If you receive warnings about installing unsigned content, review the details of the content and, if satisfied, click **Install Anyway** to continue with the installation.

8. Restart Eclipse. When prompted to restart the Eclipse IDE, click **Restart Now**. Note that the changes do not take effect until you restart Eclipse.
CHAPTER 5. UNINSTALLING CODEREADY STUDIO

The following section describes how to uninstall CodeReady Studio using Eclipse or the Installer.

Note that you can have multiple versions of CodeReady Studio installed on your system, provided you have these versions located in different directories.

5.1. UNINSTALLING RED HAT CODEREADY STUDIO USING ECLIPSE

The following section describes how to uninstall CodeReady Studio installed with Eclipse Marketplace or the Update Site Zip.

Procedure

1. Start the Eclipse IDE.
2. Click Help → Eclipse Marketplace.

The Eclipse Marketplace window appears.

3. Navigate to the Installed section.

5. Click the down arrow near the Change button.

6. Click Uninstall.
   The Confirm Selected Features window appears.

7. Ensure that Red Hat CodeReady Studio is selected.
8. Click **Confirm**.

9. Click **Finish**.
The **Software Updates** dialog box appears prompting you to restart Eclipse.

10. Click **Restart Now**.
Note that the changes do not take effect until you restart Eclipse.

### 5.2. UNINSTALLING CODEREADY STUDIO USING THE INSTALLER

The following section describes how to uninstall CodeReady Studio installed with the Installer.

**Procedure**

1. Ensure that CodeReady Studio is not running.

2. Navigate to the `/Uninstaller` directory:

   ```
   $ cd /path-to/codereadystudio/Uninstaller
   ```

3. Replace `path-to` with the path to the CodeReady Studio `/codereadystudio/Uninstaller` directory.

4. Start the Uninstaller:

   ```
   $ java -jar uninstaller.jar
   ```

   The **IzPack Uninstaller** dialog box appears.

5. Select the **Force the deletion** check box.
   If the check box is not selected, some files will be left behind in the installation directory.

6. Click **Uninstall**.
CHAPTER 6. REPORTING ISSUES

You can report errors by raising a ticket in JIRA. When creating a JIRA ticket, please create it against one of the following projects: JBDS or JBIDE. Provide as much detail as possible in the JIRA ticket to help the team debug the error. You can also attach the error log to the JIRA tickets to provide context for the issue.