Chapter 1. Supported configurations and components

Every Red Hat CodeReady Studio release is tested and supported on a variety of market-leading operating systems, Java Virtual Machines (JVMs), and Red Hat JBoss Enterprise Application Platform servers and technologies.
This guide details the information about supported configurations and components for the CodeReady Studio 12.21 release.
For information related to earlier releases of CodeReady Studio, see the respective Supported Configurations and Components guides at access.redhat.com.

1.1. CodeReady Studio Components

The CodeReady Studio 12.21 release comprises the component versions of Eclipse and JBoss Tools as listed in the following table.

CodeReady Studio

12.21

Eclipse

2021-09 GA

JBoss Tools

4.21.0

1.2. Supported platforms and runtime servers

CodeReady Studio 12.21 supports the following versions of Red Hat JBoss Enterprise Application Platform:

  • 7.x, 6.x
Note

Products built on these versions of JBoss EAP are also supported, such as Red Hat JBoss Fuse Service Works and Red Hat JBoss Portal (formerly JBoss Enterprise SPA Platform and JBoss Enterprise Portal Platform, respectively). However, version 6.x servers as well as Red Hat JBoss Portal are no longer tested.

1.3. Supported frameworks

The frameworks that are supported by the CodeReady Studio 12.21 release are listed in the following table.

JakartaEE

8

Hibernate

3.5, 3.6, 4.0, 4.3, 5.0, 5.1, 5.2, 5.3, 5.4

jQuery Mobile

1.3, 1.4

AngularJS + Ionic

AngularJS 1.4.14
Ionic 1.0

1.4. Supported operating systems and Java Development Kits

The operating systems, chip architectures, and Java Development Kits that are supported by the CodeReady Studio 12.21 release are listed in the following table:

Operating SystemChip ArchitectureJava Development Kit

Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8

x86_64

OpenJDK 11

Microsoft Windows 8, and Microsoft Windows 10

x86_64

OpenJDK 11, Oracle JDK 11

macOS Catalina (10.15) and macOS Big Sur (11.0)

x86_64

Oracle JDK 11, OpenJDK 11

Fedora 33 and Fedora 34

x86_64

OpenJDK 11, Oracle JDK 11

Ubuntu 20.04 LTS and Ubuntu 21.04

x86_64

OpenJDK 11, Oracle JDK11

Important

Eclipse 2021-09 GA is tested CodeReady Studio 12.21 under Java Development Kit 11. Older Jave Development Kits are not supported for running CodeReady Studio. However, older versions are supported for application development and deployment.

Note

There are known issues when running CodeReady Studio with Java Development Kit 11. For more information, see JBDS-4751.

1.4.1. Additional resources