
Red Hat CodeReady Studio 12.17

Installation Guide

Installing Red Hat CodeReady Studio

Last Updated: 2020-12-15





Red Hat CodeReady Studio 12.17 Installation Guide

Installing Red Hat CodeReady Studio

Eva-Lotte Gebhardt
egebhard@redhat.com

Levi Valeeva
levi@redhat.com

Yana Hontyk
yhontyk@redhat.com



Legal Notice

Copyright © 2020 Red Hat, Inc.

The text of and illustrations in this document are licensed by Red Hat under a Creative Commons
Attribution–Share Alike 3.0 Unported license ("CC-BY-SA"). An explanation of CC-BY-SA is
available at
http://creativecommons.org/licenses/by-sa/3.0/
. In accordance with CC-BY-SA, if you distribute this document or an adaptation of it, you must
provide the URL for the original version.

Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert,
Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.

Red Hat, Red Hat Enterprise Linux, the Shadowman logo, the Red Hat logo, JBoss, OpenShift,
Fedora, the Infinity logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States
and other countries.

Linux ® is the registered trademark of Linus Torvalds in the United States and other countries.

Java ® is a registered trademark of Oracle and/or its affiliates.

XFS ® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States
and/or other countries.

MySQL ® is a registered trademark of MySQL AB in the United States, the European Union and
other countries.

Node.js ® is an official trademark of Joyent. Red Hat is not formally related to or endorsed by the
official Joyent Node.js open source or commercial project.

The OpenStack ® Word Mark and OpenStack logo are either registered trademarks/service marks
or trademarks/service marks of the OpenStack Foundation, in the United States and other
countries and are used with the OpenStack Foundation's permission. We are not affiliated with,
endorsed or sponsored by the OpenStack Foundation, or the OpenStack community.

All other trademarks are the property of their respective owners.

Abstract

This document describes the process of installing, upgrading, and uninstalling Red Hat CodeReady
Studio.
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CHAPTER 1. MINIMAL REQUIREMENTS
CodeReady Studio 12.17 is compatible with a range of operating systems, architectures, and Java
Development Kit combinations. For a complete list, see Supported Configurations and Components .

Hardware requirements

2 GB RAM

4 GB RAM is strongly recommended.

2 GB hard disk space

Software requirements

Installed OpenJDK.

Red Hat OpenJDK is strongly recommended.

Operating system requirements

For Linux (x86_64)

Red Hat Enterprise Linux 7 or 8

Fedora 31 or 32

Ubuntu 20.04 LTS or 19.10

For Windows (x86_64)

Microsoft Windows 8 or 10

For macOS (x86_64)

Catalina (10.15) or Mojave (10.14)

NOTE

On Windows, to make the CodeReady Studio instance available to all users install it in a
folder accessible to all users (C:\codereadystudio). If the main installation folder is not
writable by a given user, any newly installed features and updates get saved inside the
home directory of the user.

CHAPTER 1. MINIMAL REQUIREMENTS
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CHAPTER 2. INSTALLING OPENJDK
The following section describes how to install OpenJDK on Microsoft Windows and Red Hat
Enterprise Linux (RHEL).

2.1. INSTALLING OPENJDK ON WINDOWS

The following section describes how to install OpenJDK 11 on Windows using the MSI-based installer.

Procedure

1. Download the MSI-based Installer from Red Hat Developer Portal .

2. Run the installer and follow the on-screen installation instructions.

3. Configure CodeReady Studio to use OpenJDK by following the instructions for Working with
Java Runtime Environments.

2.1.1. Additional Resources

For more information on how to install OpenJDK 11, see the Installing and Using OpenJDK 11 for
Windows

2.2. INSTALLING OPENJDK ON RHEL

The following section describes how to install OpenJDK 11 on RHEL.

Prerequisites

Root access.

Registered system with attached subscriptions.
For more information, see the Registering the system and managing subscriptions  Guide.

Procedure

To install OpenJDK RPMs, use:

# yum install java-11-openjdk-devel

Optionally, you can install the java-11-openjdk-src and the java-11-openjdk-demo packages. The java-
11-openjdk-src package contains the complete OpenJDK 11 class library source code you can use with
IDE indexers and debuggers. The java-11-openjdk-demo package contains Java runtimes for OpenJDK
(demos and examples).

To install java-11-openjdk-demo and java-11-openjdk-src, use:

# yum install java-11-openjdk-src java-11-openjdk-demo

Troubleshooting

If you encounter the following error message while attempting to log in to the OpenShift cluster,
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If you encounter the following error message while attempting to log in to the OpenShift cluster,
configure your Java to use TLSv1.2. This problem only occurs in Java JDK versions prior to Java 11.0.7
and OpenShift cluster 4.4.0 or higher.

Unable to execute request to request url https://<openshift-cluster-oauth-authorization-server>

To configure Java to use TLSv1.2:

1. Open the file codereadystudio.ini located in the studio directory inside of the CodeReady
Studio installation directory.

2. Add the following line under the -vmargs section:

`-Djdk.tls.client.protocols=TLSv1.2`

2.2.1. Additional resources

For more information on how to install, run, and switch between two parallel installed major
OpenJDK versions on RHEL8, see How to install Java 8 and 11 on Red Hat Enterprise Linux 8 .

CHAPTER 2. INSTALLING OPENJDK
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CHAPTER 3. INSTALLING CODEREADY STUDIO
The following section describes how to install CodeReady Studio:

Using Eclipse.

Using the Installer .

Using a script.

From source.

Note that you can have multiple versions of CodeReady Studio installed on your system with Installer or
Eclipse, provided you have these versions located in different directories.

3.1. INSTALLING CODEREADY STUDIO IN ECLIPSE

CodeReady Studio for Eclipse packages the CodeReady Studio plug-ins for your existing Eclipse
instance. You can install CodeReady Studio from the Eclipse Marketplace when you are online. This
installation method is referred to as Bring Your Own Eclipse (BYOE). Alternatively, you can use the 
Update Site Zip to install CodeReady Studio when you are offline.

The following section describes how to install CodeReady Studio when you are online and when you are
offline.

3.1.1. Installing CodeReady Studio in Eclipse when online

The following section describes how to install CodeReady Studio BYOE from Eclipse Marketplace.

Procedure

1. Start the Eclipse IDE.

2. Click Help → Eclipse Marketplace.

Red Hat CodeReady Studio 12.17 Installation Guide
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The Eclipse Marketplace window appears.

3. Locate Red Hat CodeReady Studio 12.17 GA.
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4. Click Install.

5. Follow the on-screen instructions to complete the installation process.

IMPORTANT

When prompted to select additional features to install, select the Fuse Tooling
feature for creating, testing, and debugging integration applications.

If you receive warnings about installing unsigned content, review the details of the content and,
if satisfied, click Install Anyway to continue with the installation.

Red Hat CodeReady Studio 12.17 Installation Guide
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6. Restart Eclipse.
When prompted to restart the Eclipse IDE, click Restart Now. Note that the changes do not
take effect until you restart Eclipse.

3.1.2. Installing CodeReady Studio in Eclipse when offline

The following section describes how to install CodeReady Studio with the Update Site Zip. Alternatively,
you can also use an Installer downloaded on your system instead of the Update Site Zip.

Note that the Target Platform Zip contains the features on which CodeReady Studio depends. It also
contains the sources of all the included plug-ins.

Prerequisites

Download the Red Hat CodeReady Studio 12.17 Update Site Zip from the Red Hat Developer
Portal.

Procedure

1. Start the Eclipse IDE.

2. Click Help → Install New Software.

CHAPTER 3. INSTALLING CODEREADY STUDIO
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The Available Software window appears.

3. Click Add.
The Add Repository window appears.

4. Click Archive and locate the Update Site Zip file.

5. Click Add.

6. Select the Red Hat CodeReady Studio - Bring Your Own Eclipse and Red Hat Fuse Tooling
check boxes.

7. Click Next.

8. Follow the on-screen instructions to complete the installation process.
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If you receive warnings about installing unsigned content, review the details of the content and,
if satisfied, click Install Anyway to continue with the installation.

9. Restart Eclipse.
When prompted to restart the Eclipse IDE, click Restart Now. Note that the changes do not
take effect until you restart Eclipse.

3.2. INSTALLING CODEREADY STUDIO STAND-ALONE USING THE
INSTALLER

The Installer contains CodeReady Studio stand-alone that packages the CodeReady Studio plug-ins
with Eclipse and dependent third-party plug-ins. The Installer is compatible with all operating systems
and is available from a variety of sources, including the Red Hat Customer Portal.

The following section describes how to install CodeReady Studio using the Installer.

Procedure

1. Download the Red Hat CodeReady Studio 12.17 Installer from the Red Hat Developer Portal .

2. Go to the directory that contains the downloaded codereadystudio-12.17.0.GA-installer-
standalone.jar file.

3. Start the Installer:

$ java -jar codereadystudio-12.17.0.GA-installer-standalone.jar

4. Follow the on-screen instructions to complete the installation process.

IMPORTANT

When prompted to select additional features to install, select the Fuse Tooling
feature for creating, testing, and debugging integration applications.
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3.3. PERFORMING ADVANCED INSTALLATION TASKS

The following section describes how to:

Install CodeReady Studio using a script.

Build the Red Hat CodeReady Studio Installer from the source code.

3.3.1. Installing CodeReady Studio using a script

The following section describes how to install CodeReady Studio using a script.

Procedure

1. Download the Red Hat CodeReady Studio 12.17 Installer from the Red Hat Developer Portal .

2. Go to the directory that contains the downloaded codereadystudio-12.17.0.GA-installer-
standalone.jar file.

3. Start the installer:

$ java -jar codereadystudio-12.17.0.GA-installer-standalone.jar

4. Follow the on-screen instructions to complete the installation process.

IMPORTANT

When prompted to select additional features to install, select the Fuse Tooling
feature for creating, testing and debugging integration applications.

After the installation is complete, an InstallConfigRecord.xml file is generated in the

Red Hat CodeReady Studio 12.17 Installation Guide
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After the installation is complete, an InstallConfigRecord.xml file is generated in the
CodeReady Studio installation directory.

5. Run the following command:

$ java -jar codereadystudio-12.17.0.GA-installer-standalone.jar \
  /path-to/InstallConfigRecord.xml

Replace path-to with the path to the InstallConfigRecord.xml file.

NOTE

The generated InstallConfigRecord.xml file is machine-specific and uses the Java
Development Kit (JDK) and installation paths of your system. To use the 
InstallConfigRecord.xml file for other operating systems, JDKs, or paths, you must
manually modify the file.

3.3.2. Building the CodeReady Studio stand-alone Installer from source

The following section describes how to build the CodeReady Studio stand-alone Installer from source.

Prerequisites

Maven 3.3 or later with Java 11 must be installed. To obtain and configure Maven, see the
Apache Maven Project.

Procedure

1. Clone the Git repository:

$ git clone https://github.com/jbdevstudio/jbdevstudio-product.git

2. Navigate to the jbdevstudio-product directory:

$ cd jbdevstudio-product

3. Checkout into master:

$ git checkout master

4. Follow the instructions in the README.adoc file.

When the build is complete, the .jar file for the CodeReady Studio stand-alone Installer is located in the 
/jbdevstudio-product/installer/target directory.

CHAPTER 3. INSTALLING CODEREADY STUDIO
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CHAPTER 4. UPGRADING CODEREADY STUDIO
The following section describes the possibilities of upgrading your version of CodeReady Studio to the
latest major and minor versions.

4.1. UPGRADING MAJOR VERSIONS OF CODEREADY STUDIO

Each major version of CodeReady Studio is based on a different version of Eclipse. As a result, it is not
possible to upgrade an older major version of CodeReady Studio to a newer major version. For example,
it is not possible to update a CodeReady Studio 10.x installation to 11.x. However, it is possible to use the
workspaces created using CodeReady Studio 11.x with CodeReady Studio 12.x.

Note that you can have multiple versions of CodeReady Studio installed on your system with Installer or
Eclipse, provided you have these versions located in different directories.

The following table details the version of Eclipse supported with each major version of Red Hat
CodeReady Studio:

Table 4.1. Eclipse Version Support Matrix

Red Hat CodeReady Studio Version Base Eclipse Version

CodeReady Studio 12.17 Eclipse IDE 2020‑09

CodeReady Studio 12.16 Eclipse IDE 2020‑06

CodeReady Studio 12.15 Eclipse IDE 2020‑03

CodeReady Studio 12.14 Eclipse IDE 2019‑12

CodeReady Studio 12.13 Eclipse IDE 2019‑09

CodeReady Studio 12.11 Eclipse SimRel 2019-03 GA

CodeReady Studio 12.9 Eclipse SimRel 2018-09 GA

CodeReady Studio 12.0 Eclipse 4.8 (Photon)

CodeReady Studio 11.x Eclipse 4.7 (Oxygen)

Red Hat CodeReady Studio 10.x Eclipse 4.6 (Neon)

Red Hat CodeReady Studio 9.x Eclipse 4.5 (Mars)

4.2. UPDATING MINOR VERSIONS OF RED HAT CODEREADY STUDIO

You can update your Red Hat CodeReady Studio to the latest minor versions within the major release.
For example, you can update your Red Hat CodeReady Studio 12.0 installation to 12.9.

You may be automatically notified by the IDE when the latest Red Hat CodeReady Studio update is
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You may be automatically notified by the IDE when the latest Red Hat CodeReady Studio update is
available, depending on your IDE settings for automatic updates.

IMPORTANT

Back up your workspace before updating. In addition to your project files, your workspace
contains metadata about customized settings and preferences for the IDE. To back up
your workspace, either copy the workspace directory to a backup location, or save it as a
compressed file.

Procedure

1. Start the Eclipse IDE.

2. Click Window → Preferences.

The Preferences window appears.

3. Select Install/Update → Available Software Sites.
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4. Ensure that the URL https://devstudio.redhat.com/12/stable/updates/ is listed in enabled
locations. If it is not listed, add it.

5. Click Apply and Close.

6. Click Help → Check for Updates.

Red Hat CodeReady Studio 12.17 Installation Guide
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Note that the search for updates might take some time.

7. Follow the on-screen instructions to apply available updates.
If you receive warnings about installing unsigned content, review the details of the content and,
if satisfied, click Install Anyway to continue with the installation.

8. Restart Eclipse.
When prompted to restart Eclipse IDE, click Restart Now. Note that the changes do not take
effect until you restart Eclipse.

CHAPTER 4. UPGRADING CODEREADY STUDIO
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CHAPTER 5. UNINSTALLING CODEREADY STUDIO
The following section describes how to uninstall CodeReady Studio using Eclipse or the Installer.

Note that you can have multiple versions of CodeReady Studio installed on your system, provided you
have these versions located in different directories.

5.1. UNINSTALLING RED HAT CODEREADY STUDIO USING ECLIPSE

The following section describes how to uninstall CodeReady Studio installed with Eclipse Marketplace or
Update Site Zip.

Procedure

1. Start Eclipse IDE.

2. Click Help → Eclipse Marketplace

The Eclipse Marketplace window appears.

3. Navigate to the Installed section.
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4. Locate Red Hat CodeReady Studio.

5. Click the down arrow near the Change button.

6. Click Uninstall.
The Confirm Selected Features window appears.

7. Ensure that Red Hat CodeReady Studio is selected.
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8. Click Confirm.

9. Click Finish.
The Software Updates dialog box appears prompting you to restart Eclipse.

10. Click Restart Now.
Note that the changes do not take effect until you restart Eclipse.

5.2. UNINSTALLING CODEREADY STUDIO USING THE INSTALLER

The following section describes how to uninstall CodeReady Studio installed with the Installer.

Procedure

1. Ensure that CodeReady Studio is not running.

2. Navigate to the /Uninstaller directory:

$ cd /path-to/codereadystudio/Uninstaller

Replace path-to with the path to the CodeReady Studio /codereadystudio/Uninstaller
directory.

3. Start the Uninstaller:

$ java -jar uninstaller.jar

The IzPack Uninstaller dialog box appears.

4. Select the Force the deletion check box.
If the check box is not selected, some files will be left behind in the installation directory.

5. Click Uninstall.
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CHAPTER 6. REPORTING ISSUES
You can report errors by raising a ticket in JIRA. When creating a JIRA ticket, please create it against one
of the following projects: JBDS or JBIDE. Provide as much detail as possible in the JIRA ticket to help
the team debug the error. You can also attach the error log to the JIRA tickets to provide context for
the issue.
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