Red Hat CodeReady Studio 12.14

Installation Guide

Installing Red Hat CodeReady Studio
Installing Red Hat CodeReady Studio

Levi Valeeva
lvaleeva@redhat.com

Supriya Takkhi
sbharadw@redhat.com

Yana Hontyk
yhontyk@redhat.com
Abstract

This document describes the process of installing, upgrading, and uninstalling Red Hat CodeReady Studio.
# Table of Contents

CHAPTER 1. MINIMAL REQUIREMENTS ................................................................. 3

CHAPTER 2. INSTALLING OPENJDK ................................................................. 4
  2.1. INSTALLING OPENJDK 1.8.0 ON WINDOWS ........................................... 4
  2.2. INSTALLING OPENJDK ON RHEL ......................................................... 4
      2.2.1. Installing OpenJDK 1.8.0 on RHEL .................................................. 4
      2.2.2. Installing OpenJDK 11 on RHEL ...................................................... 4
      2.2.3. Additional resources ................................................................. 5

CHAPTER 3. INSTALLING CODEREADY STUDIO .............................................. 6
  3.1. INSTALLING CODEREADY STUDIO IN ECLIPSE .................................. 6
      3.1.1. Installing CodeReady Studio in Eclipse when online ....................... 6
      3.1.2. Installing CodeReady Studio in Eclipse when offline ..................... 6
  3.2. INSTALLING CODEREADY STUDIO STAND-ALONE USING THE INSTALLER ... 7
  3.3. PERFORMING ADVANCED INSTALLATION TASKS .................................... 8
      3.3.1. Installing CodeReady Studio using a script ................................... 8
      3.3.2. Building the CodeReady Studio stand-alone Installer from source .... 9

CHAPTER 4. UPGRADING CODEREADY STUDIO ............................................. 10
  4.1. UPGRADING MAJOR VERSIONS OF CODEREADY STUDIO ....................... 10
  4.2. UPDATING MINOR VERSIONS OF RED HAT CODEREADY STUDIO ................ 10

CHAPTER 5. UNINSTALLING CODEREADY STUDIO .......................................... 12
  5.1. UNINSTALLING RED HAT CODEREADY STUDIO USING ECLIPSE ............... 12
  5.2. UNINSTALLING CODEREADY STUDIO USING THE INSTALLER ................... 12

CHAPTER 6. REPORTING ISSUES FROM WITHIN RED HAT CODEREADY STUDIO .. 14
CHAPTER 1. MINIMAL REQUIREMENTS

CodeReady Studio 12.14 is compatible with a range of operating systems, architectures, and Java Development Kit combinations. For a complete list, see Supported Configurations and Components.

Hardware requirements

- 2 GB RAM
  - 4 GB RAM is strongly recommended.
- 2 GB hard disk space

Software requirements

- Installed OpenJDK.
  - Red Hat OpenJDK is strongly recommended.

NOTE

On Windows, to make CodeReady Studio instance available to all users install it in a folder accessible to all users (C:\codereadystudio). If the main installation folder is not writable by a given user, any newly installed features and updates get saved inside the home directory of the user.
CHAPTER 2. INSTALLING OPENJDK

The following section describes how to install OpenJDK on Microsoft Windows and Red Hat Enterprise Linux (RHEL).

2.1. INSTALLING OPENJDK 1.8.0 ON WINDOWS

The following section describes how to install OpenJDK 1.8.0 on Windows using the MSI-based installer.

Procedure

2. Run the installer and follow the on-screen installation instructions.
3. Configure CodeReady Studio to use OpenJDK by following the instructions at Working with JREs.

2.2. INSTALLING OPENJDK ON RHEL

The following section describes how to install OpenJDK 1.8.0 and OpenJDK 11 on RHEL.

Prerequisites

- Root access.
- Registered system with attached subscriptions. See Registering the system and managing subscriptions for more details.

2.2.1. Installing OpenJDK 1.8.0 on RHEL

The following section describes how to install OpenJDK 1.8.0 on RHEL.

Procedure

- To install OpenJDK RPMs, use:

  # yum install java-1.8.0-openjdk-devel

Optionally, you can install the java-1.8.0-openjdk-src and the java-1.8.0-openjdk-demo packages. The java-1.8.0-openjdk-src package contains the complete OpenJDK 8 class library source code you can use with IDE indexers and debuggers. The java-1.8.0-openjdk-demo package contains Java runtimes for OpenJDK (demos and examples).

- To install java-1.8.0-openjdk-demo and java-1.8.0-openjdk-src, use:

  # yum install java-1.8.0-openjdk-src java-1.8.0-openjdk-demo

2.2.2. Installing OpenJDK 11 on RHEL

The following section describes how to install OpenJDK 11 on RHEL.
Procedure

- To install OpenJDK RPMs, use:
  
  ```bash
  # yum install java-11-openjdk-devel
  ```

Optionally, you can install the `java-11-openjdk-src` and the `java-11-openjdk-demo` packages. The `java-11-openjdk-src` package contains the complete OpenJDK 8 class library source code you can use with IDE indexers and debuggers. The `java-11-openjdk-demo` package contains Java runtimes for OpenJDK (demos and examples).

- To install `java-11-openjdk-demo` and `java-11-openjdk-src`, use:

  ```bash
  # yum install java-11-openjdk-src java-11-openjdk-demo
  ```

### 2.2.3. Additional resources

- For more information on how to install, run, and switch between two parallel installed major OpenJDK versions on RHEL8, see [https://developers.redhat.com/blog/2018/12/10/install-java-rhel8/](https://developers.redhat.com/blog/2018/12/10/install-java-rhel8/).
CHAPTER 3. INSTALLING CODEREADY STUDIO

The following section describes how to install CodeReady Studio:

- In Eclipse.
- Using the Installer.
- Using a script.
- From source.

Note that you can have multiple versions of CodeReady Studio installed on your system with Installer or Eclipse, provided you have these versions located in different directories.

3.1. INSTALLING CODEREADY STUDIO IN ECLIPSE

CodeReady Studio for Eclipse packages the CodeReady Studio plug-ins for your existing Eclipse instance. You can install CodeReady Studio from the Eclipse Marketplace when you are online. This installation method is referred to as BYOE (Bring Your Own Eclipse). Alternatively, you can use the Update Site Zip to install CodeReady Studio when you are offline.

The following section describes how to install CodeReady Studio when you are online and when you are offline.

3.1.1. Installing CodeReady Studio in Eclipse when online

The following section describes how to install CodeReady Studio BYOE from Eclipse Marketplace.

Procedure

2. Click Help → Eclipse Marketplace
3. Locate Red Hat CodeReady Studio 12.14 GA
4. Click Install.

IMPORTANT

When prompted to select additional features to install, select the Fuse Tooling feature for creating, testing and debugging integration applications.

5. Follow the on-screen instructions to complete the installation process.
   If you receive warnings about installing unsigned content, review the details of the content and, if satisfied, click OK to continue with the installation.
6. Restart Eclipse.
   Note that the changes do not take effect until you restart Eclipse.

3.1.2. Installing CodeReady Studio in Eclipse when offline
The following section describes how to install CodeReady Studio with the Update Site Zip. Alternatively, you can also use an Installer downloaded on your system instead of the Update Site Zip.

Note that the Target Platform Zip contains the features on which CodeReady Studio depends. It also contains the sources of all the included plug-ins.

Prerequisites


Procedure


2. Click Help → Install New Software
   The Available software window appears.

3. Click Add → Archive to locate the Update Site Zip file.

4. Click Add.

5. Check the Red Hat CodeReady Studio - Bring Your Own Eclipse and Red Hat Fuse Tooling check boxes.

6. Click Next.

7. Follow the on-screen instructions to complete the installation process.
   If you receive warnings about installing unsigned content, review the details of the content and, if satisfied, click OK to continue with the installation.

8. Restart Eclipse.
   Note that the changes do not take effect until you restart Eclipse.

3.2. INSTALLING CODEREADY STUDIO STAND-ALONE USING THE INSTALLER

The Installer contains CodeReady Studio stand-alone that packages the CodeReady Studio plug-ins with Eclipse and dependent third-party plug-ins. The Installer is compatible with all operating systems and is available from a variety of sources, including the Red Hat Customer Portal.

The following section describes how to install CodeReady Studio stand-alone.

Procedure


2. Go to the directory that contains the .jar file for the Red Hat CodeReady Studio 12.14 Stand-alone Installer.
   Review the contents of the .jar file. If satisfied, continue with the installation.

3. Start the installer:

   $ java -jar codereadystudio-12.14.0.GA-installer-standalone.jar
4. Follow the on-screen instructions to complete the installation process.

**IMPORTANT**

When prompted to select additional features to install, select the *Fuse Tooling* feature for creating, testing and debugging integration applications.

### 3.3. PERFORMING ADVANCED INSTALLATION TASKS

The following section describes how to:

- Install CodeReady Studio using a script.
- Build the Red Hat CodeReady Studio Installer from the source code.

#### 3.3.1. Installing CodeReady Studio using a script

The following section describes how to install CodeReady Studio using a script.

**Procedure**


2. Go to the directory that contains `.jar` file for the *Red Hat CodeReady Studio 12.14 Stand-alone Installer*.
   Review the contents of the `.jar` file. If satisfied, continue with the installation.

3. Start the installer:

   ```
   $ java -jar codereadystudio-12.14.0.GA-installer-standalone.jar
   ```

4. Follow the on-screen instructions to complete the installation process.

**IMPORTANT**

When prompted to select additional features to install, select the *Fuse Tooling* feature for creating, testing and debugging integration applications.

After the installation is complete, an `InstallConfigRecord.xml` file is generated in the CodeReady Studio installation directory.

5. In a terminal window, use:

   ```
   $ java -jar codereadystudio-12.14.0.GA-installer-standalone.jar /path-to/InstallConfigRecord.xml
   ```

   Replace *path-to* with the path to the `InstallConfigRecord.xml` file.
NOTE
The generated `InstallConfigRecord.xml` file is machine-specific and uses the Java Development Kit (JDK) and installation paths of your system. To use the `InstallConfigRecord.xml` file for other operating systems, JDKs, or paths, you must manually modify the file.

3.3.2. Building the CodeReady Studio stand-alone Installer from source

The following section describes how to build the CodeReady Studio stand-alone Installer from source.

Prerequisites
- Maven 3.3 or later with Java 8 must be installed. To obtain and configure Maven, see [http://maven.apache.org/](http://maven.apache.org/).

Procedure
1. Clone the git repository:

   ```
   $ git clone https://github.com/jbdevstudio/jbdevstudio-product.git
   ```

2. Navigate to the `jbdevstudio-product` directory:

   ```
   $ cd jbdevstudio-product
   ```

3. Checkout into `master`:

   ```
   $ git checkout master
   ```

4. Follow the instructions in the `README.adoc` file.
   Note that building the CodeReady Studio stand-alone Installer takes some time.

When the build is complete, the `.jar` file for the CodeReady Studio stand-alone Installer is located in the `/jbdevstudio-product/installer/target` directory.
CHAPTER 4. UPGRADING CODEREADY STUDIO

The following section describes the possibilities of upgrading your version of CodeReady Studio to the latest major and minor versions.

4.1. UPGRADING MAJOR VERSIONS OF CODEREADY STUDIO

Each major version of CodeReady Studio is based on a different version of Eclipse. As a result, it is not possible to upgrade an older major version of CodeReady Studio to a newer major version. For example, it is not possible to update a CodeReady Studio 10.x installation to 11.x. However, it is possible to use the workspaces created using CodeReady Studio 11.x with CodeReady Studio 12.x.

Note that you can have multiple versions of CodeReady Studio installed on your system with Installer or Eclipse, provided you have these versions located in different directories.

The following table details the version of Eclipse supported with each major version of Red Hat CodeReady Studio:

Table 4.1. Eclipse Version Support Matrix

<table>
<thead>
<tr>
<th>Red Hat CodeReady Studio Version</th>
<th>Base Eclipse Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>CodeReady Studio 12.14</td>
<td>Eclipse IDE 2019-12</td>
</tr>
<tr>
<td>CodeReady Studio 12.13</td>
<td>Eclipse IDE 2019-09</td>
</tr>
<tr>
<td>CodeReady Studio 12.11</td>
<td>Eclipse SimRel 2019-03 GA</td>
</tr>
<tr>
<td>CodeReady Studio 12.9</td>
<td>Eclipse SimRel 2018-09 GA</td>
</tr>
<tr>
<td>CodeReady Studio 12.0</td>
<td>Eclipse 4.8 (Photon)</td>
</tr>
<tr>
<td>CodeReady Studio 11.x</td>
<td>Eclipse 4.7 (Oxygen)</td>
</tr>
<tr>
<td>Red Hat CodeReady Studio 10.x</td>
<td>Eclipse 4.6 (Neon)</td>
</tr>
<tr>
<td>Red Hat CodeReady Studio 9.x</td>
<td>Eclipse 4.5 (Mars)</td>
</tr>
</tbody>
</table>

4.2. UPDATING MINOR VERSIONS OF RED HAT CODEREADY STUDIO

You can update your Red Hat CodeReady Studio to the latest minor versions within the major release. For example, you can update your Red Hat CodeReady Studio 12.0 installation to 12.9.

You may be automatically notified by the IDE when the latest Red Hat CodeReady Studio update is available, depending on your IDE settings for automatic updates.
IMPORTANT

Back up your workspace before updating. In addition to your project files, your workspace contains metadata about customized settings and preferences for the IDE. To back up your workspace, either copy the workspace directory to a backup location, or save it as a compressed file.

Procedure

2. Click Window → Preferences.
4. Ensure that the URL https://devstudio.redhat.com/12/stable/updates/ is listed in enabled locations. If it is not listed, add it.
5. Click the Apply and Close button.
6. Click Help → Check for Updates
   Note that the search for updates might take some time.

   If you receive warnings about installing unsigned content, review the details of the content and, if satisfied, click OK to continue with the installation.

7. Follow the on-screen instructions to apply available updates.
8. Restart Eclipse.
   Note that the changes do not take effect until you restart Eclipse.
CHAPTER 5. UNINSTALLING CODEREADY STUDIO

The following section describes how to uninstall CodeReady Studio using Eclipse or the Installer.

Note that you can have multiple versions of CodeReady Studio installed on your system, provided you have these versions located in different directories.

5.1. UNINSTALLING RED HAT CODEREADY STUDIO USING ECLIPSE

The following section describes how to uninstall CodeReady Studio installed with Eclipse Marketplace or Update Site Zip.

Procedure

2. Click Help → Eclipse Marketplace
3. Navigate to the Installed section.
5. Click the down arrow near the Change button.
   The drop-down menu appears.
6. Click Uninstall.
   The Confirm Selected Features window appears.
7. Ensure that Red Hat CodeReady Studio is selected.
8. Click Confirm → Finish.
   The Software Updates dialog box appears.
9. Click Yes to restart Eclipse.
   Note that the changes do not take effect until you restart Eclipse.

5.2. UNINSTALLING CODEREADY STUDIO USING THE INSTALLER

The following section describes how to uninstall the CodeReady Studio installed with the Installer.

Procedure

1. Ensure that CodeReady Studio is not running.
2. Navigate to the /Uninstaller directory:

   $ cd /path-to/Uninstaller
   
   Replace path-to with the path to the CodeReady Studio /Uninstaller directory.
3. Start the uninstaller:

   $ java -jar uninstaller.jar
The IzPack Uninstaller dialog box appears.

4. Check **Force the deletion** to remove the CodeReady Studio installation directory. If the check box is not selected, some files will be left behind in the installation directory.

5. Click **Uninstall**.
CHAPTER 6. REPORTING ISSUES FROM WITHIN RED HAT CODEREADY STUDIO

You can report errors by raising a ticket in JIRA. When creating a JIRA ticket, please create it against one of the following projects JBDS or JBIDE. Provide as much detail as possible in the JIRA ticket to help the team debug the error. You can also attach the error log to the JIRA tickets to provide context for the issue.