Red Hat CodeReady Studio 12.13

Installation Guide

Installing Red Hat CodeReady Studio
Installing Red Hat CodeReady Studio

Supriya Takkhi
sbharadw@redhat.com

Yana Hontyk
yhontyk@redhat.com
Legal Notice

Copyright © 2019 Red Hat, Inc.

The text of and illustrations in this document are licensed by Red Hat under a Creative Commons Attribution–Share Alike 3.0 Unported license ("CC-BY-SA"). An explanation of CC-BY-SA is available at http://creativecommons.org/licenses/by-sa/3.0/. In accordance with CC-BY-SA, if you distribute this document or an adaptation of it, you must provide the URL for the original version.

Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert, Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.

Red Hat, Red Hat Enterprise Linux, the Shadowman logo, the Red Hat logo, JBoss, OpenShift, Fedora, the Infinity logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States and other countries.

Linux ® is the registered trademark of Linus Torvalds in the United States and other countries.

Java ® is a registered trademark of Oracle and/or its affiliates.

XFS ® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States and/or other countries.

MySQL ® is a registered trademark of MySQL AB in the United States, the European Union and other countries.

Node.js ® is an official trademark of Joyent. Red Hat is not formally related to or endorsed by the official Joyent Node.js open source or commercial project.

The OpenStack ® Word Mark and OpenStack logo are either registered trademarks/service marks or trademarks/service marks of the OpenStack Foundation, in the United States and other countries and are used with the OpenStack Foundation’s permission. We are not affiliated with, endorsed or sponsored by the OpenStack Foundation, or the OpenStack community.

All other trademarks are the property of their respective owners.

Abstract

Information for users installing Red Hat CodeReady Studio. This guide describes all prerequisites for a successful installation of the product followed by a number of installation methods, including how to use your existing installation of Eclipse.
Table of Contents

PART I. INSTALLATION GUIDE FOR CODEREADY STUDIO .................................................. 3
  INSTALLING OPENJDK 1.8.0 ON WINDOWS  .............................................................. 3
  INSTALLING OPENJDK 1.8.0 ON RHEL  ....................................................................... 3

CHAPTER 1. INSTALLING CODEREADY STUDIO IN ECLIPSE ........................................ 5
  1.1. INSTALLING CODEREADY STUDIO IN ECLIPSE WHEN ONLINE ............................... 5
  1.2. INSTALLING CODEREADY STUDIO IN ECLIPSE WHEN OFFLINE ............................. 5

CHAPTER 2. INSTALLING CODEREADY STUDIO STAND-ALONE USING THE INSTALLER .......... 7

CHAPTER 3. PERFORMING ADVANCED INSTALLATION TASKS ........................................ 8
  3.1. INSTALLING RED HAT CODEREADY STUDIO USING A SCRIPT ............................. 8
  3.2. BUILDING THE CODEREADY STUDIO STAND-ALONE INSTALLER FROM SOURCE ...... 8

CHAPTER 4. UNINSTALLING CODEREADY STUDIO ....................................................... 10
  4.1. UNINSTALLING CODEREADY STUDIO INSTALLED USING THE INSTALLER ............... 10
  4.2. UNINSTALLING RED HAT CODEREADY STUDIO INSTALLED IN ECLIPSE .................. 11

CHAPTER 5. UPGRADING CODEREADY STUDIO .......................................................... 13
  5.1. UPGRADING MAJOR VERSIONS OF CODEREADY STUDIO ................................. 13
  5.2. UPDATING MINOR VERSIONS OF RED HAT CODEREADY STUDIO .......................... 13

CHAPTER 6. REPORTING ISSUES FROM WITHIN RED HAT CODEREADY STUDIO ............... 15
PART I. INSTALLATION GUIDE FOR CODEREADY STUDIO

This guide details steps to install, uninstall, and upgrade CodeReady Studio that you may have installed using different methods.

Prerequisites

CodeReady Studio 12.13 is supported for use with a range of operating systems, architectures, and Java Development Kit combinations; for a complete list, see Supported Configurations and Components on the Red Hat Customer Portal.

NOTE

If you install CodeReady Studio on Windows in a folder accessible to all the users (example: C:\codereadystudio), this CodeReady Studio instance can be used by all the users. However, if the main installation folder is not writable by a given user, any newly installed feature and update gets saved inside the user’s home directory.

Minimum hardware requirements

1. 4 GB RAM (minimum 2 GB RAM)
2. 2 GB hard disk space

Software requirements

1. Install OpenJDK. Red Hat OpenJDK is recommended.

INSTALLING OPENJDK 1.8.0 ON WINDOWS

To install OpenJDK 1.8.0 on Windows using the MSI-based installer:

2. Run the installer and follow the on-screen instructions to install.
3. To configure CodeReady Studio to use OpenJDK, follow the instructions at Working with JREs.

INSTALLING OPENJDK 1.8.0 ON RHEL

To install OpenJDK 1.8.0 on Red Hat Enterprise Linux:

NOTE

All the commands in the following procedure must be run as the root user.

1. Register and subscribe the system by running the following command:
   
   ```bash
   # subscription-manager register
   ```

2. When prompted, enter your Red Hat Customer Portal username and password.

3. To find a suitable subscription, such as Developer Subscription, run the following command:
   
   ```bash
   # subscription-manager list --available
   ```
This command lists the available subscriptions and details of the subscriptions. Note down the pool ID of the appropriate subscription.

4. To attach a subscription to your system, run the following command:

```
# subscription-manager attach --pool=<pool ID from previous command>
```

5. To install OpenJDK RPMs:

```
# yum install java-1.8.0-openjdk-devel
```

**NOTE**

Install the `java-1.8.0-openjdk-demo` package for examples of Java applications and the `java-1.8.0-openjdk-src` package to debug your applications. Both packages are available from the `Optional` repository. Use the following command to enable that repository on your system:

```
# subscription-manager repos --enable=rhel-7-server-optional-rpms
```

Use the following command to install the packages:

```
# yum install java-1.8.0-openjdk-src java-1.8.0-openjdk-demo
```
CHAPTER 1. INSTALLING CODEREADY STUDIO IN ECLIPSE

CodeReady Studio for Eclipse packages the CodeReady Studio plug-ins for your existing Eclipse instance. You can either install CodeReady Studio from the Eclipse Marketplace when you are online or use the Update Site Zip to install it when you are offline. Installing CodeReady Studio from the Eclipse Marketplace is referred to as BYOE (Bring Your Own Eclipse).

1.1. INSTALLING CODEREADY STUDIO IN ECLIPSE WHEN ONLINE

CodeReady Studio BYOE is available to install from Eclipse Marketplace when you are online.

IMPORTANT

If anytime before or during the installation, you are asked about selecting additional features to install, you may select Fuse Tooling to use the Fuse tooling features after the installation is complete.

Procedure

To install CodeReady Studio BYOE from Eclipse Marketplace, take the following steps:

1. Start Eclipse SimRel 2018-09 GA.


3. Follow the on-screen instructions to complete the installation process.

During the installation process, if you receive warnings about installing unsigned content, review the details of the content and if satisfied, click OK to continue with the installation.

After the installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately and No if you need to save any unsaved changes to open projects. Note that the IDE changes do not take effect until Eclipse is restarted.

1.2. INSTALLING CODEREADY STUDIO IN ECLIPSE WHEN OFFLINE

You need the Update Site Zip to install CodeReady Studio in Eclipse in the offline mode. Alternatively, you can also use an installer downloaded on your system instead of the Update Site Zip to install CodeReady Studio in Eclipse when Offline. Note that the Target Platform Zip contains the features on which CodeReady Studio depends. It also contains the sources of all the included plugins. You can download the Target Platform Zip from https://devstudio.redhat.com/12/stable/updates/.

IMPORTANT

- You must first be online to download the .zip file before proceeding to install CodeReady Studio in Eclipse in the offline mode.

- If anytime before or during the installation, you are asked about selecting additional features to install, you may select Fuse Tooling to use the Fuse tooling features after the installation is complete.

Procedure
To install CodeReady Studio in Eclipse in offline mode, take the following steps:


2. Start Eclipse SimRel 2018-09 GA.

3. Click Help > Install New Software.

4. In the Work with field, enter the path of the Update Site Zip file. Alternatively, click Add and click Archive to locate the file.

5. From the table of components, select Red Hat CodeReady Studio 12 - Bring Your Own Eclipse and click Next.

6. Follow the on-screen instructions to complete the installation process.

During the installation process, you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied, click OK to continue with the installation.

After the installation is complete, you are prompted to restart Eclipse. Click Yes to restart immediately and No to save any unsaved changes to open projects. Note that the IDE changes do not take effect until Eclipse is restarted.
CHAPTER 2. INSTALLING CODEREADY STUDIO STAND-ALONE USING THE INSTALLER

CodeReady Studio stand-alone packages the CodeReady Studio plug-ins with Eclipse and dependent third-party plug-ins in an installer for all operating systems.

The installer provided to install CodeReady Studio stand-alone is available from a variety of sources, including the Red Hat Customer Portal.

**IMPORTANT**

If anytime before or during the installation, you are asked about selecting additional features to install, you may select Fuse Tooling to use the Fuse tooling features after the installation is complete.

**Procedure**

To install CodeReady Studio stand-alone, take the following steps:

1. Download **Red Hat CodeReady Studio 12.13 Stand-alone Installer** from **CodeReady Studio Software Downloads**.

2. Start the installer:

   ```
   $ cd /path/to/.jar
   $ java -jar codereadystudio-12.13.0.GA-installer-standalone.jar
   ```

   Alternatively, you can start the installer by double-clicking the `.jar` file. On OS X systems, hold control and click the `.jar` file, click **Open**, review the `.jar` file details and if satisfied, click **Open**.

3. Follow the on-screen instructions to complete the installation process.
CHAPTER 3. PERFORMING ADVANCED INSTALLATION TASKS

This section describes steps to install CodeReady Studio using a script and to build the Red Hat CodeReady Studio installer from the source code.

3.1. INSTALLING RED HAT CODEREADY STUDIO USING A SCRIPT

Use the scripted method to install CodeReady Studio stand-alone using the GUI once and then a generated script for subsequent installations. This installation method enables simplified repeat installations or installations in bulk without stepping through the installer GUI for every installation.

The CodeReady Studio stand-alone installer is available from a variety of sources, including the Red Hat Customer Portal.

Procedure

To install CodeReady Studio by script, take the following steps:


2. Start the installer:

   $ cd /path/to/.jar
   $ java -jar codereadystudio-12.13.0.GA-installer-standalone.jar

3. Follow the on-screen instructions to complete the installation process. After the installation is complete, an InstallConfigRecord.xml file is generated in the CodeReady Studio installation directory.

4. In the terminal window, enter the following command:

   $ java -jar codereadystudio-12.13.0.GA-installer-standalone.jar \
   /path/to/codereadystudio/InstallConfigRecord.xml

NOTE

The generated InstallConfigRecord.xml file is machine-specific and uses the Java Developer Kit and installation paths of your system. To use the InstallConfigRecord.xml file for other operating systems, Java Developer Kits, or paths, you must manually modify the file.

3.2. BUILDING THE CODEREADY STUDIO STAND-ALONE INSTALLER FROM SOURCE

Prerequisites

- Maven 3.3 or later, with Java 8 must be installed to build the installer from the source code. To obtain and configure Maven, see http://maven.apache.org/.

Procedure
To build the CodeReady Studio stand-alone installer from source, take the following steps:

1. Clone the git repository by running the command:

   
   ```
   $ git clone https://github.com/jbdevstudio/jbdevstudio-product.git
   
   ```

2. Checkout the master branch by running the command:

   
   ```
   $ git checkout master
   
   ```

3. Build the installer by following the instructions in the `jbdevstudio-product/README.adoc` file.

   **NOTE**

   The `jbdevstudio-product/README.adoc` file is located in the extracted current folder at the highest level.

Building takes some time to complete, after which the `devstudio-[version]-installer-standalone.jar` file will be located in the `/path/to/jbdevstudio-product/installer/target` directory.
CHAPTER 4. UNINSTALLING CODEREADY STUDIO

You may want to uninstall a specific version of CodeReady Studio if you have concluded development in one version, say 11.x, and you now want to install a newer version, say 12.x. However, you can have more than one version of Installer-installed CodeReady Studio or Eclipse-installed CodeReady Studio on your system, provided you have these versions located in different directories.

4.1. UNINSTALLING CODEREADY STUDIO INSTALLED USING THE INSTALLER

Procedure

To uninstall CodeReady Studio, take the following steps:

1. Ensure that CodeReady Studio is not running.

2. On the command line, navigate to `path/to/CodeReady Studio/Uninstaller`.

3. On the command line, type:

   ```
   $ java -jar uninstaller.jar
   ```

4. In the IzPack Uninstaller dialog box:

   a. Click the Force the deletion of `<path_to_CodeReady Studio_directory>` check box, to remove the entire CodeReady Studio installation directory. If this is not selected, Red Hat CodeReady Studio will be uninstalled but some files will be left as is in the installation directory.

   b. Click Uninstall.

5. After the progress bar shows Finished, click Quit to close the Uninstaller dialog box.

Figure 4.1. Uninstall CodeReady Studio
4.2. UNINSTALLING RED HAT CODEREADY STUDIO INSTALLED IN ECLIPSE

Procedure

CodeReady Studio can be uninstalled using the following steps regardless of whether it was installed via Eclipse Marketplace or the update .zip file.

To uninstall CodeReady Studio, take the following steps:

1. Start Eclipse SimRel 2018-09 GA.
2. Click Help > Eclipse Marketplace.
3. In the Eclipse Marketplace window, Find field, type Red Hat CodeReady Studio and then click Go.
5. Click the Update drop-down list to view the options available. Click Uninstall.

Figure 4.2. Uninstall Button

6. In the Confirm Selected Features window, ensure that Red Hat CodeReady Studio<version> is selected and click Confirm.
7. Click Finish.
8. In the **Software Updates** dialog box, click **Yes** to restart Eclipse for the changes to take effect.
CHAPTER 5. UPGRADING CODEREADY STUDIO

Depending on your need, refer to the respective sections to upgrade CodeReady Studio.

5.1. UPGRADING MAJOR VERSIONS OF CODEREADY STUDIO

Each major version of CodeReady Studio is based on a different version of Eclipse. As a result, it is not possible to update an older major version of CodeReady Studio to a newer major version. For example, it is not possible to update a CodeReady Studio 10.x installation to 11.x, nor is it possible to update a 11.x installation to 12.x. However, it is possible to use the workspaces created using CodeReady Studio 11.x with CodeReady Studio 12.x.

The following table details the version of Eclipse supported with each major version of Red Hat CodeReady Studio:

Table 5.1. Eclipse Version Support Matrix

<table>
<thead>
<tr>
<th>Red Hat CodeReady Studio Version</th>
<th>Base Eclipse Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>CodeReady Studio 12.11</td>
<td>Eclipse SimRel 2019-03 GA</td>
</tr>
<tr>
<td>CodeReady Studio 12.9</td>
<td>Eclipse SimRel 2018-09 GA</td>
</tr>
<tr>
<td>CodeReady Studio 12.0</td>
<td>Eclipse 4.8 (Photon)</td>
</tr>
<tr>
<td>CodeReady Studio 11.x</td>
<td>Eclipse 4.7 (Oxygen)</td>
</tr>
<tr>
<td>Red Hat CodeReady Studio 10.x</td>
<td>Eclipse 4.6 (Neon)</td>
</tr>
<tr>
<td>Red Hat CodeReady Studio 9.x</td>
<td>Eclipse 4.5 (Mars)</td>
</tr>
</tbody>
</table>

5.2. UPDATING MINOR VERSIONS OF RED HAT CODEREADY STUDIO

You can update your Red Hat CodeReady Studio to the latest minor versions within the major release. For example, you can update your Red Hat CodeReady Studio 12.0 installation to 12.9.

IMPORTANT

Before updating, back up your workspace. In addition to your project files, your workspace contains metadata about customized settings and preferences for the IDE. To back up your workspace, either copy the workspace directory to a backup location, or save it as a compressed file.

You may be automatically notified by the IDE when the Red Hat CodeReady Studio 12.x update is available, depending on your IDE settings for automatic updates.

Procedure

Alternatively, use the following instructions to manually check for and apply the most recent Red Hat CodeReady Studio update:
1. In the IDE, click **Window > Preferences**, expand **Install/Update** and click **Available Software Sites**.

2. In the **Available Software Sites** table, ensure the URL
   https://devstudio.redhat.com/12/stable/updates/ is listed or, if not listed, add it.

3. Close the **Preferences** window.

4. Click **Help > Check for Updates**

5. For any Red Hat CodeReady Studio updates found, follow the on-screen instructions to apply the update.

During the update process, you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied click **OK** to continue with the update.

After updating is complete, you are prompted to restart the IDE. Click **Yes** to restart immediately or **No** to save any unsaved changes to open projects. Note that IDE changes do not take effect until the IDE is restarted.
You can report errors by raising a ticket in JIRA. You must enter as much detail as possible in the JIRA ticket to help the team debug the error. You can attach the error log to the JIRAs submitted against each problem to provide context for the issue.