Chapter 4. Supported Operating Systems and Java Development Kits

Note

As CodeReady Studio is based on Eclipse, the system requirements of Eclipse also apply to CodeReady Studio. For more information about Eclipse system requirements, see Eclipse SimRel 2019-06 GA, https://wiki.eclipse.org/SimRel/2019-06/Simultaneous_Release_Plan.

The operating systems, chip architectures, and Java Development Kits that are supported by the CodeReady Studio 12.13 release are as listed in the following table.

Operating SystemChip ArchitectureJava Development Kit

Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8

x86_64

OpenJDK 1.7[a], OpenJDK 1.8, OpenJDK 11[b], Oracle JDK 1.7[a], Oracle JDK 1.8, Oracle JDK 11[b]

Microsoft Windows 7, Microsoft Windows 8, and Microsoft Windows 10

x86_64

OpenJDK 1.8, OpenJDK 11[b], Oracle JDK 1.6[a], Oracle JDK 1.7[a], Oracle JDK 1.8, Oracle JDK 11[b]

macOS High Sierra (10.13) and macOS Mojave (10.14)

x86_64

Apple JDK 1.6[a], Oracle JDK 1.7[a], Oracle JDK 1.8, Oracle JDK 11[b]

Fedora 29 and 30

x86_64

OpenJDK 1.7[a], OpenJDK 1.8, OpenJDK 11[b], Oracle JDK 1.6[a], Oracle JDK 1.7[a], Oracle JDK 1.8, Oracle JDK 11[b]

Ubuntu 18.04 LTS and 19.04

x86_64

OpenJDK 1.6[a], OpenJDK 1.7[a], OpenJDK 1.8, OpenJDK 11[b], Oracle JDK 1.6[a], Oracle JDK 1.7[a], Oracle JDK 1.8, Oracle JDK 11[b]

[a] Java Development Kits 1.6, 1.7, and 9 are not supported for running CodeReady Studio; they are supported for application development and deployment only.
[b] There are known issues when running CodeReady Studio with Java Development Kit 11. For more information, see JBDS-4751.