Migrating to Red Hat CloudForms 4.5

Red Hat CloudForms 4.5

Upgrading your system from earlier versions of Red Hat CloudForms Management Engine

Red Hat CloudForms Documentation Team

Abstract

This document describes the process of migrating your Red Hat CloudForms 4.1 or 4.2 environment to Red Hat CloudForms 4.5 (CFME 5.8). It also describes methods for applying minor updates to your CloudForms 4.5 appliances.
If you have a suggestion for improving this guide or have found an error, please submit a Bugzilla report at http://bugzilla.redhat.com against Red Hat CloudForms Management Engine for the Documentation component. Please provide specific details, such as the section number, guide name, and CloudForms version so we can easily locate the content.

This document describes the process of migrating an older Red Hat CloudForms environment to Red Hat CloudForms 4.5 (CFME 5.8). Section 3, “Updating CloudForms” also provides instructions for applying minor updates (errata) to your CloudForms appliances.

You can migrate directly to Red Hat CloudForms 4.5 from the following versions:

  • Red Hat CloudForms 4.2 (CFME 5.7)
  • Red Hat CloudForms 4.1 (CFME 5.6)
Note

Migrating from Cloudforms 3.2 (CFME 5.4) directly to Red Hat CloudForms 4.5 (CFME 5.8) is not supported. You must first upgrade to Red Hat CloudForms 4.1 (CFME 5.6) to perform a migration to CloudForms 4.5.

See Migrating and Updating Red Hat CloudForms / Red Hat CloudForms Management Engine for articles on migrating to CloudForms versions prior to 4.5.

1. Migrating from CloudForms 4.2 (CFME 5.7) to CloudForms 4.5 (CFME 5.8)

1.1. Overview

This procedure describes the process of migrating your Red Hat CloudForms 4.2 (CFME 5.7) to Red Hat CloudForms 4.5 (CFME 5.8). This procedure does not necessarily include migration of all possible customer modifications, so it is recommended that you fully test any modifications before migrating your environment.

Important
  • Read through all of the steps in this procedure before beginning the migration process.
  • CloudForms 4.5 appliances require 12 GB memory, which is an increase from the 8 GB requirement in previous releases. Before migrating your appliances, adjust resources in your environment accordingly to avoid performance issues. See Migration Considerations in the Release Notes for more information.
  • The addition of default SSL authentication in CloudForms 4.5 for OpenShift Container Platform and Red Hat Virtualization providers may break existing connections to these providers after upgrading your environment. After migrating all appliances to CloudForms 4.5, edit any existing OpenShift Container Platform and Red Hat Virtualization providers to specify a security protocol and trusted certificate to use for connecting to the providers. See Managing Providers for configuration instructions.

You can classify the migration into three groups of appliances:

  • VMDB appliance - An appliance with workers running, which also hosts its own database that other appliances can also connect to.
  • Non-VMDB appliance - An appliance with workers running which does not host a database. The appliance is connected to an external database.
  • Dedicated database appliance - A CloudForms appliance or non-CloudForms virtual machine with no workers running on it: the appliance contains only a database for other appliances to connect to.

Migration Workflow Summary

In summary, the migration process from CFME 5.7 to CFME 5.8 follows this workflow:

Note

Appliances must be offline during migration; ensure you plan for downtime when migrating.

  1. Back up appliances (optional but recommended).
  2. Prepare appliances:

    1. Disable older CloudForms repositories and enable new repositories.
    2. Resize the disk space on the virtual machines hosting the appliances.
    3. Shut down evmserver on the master or global appliance.
  3. Migrate appliances:

    1. Update CFME packages on all appliances.
    2. Load the new version of the pglogical library on the VMDB and dedicated database appliances.
    3. Migrate the non-VMDB and VMDB appliance databases and update the Automate Model.
    4. Restart PostgreSQL on the VMDB and dedicated database appliances.
    5. Restart evmserver on the VMDB and non-VMDB appliances.
  4. Configure replication after the migration process is complete and appliances are running once again.

1.2. Backing Up Current Appliances

These steps will not affect the operations of your CloudForms infrastructure. However, they will help ensure that you are able to roll back if required and replicate the network settings.

  1. Back up the databases of your CFME 5.7 appliances. Take a snapshot if possible.
  2. Back up the following files for disaster recovery, noting which appliance each comes from:

    • /var/www/miq/vmdb/GUID
    • /var/www/miq/vmdb/REGION
  3. If you plan to reuse the hostnames and IP addresses, keep track of that information. You may need these after the CFME 5.8 appliances are created. This information is available on the summary screen of the appliance console.
  4. During the upgrade, the iptables configuration file (/etc/sysconfig/iptables) is removed. If you have changed the iptables configuration from the default (run iptables --list -n to see the current configuration), use the following command to back up the iptables configuration:

    # iptables-save > /etc/iptables.conf

    You can restore your iptables configuration file with the following command:

    # iptables-restore < /etc/iptables.conf

    Alternatively, add this command to /etc/rc.local to reload the rules at every reboot.

Note

For 5.7 appliances with the User Interface server role: Before migration, ensure that the Web Services role is enabled (it is enabled by default in CFME 5.7). If the Web Services role is disabled, it will not be turned on during the migration process. This role is required in CFME 5.8 to be able to log in to the user interface.

1.3. Preparing the Appliances for Migration

On all appliances:

  1. Disable the CloudForms 4.2 (CFME 5.7) repositories:

    # subscription-manager repos --disable=cf-me-5.7-for-rhel-7-rpms
    Note

    See Enabling Supplementary and Optional Repositories in Using and Configuring Red Hat Subscription Manager for more information.

  2. Enable the CloudForms 4.5 (CFME 5.8) repositories:

    # subscription-manager repos --enable=rhel-7-server-rpms \
    --enable=cf-me-5.8-for-rhel-7-rpms \
    --enable=rhel-7-server-optional-rpms \
    --enable=rhel-7-server-supplementary-rpms \
    --enable=rhel-server-rhscl-7-rpms

1.4. Resizing the Disk Space

CloudForms 4.5 requires more disk space than previous CloudForms versions because of the addition of built-in Ansible features. Before migrating your appliances to CloudForms 4.5, resize the virtual machine partition hosting the appliances to ensure sufficient space is available for the appliance.

Complete the following steps to resize the disk space, replacing filenames as needed:

  1. Install the xfsdump tool for backing up filesystems:

    # yum -y install xfsdump
  2. Back up the partition’s existing filesystem, /repo, to a temporary repository, /tmp/repo:

    # xfsdump -F -f /tmp/repo /repo
  3. Unmount the existing filesystem:

    # umount /repo
  4. Remove the logical volume:

    # lvremove -f /dev/VG-CFME/lv_repo
  5. Create a new 1GB logical volume in the existing volume group lv_repo:

    # lvcreate --yes -L 1GB -n lv_repo VG-CFME
  6. Construct the volume path:

    # mkfs.xfs /dev/VG-CFME/lv_repo
  7. Mount the volume to /repo:

    # mount /dev/VG-CFME/lv_repo /repo
  8. Restore the /tmp/repo filesystem data to the old filesystem:

    # xfsrestore -f /tmp/repo /repo
  9. Resize the volume to allow sufficient space for the CloudForms 4.5 appliance:

    # lvextend --resizefs --size +9GB /dev/VG-CFME/lv_var

1.5. Migrating from CFME 5.7 to 5.8

Perform the following steps on your CloudForms VMDB, non-VMDB and dedicated database appliances to migrate to CFME 5.8.

Note

Some steps are run on only certain appliances. Ensure you wait for each command to finish before going to the next step.

  1. Connect to the appliance using SSH.
  2. On the VMDB and non-VMDB appliances, stop the evmserver process:

    [root@VMDB]# systemctl stop evmserverd
    [root@non-VMDB]# systemctl stop evmserverd
  3. Update packages on all appliances:

    [root@VMDB]# yum update
    [root@non-VMDB]# yum update
    [root@dedicatedDB]# yum update
  4. On the VMDB and dedicated database appliances, restart the server to load the new version of the pglogical library:

    [root@VMDB]# systemctl restart $APPLIANCE_PG_SERVICE
    [root@dedicatedDB]# systemctl restart $APPLIANCE_PG_SERVICE
  5. On the VMDB and non-VMDB appliances, change to the vmdb directory:

    [root@VMDB]# cd /var/www/miq/vmdb/
    [root@non-VMDB]# cd /var/www/miq/vmdb/
  6. On the VMDB and non-VMDB appliances, run the below command appropriate to your environment to migrate everything in the database to work with the latest 5.8 configuration:

    1. In a single (standalone database) or replicated environment, run this command on each VMDB appliance:

      [root@VMDB]# rake db:migrate
    2. In a dedicated database or highly available environment, run this command on a single non-VMDB appliance pointed at that environment:

      [root@non-VMDB]# rake db:migrate
  7. On the VMDB and non-VMDB appliances, update the Automate Model to the latest version. This resets the ManageIQ and Red Hat domains (base domains) to a new and upgraded version. Run the command appropriate to your environment to update the Automate Model:

    1. In a single (standalone database) or replicated environment, run this command on each VMDB appliance:

      [root@VMDB]# rake evm:automate:reset
    2. In a dedicated database or highly available environment, run this command on a single non-VMDB appliance pointed at that environment:

      [root@non-VMDB]# rake evm:automate:reset
  8. On the VMDB and dedicated database appliances, restart PostgreSQL:

    [root@VMDB]# systemctl restart rh-postgresql95-postgresql
    [root@dedicatedDB]# systemctl restart rh-postgresql95-postgresql
  9. On the VMDB and non-VMDB appliances, start the evmserver process:

    [root@VMDB]# systemctl start evmserverd
    [root@non-VMDB]# systemctl start evmserverd

2. Migrating from CloudForms 4.1 (CFME 5.6) to CloudForms 4.5 (CFME 5.8)

2.1. Overview

This procedure describes the process of migrating your Red Hat CloudForms 4.1 (CFME 5.6) to Red Hat CloudForms 4.5 (CFME 5.8). This procedure does not necessarily include migration of all possible customer modifications, so it is recommended that you fully test any modifications before migrating your environment.

Important
  • Read through all of the steps in this procedure before beginning the migration process.
  • CloudForms 4.5 appliances require 12 GB memory, which is an increase from the 8 GB requirement in previous releases. Before migrating your appliances, adjust resources in your environment accordingly to avoid performance issues. See Migration Considerations in the Release Notes for more information.
  • The addition of default SSL authentication in CloudForms 4.5 for OpenShift Container Platform and Red Hat Virtualization providers may break existing connections to these providers after upgrading your environment. After migrating all appliances to CloudForms 4.5, edit any existing OpenShift Container Platform and Red Hat Virtualization providers to specify a security protocol and trusted certificate to use for connecting to the providers. See Managing Providers for configuration instructions.

You can classify the migration into three groups of appliances:

  • VMDB appliance - An appliance with workers running, which also hosts its own database that other appliances can also connect to.
  • Non-VMDB appliance - An appliance with workers running which does not host a database. The appliance is connected to an external database.
  • Dedicated database appliance - A CloudForms appliance or non-CloudForms virtual machine with no workers running on it: the appliance contains only a database for other appliances to connect to.

Migration Workflow Summary

In summary, the migration process from CFME 5.6 to CFME 5.8 follows this workflow:

Note

Appliances must be offline during migration; ensure you plan for downtime when migrating.

  1. Back up appliances (optional but recommended).
  2. Prepare appliances:

    1. Disable older CloudForms repositories and enable new repositories.
    2. On subordinate appliances, stop database synchronization and shut down the evmserver process.
    3. Resize the disk space on the virtual machines hosting the appliances.
    4. Remove any existing rubyrep configuration.
    5. Shut down evmserver on the master or global appliance.
  3. Migrate appliances:

    1. Update CFME packages on all appliances.
    2. Load the new version of the pglogical library on the VMDB and dedicated database appliances.
    3. Migrate the non-VMDB and VMDB appliance databases and update the Automate Model.
    4. Restart PostgreSQL on the VMDB and dedicated database appliances.
    5. Restart evmserver on the VMDB and non-VMDB appliances.
  4. Configure replication after the migration process is complete and appliances are running once again.

2.2. Backing Up Current Appliances

These steps will not affect the operations of your CloudForms infrastructure. However, they will help ensure that you are able to roll back if required and replicate the network settings.

  1. Back up the databases of your CFME 5.6 appliances. Take a snapshot if possible.
  2. Back up the following files for disaster recovery, noting which appliance each comes from:

    • /var/www/miq/vmdb/GUID
    • /var/www/miq/vmdb/REGION
  3. If you plan to reuse the hostnames and IP addresses, keep track of that information. You may need these after the CFME 5.8 appliances are created. This information is available on the summary screen of the appliance console.
  4. During the upgrade, the iptables configuration file (/etc/sysconfig/iptables) is removed. If you have changed the iptables configuration from the default (run iptables --list -n to see the current configuration), use the following command to back up the iptables configuration:

    # iptables-save > /etc/iptables.conf

    You can restore your iptables configuration file with the following command:

    # iptables-restore < /etc/iptables.conf

    Alternatively, add this command to /etc/rc.local to reload the rules at every reboot.

Note

For 5.6 appliances with the User Interface server role: Before migration, ensure that the Web Services role is enabled (it is enabled by default in CFME 5.7). If the Web Services role is disabled, it will not be turned on during the migration process. This role is required in CFME 5.8 to be able to log in to the user interface.

2.3. Preparing the Appliances for Migration

On all appliances:

  1. Disable the CloudForms 4.1 (CFME 5.6) repositories:

    # subscription-manager repos --disable=cf-me-5.6-for-rhel-7-rpms
    Note

    See Enabling Supplementary and Optional Repositories in Using and Configuring Red Hat Subscription Manager for more information.

  2. Enable the CloudForms 4.5 (CFME 5.8) repositories:

    # subscription-manager repos --enable=rhel-7-server-rpms \
    --enable=cf-me-5.8-for-rhel-7-rpms \
    --enable=rhel-7-server-optional-rpms \
    --enable=rhel-7-server-supplementary-rpms \
    --enable=rhel-server-rhscl-7-rpms

2.4. Resizing the Disk Space

CloudForms 4.5 requires more disk space than previous CloudForms versions because of the addition of built-in Ansible features. Before migrating your appliances to CloudForms 4.5, resize the virtual machine partition hosting the appliances to ensure sufficient space is available for the appliance.

Complete the following steps to resize the disk space, replacing filenames as needed:

  1. Install the xfsdump tool for backing up filesystems:

    # yum -y install xfsdump
  2. Back up the partition’s existing filesystem, /repo, to a temporary repository, /tmp/repo:

    # xfsdump -F -f /tmp/repo /repo
  3. Unmount the existing filesystem:

    # umount /repo
  4. Remove the logical volume:

    # lvremove -f /dev/VG-CFME/lv_repo
  5. Create a new 1GB logical volume in the existing volume group lv_repo:

    # lvcreate --yes -L 1GB -n lv_repo VG-CFME
  6. Format the volume:

    # mkfs.xfs /dev/VG-CFME/lv_repo
  7. Mount the volume to /repo:

    # mount /dev/VG-CFME/lv_repo /repo
  8. Restore the /tmp/repo filesystem data to the old filesystem:

    # xfsrestore -f /tmp/repo /repo
  9. Resize the volume to allow sufficient space for the CloudForms 4.5 appliance:

    # lvextend --resizefs --size +9GB /dev/VG-CFME/lv_var

2.5. Additional Preparation for VMDB Appliances

Complete the following steps only on CFME 5.6 VMDB appliances, which run rubyrep:

  1. This step must be completed before migrating the master VMDB appliance. On the subordinate region VMDB appliances, stop the Database Synchronization server role.

    1. In the CloudForms user interface, navigate to the specific server’s page under SettingsConfigurationSettingsServer.
    2. On the Server tab under Server Control, uncheck the Database Synchronization role.
    3. Click Save.
    4. Verify that the Database Synchronization role has stopped by navigating to ConfigureConfigurationDiagnosticsRegion.
    5. Click the Replication tab. The number for Current Backlog should be increasing.
  2. Connect to the VMDB appliance using SSH.
  3. Shut down the evmserver process on the subordinate or remote database:

    # systemctl stop evmserverd
  4. Change to the vmdb directory:

    # cd /var/www/miq/vmdb/
  5. Run the following to remove any installed rubyrep configuration. This will prevent errors when setting up pglogical after migration:

    # rake evm:dbsync:uninstall

2.6. Migrating from CFME 5.6 to 5.8

Perform the following steps on your CloudForms VMDB, non-VMDB and dedicated database appliances to migrate to CFME 5.8.

Note

Some steps are run on only certain appliances. Ensure you wait for each command to finish before going to the next step.

  1. Connect to the appliance using SSH.
  2. On the VMDB and non-VMDB appliances, stop the evmserver process:

    [root@VMDB]# systemctl stop evmserverd
    [root@non-VMDB]# systemctl stop evmserverd
  3. Update packages on all appliances:

    [root@VMDB]# yum update
    [root@non-VMDB]# yum update
    [root@dedicatedDB]# yum update
  4. On the VMDB and dedicated database appliances, restart the server to load the new version of the pglogical library:

    [root@VMDB]# systemctl restart $APPLIANCE_PG_SERVICE
    [root@dedicatedDB]# systemctl restart $APPLIANCE_PG_SERVICE
  5. On the VMDB and non-VMDB appliances, change to the vmdb directory:

    [root@VMDB]# cd /var/www/miq/vmdb/
    [root@non-VMDB]# cd /var/www/miq/vmdb/
  6. On the VMDB and non-VMDB appliances, log out of the appliance, then log back in to fully reload Ruby.

    Important

    Failure to log out of the old shell environment and back into a new one results in an error reporting the Ruby gem bundle is locked.

    To resolve errors from running bundle install or failing to log in and out of the old shell environment: log out of the current shell and log back in, then run yum reinstall cfme-gemset.

  7. On the VMDB and non-VMDB appliances, run the below command appropriate to your environment to migrate everything in the database to work with the latest 5.8 configuration:

    1. In a single (standalone database) or replicated environment, run this command on each VMDB appliance:

      [root@VMDB]# rake db:migrate
    2. In a dedicated database or highly available environment, run this command on a single non-VMDB appliance pointed at that environment:

      [root@non-VMDB]# rake db:migrate
  8. On the VMDB and non-VMDB appliances, update the Automate Model to the latest version. This resets the ManageIQ and Red Hat domains (base domains) to a new and upgraded version. Run the command appropriate to your environment to update the Automate Model:

    1. In a single (standalone database) or replicated environment, run this command on each VMDB appliance:

      [root@VMDB]# rake evm:automate:reset
    2. In a dedicated database or highly available environment, run this command on a single non-VMDB appliance pointed at that environment:

      [root@non-VMDB]# rake evm:automate:reset
  9. On the VMDB and dedicated database appliances, run the PostgreSQL upgrade script:

    Important

    When you run the script, you are asked to confirm whether to proceed with the operation. Your response must be either a capital Y or a capital N; all other values are rejected.

    [root@VMDB]# /usr/bin/miq_postgres_upgrade.sh
    [root@dedicatedDB]# /usr/bin/miq_postgres_upgrade.sh
  10. Before starting the new server, edit the /var/opt/rh/rh-postgresql95/lib/pgsql/data/postgresql.conf file on the VMDB and dedicated database appliances to ensure the configuration works correctly with PostgreSQL 9.5.

    Note

    Note that some lines below are intentionally added in a commented-out fashion; these indicate the default values for particular parameters and are shown for informational purposes. See /var/opt/rh/rh-postgresql95/lib/pgsql/data/postgresql.conf for further documentation about configuring this file.

    1. Under Checkpoints, remove and add the following lines as shown:

      -checkpoint_segments = 15   # MIQ Value;
      -#checkpoint_segments = 3    # in logfile segments, min 1, 16MB each
      +#max_wal_size = 1GB
      +#min_wal_size = 80MB
    2. Under Kernel Resource Usage, edit the following line as shown:

      -shared_preload_libraries = 'pglogical'   # MIQ Value (change requires restart)
      +shared_preload_libraries = 'pglogical,repmgr_funcs'   # MIQ Value (change requires restart)
    3. Under Archiving, add the following line:

      +wal_log_hints = on
  11. After making these changes, start the VMDB and dedicated database appliances using:

    [root@VMDB]# systemctl enable rh-postgresql95-postgresql.service && systemctl start rh-postgresql95-postgresql.service
    [root@dedicatedDB]# systemctl enable rh-postgresql95-postgresql.service && systemctl start rh-postgresql95-postgresql.service
  12. Start the evmserver process:

    # systemctl start evmserverd

All appliances have been migrated to CFME 5.8 and the migration is now complete.

Note

To configure replication, see Configuring Database Replication in General Configuration.

3. Updating CloudForms

This chapter details applying software package minor updates (referred to as errata) to CloudForms 4.5 appliances.

Appliances must be registered to Red Hat Subscription Manager and subscribed to the update channels required by CloudForms in order to access updates. See Registering Red Hat CloudForms in General Configuration to register and subscribe the appliance.

3.1. Updating the CloudForms Application

An important part of securing CloudForms is to ensure your appliances use the latest software packages.

The Red Hat Updates tab in the CloudForms user interface enables you to check for updates and update registered appliances. Any services requiring a restart to apply updates are automatically restarted as part of the Red Hat Updates process.

Important

Using the Red Hat Updates tab only applies software updates for the CloudForms application. To run the update from the command line, run yum update cfme*. See Section 3.2, “Updating All Packages on the Appliance” for instructions on applying Red Hat errata. To upgrade your appliance to CloudForms 4.5 from an earlier version, see Section 1, “Migrating from CloudForms 4.2 (CFME 5.7) to CloudForms 4.5 (CFME 5.8)” and Section 2, “Migrating from CloudForms 4.1 (CFME 5.6) to CloudForms 4.5 (CFME 5.8)”.

To apply updates to the CloudForms application:

  1. From the settings menu, select Configuration.
  2. Select Region in the accordion menu and click the Red Hat Updates tab.
  3. Click Check For Updates to search the Content Delivery Network (CDN) for any updated CloudForms packages. If an appliance update is available, it will be listed with the available version.
  4. Click Apply CFME Update to install and update CloudForms packages. The CloudForms service will be automatically restarted as needed.
Note

If the appliance is registered to Red Hat Satellite, you can use content views to manage updates for CloudForms. For more information, see Creating Content Views in the Red Hat Satellite 6 Content Management Guide.

The following options are available in the Appliance Updates section of Red Hat Updates:

Table 1. Options Available in Appliance Updates

OptionUse

Refresh List

Refreshes the list of appliances.

Check for Updates

Checks for all available CloudForms updates using yum.

Register

Attempts to register the appliance if it is not already registered. CloudForms subscribes to the cf-me-5.8-for-rhel-7-rpms rhel-server-rhscl-7-rpms repositories, and to the products designated by Red Hat product certification for subscription-manager registered appliances. The Red Hat Enterprise Linux channels are enabled by default on registration. In addition, CloudForms automatically checks for updates after registering.

Apply CFME Update

Applies updates to CloudForms packages only. Specifically, this option runs the yum -y update cfme-appliance command. This command installs every package listed in the dependency tree if it is not already installed. If a specific version of a package is required, that version of the package is installed or upgraded. No other packages, such as PostgreSQL or Red Hat Enterprise Linux, are updated. The appliance may be rebooted automatically during this process.

3.2. Updating All Packages on the Appliance

You can apply updates to the appliance using the yum command or Red Hat Satellite. This updates all RPMs on the appliance, not just the CloudForms packages. Yum can be used at any time to update any single package or the entire appliance to any new or updated packages available on the subscription.

Warning

Updates to the the operating system, CloudForms application or dependent packages may introduce incompatibilities in customized environments. Before applying updates to the appliance, back up the appliance or take a snapshot so that changes can be reverted in production environments if needed.

Important

Scheduled downtime is required while updating system packages for the following reasons:

  • Some updates may interrupt CloudForms operations.
  • Updates for the PostgreSQL database server suspend CloudForms operations.
  • System updates may require a reboot of the CloudForms appliance.

To update all packages on the appliance using yum, follow the procedure below. To update packages on the appliance using Red Hat Satellite, see Viewing and Applying Errata and Configuring and Running Remote Commands in the Red Hat Satellite 6 documentation for more information.

  1. Log into each appliance console as the root user and perform the following steps:

    1. Stop the CloudForms application (the evmserver process) with the following command:

      # systemctl stop evmserverd
    2. Apply the software updates:

      # yum update
      Important

      Do not reboot or restart yet.

  2. Log into each server containing an internal database and perform the following steps:

    1. Stop the database with the following command:

      # systemctl stop rh-postgresql95-postgresql.service
    2. Apply the software updates:

      # yum update
    3. Reboot the server unless the errata or the command needs-restarting advises a restart is safe:

      # systemctl restart rh-postgresql95-postgresql.service
  3. Log into the appliance console on each appliance as the root user and perform the following steps:

    1. Reboot the server unless the errata or the command needs-restarting advises a restart is safe:

      # reboot