Chapter 1. Compatibility Matrix for Red Hat Ceph Storage 3.0

The following tables list products and their versions compatible with Red Hat Ceph Storage 3.0.

Host Operating SystemVersionNotes

Red Hat Enterprise Linux

7.4

Included in the product

Ubuntu

16.04.03

OS component is supported by other vendor

ProductVersionNotes

Ansible

2.4

Included in the product

Red Hat OpenShift

3.1 and later

The RBD driver supported from version 3.0. The Cinder driver from version 3.1

Red Hat OpenStack Platform

10 and later

 

Red Hat Satellite

6

Only registering with the Content Delivery Network (CDN) is supported. Registering with Red Hat Network (RHN) is deprecated and not supported.

Client ConnectorVersionNotes

S3A

2.7.3

 

Red Hat Enterprise Linux iSCSI Initiator

The latest versions of the iscsi-initiator-utils and device-mapper-multipath packages

A special kernel version that is not generally available in Red Hat Enterprise Linux yet is required. Contact the Red Hat Support for availability of an early release of the kernel.

RHCS as a backup targetVersionNotes

Veritas NetBackup for Symantec OpenStorage (OST) cloud backup

7.7 and 8.0

 

Rubrik Cloud Data Management (CDM)

3.2 and later

 

NetApp AltaVault

4.3.2 and 4.4

 

Trilio, TrilioVault

3.0

S3 target