Simplify Migration of Java Applications
Abstract

This guide describes how to use the Red Hat Application Migration Toolkit Eclipse plugin to simplify migration of Java applications.
Table of Contents

CHAPTER 1. INTRODUCTION .................................................. 3
  1.1. ABOUT THE ECLIPSE PLUGIN GUIDE 3
  1.2. ABOUT RED HAT APPLICATION MIGRATION TOOLKIT 3
      What is Red Hat Application Migration Toolkit? 3
      How Does Red Hat Application Migration Toolkit Simplify Migration? 3
      How Do I Learn More? 3
  1.3. ABOUT THE ECLIPSE PLUGIN 3
  1.4. SUPPORTED CONFIGURATIONS 3

CHAPTER 2. INSTALL THE ECLIPSE PLUGIN ................................ 4.

CHAPTER 3. ACCESS THE RHAMT ECLIPSE TOOLS .......................... 6.
  3.1. ECLIPSE PLUGIN COMPONENTS 6

CHAPTER 4. IDENTIFY AND RESOLVE MIGRATION ISSUES .................. 7.
  4.1. CREATE AN RHAMT RUN CONFIGURATION 7
      Input 7
      Options 7
      Rules 8
  4.2. EXECUTE RHAMT 8
  4.3. REVIEW RHAMT ISSUES 8
  4.4. RESOLVE RHAMT ISSUES 8
      4.4.1. Resolve an Issue Manually 8
      4.4.2. Resolve an Issue Using a Quick Fix 9

CHAPTER 5. ADD CUSTOM RULES ............................................. 10.
  5.1. BROWSE RULES 10
  5.2. IMPORT A CUSTOM RULESET 10
  5.3. CREATE A CUSTOM RULESET 10

APPENDIX A. REFERENCE MATERIAL ....................................... 12
  A.1. RHAMT ISSUE ICON LEGEND 12
CHAPTER 1. INTRODUCTION

1.1. ABOUT THE ECLIPSE PLUGIN GUIDE

This guide is for engineers, consultants, and others who want to use the Eclipse plugin for Red Hat Application Migration Toolkit (RHAMT) to assist with migrating applications.

NOTE
This guide uses Eclipse to refer to an installation of Eclipse or JBoss Developer Studio.

1.2. ABOUT RED HAT APPLICATION MIGRATION TOOLKIT

What is Red Hat Application Migration Toolkit?
Red Hat Application Migration Toolkit (RHAMT) is an extensible and customizable rule-based tool that helps simplify migration of Java applications.

RHAMT examines application artifacts, including project source directories and application archives, then produces an HTML report that highlights areas needing changes. RHAMT can be used to migrate Java applications from previous versions of Red Hat JBoss Enterprise Application Platform or from other containers, such as Oracle® WebLogic Server or IBM® WebSphere® Application Server.

How Does Red Hat Application Migration Toolkit Simplify Migration?
Red Hat Application Migration Toolkit looks for common resources and highlights technologies and known trouble spots when migrating applications. The goal is to provide a high-level view into the technologies used by the application and provide a detailed report organizations can use to estimate, document, and migrate enterprise applications to Java EE and Red Hat JBoss Enterprise Application Platform.

How Do I Learn More?
See the Getting Started Guide to learn more about the features, supported configurations, system requirements, and available tools in the Red Hat Application Migration Toolkit.

1.3. ABOUT THE ECLIPSE PLUGIN

The Eclipse plugin for Red Hat Application Migration Toolkit provides assistance directly in Eclipse and Red Hat JBoss Developer Studio for developers making changes for a migration or modernization effort. It analyzes your projects using RHAMT, marks migration issues in the source code, provides guidance to fix the issues, and offers automatic code replacement when possible.

1.4. SUPPORTED CONFIGURATIONS

The Eclipse plugin is tested in following development environments.

- Eclipse 4.7 (Oxygen)
- Red Hat JBoss Developer Studio 11.2
CHAPTER 2. INSTALL THE ECLIPSE PLUGIN

Review the supported configurations to make sure that you are using a development environment that is compatible with the Eclipse plugin.

NOTE

If you are running macOS, it is recommended to set the maximum number of user processes, `maxproc`, to at least 2048, and the maximum number of open files, `maxfiles`, to 100000.

If you do not already have an existing installation, download Eclipse or JBoss Developer Studio and install it.

NOTE

This guide uses Eclipse to refer to an installation of Eclipse or JBoss Developer Studio.

Install the Plugin

1. Launch Eclipse.
2. From the menu bar, select Help → Install New Software.
3. Add the RHAMT update site.
   a. Next to the Work with field, click Add.
   b. In the Name field, enter RHAMT.
   c. In the Location field, enter http://download.jboss.org/jbosstools/oxygen/development/updates/rhamt/composite/ and press OK.
   d. Select all of the checkboxes under JBoss Tools - RHAMT and press Next.
4. Review the installation details and press Next.
5. Accept the terms of the license agreement and press Finish to install the plugin.
6. Restart Eclipse for the changes to take effect.

Install the Plugin for an Offline Environment

1. Download the Eclipse Plugin Repository.
2. Launch Eclipse.
3. From the menu bar, select Help → Install New Software.
4. Add the RHAMT update site.
   a. Next to the Work with field, click Add.
   b. In the Name field, enter RHAMT - Offline.
c. Next to the Location field, click Archive.
d. Select the file downloaded in the first step and click OK.
e. Select all of the checkboxes under JBoss Tools - RHAMT and press Next.

5. Review the installation details and press Next.

6. Accept the terms of the license agreement and press Finish to install the plugin.

7. Restart Eclipse for the changes to take effect.
CHAPTER 3. ACCESS THE RHAMT ECLIPSE TOOLS

Once the plugin is installed, the RHAMT Eclipse tools are available in the RHAMT perspective. To open the RHAMT perspective, navigate to Window → Perspective → Open Perspective → Other. Select RHAMT and press OK.

Review the plugin components and then get started identifying and resolving migration issues. You can also view the embedded help for the plugin by selecting Help → Getting Started in Eclipse.

3.1. ECLIPSE PLUGIN COMPONENTS

The following components are available in the RHAMT perspective when using the Eclipse plugin to analyze projects.

Issue Explorer

This view allows you to explore the RHAMT issues for projects that have been analyzed.
If this view is not visible in the RHAMT Perspective, you can open it by selecting Window → Show View → Issue Explorer.

RHAMT Server

The RHAMT server is a separate process that executes the RHAMT analysis, flags the migration issues, and generates the reports.
You can start, stop, and view the status of the RHAMT server from the Issue Explorer.

Issue Details

This view shows detailed information about the selected RHAMT issue, including the hint, severity, and any additional resources.
If this view is not visible in the RHAMT Perspective, you can open it by selecting Window → Show View → Issue Details.

RHAMT Report

This view shows the HTML reports that are generated when RHAMT is executed. From the report landing page you can navigate to detailed reports, such as Application Details, Issues, and Dependencies.
Note that the RHAMT run configuration used must have the Generate Report option selected in order for the RHAMT reports to be generated.
If this view is not visible in the RHAMT Perspective, you can open it by selecting Window → Show View → RHAMT Report.
CHAPTER 4. IDENTIFY AND RESOLVE MIGRATION ISSUES

Follow these steps to use the Eclipse plugin to identify and resolve migration issues.

1. Import the project to analyze into Eclipse.

2. Create a run configuration. From the Issue Explorer, press the RHAMT button ( ).

   At a minimum, select the project to analyze. Set additional options as needed.

3. Click Run to execute RHAMT.

4. Review RHAMT issues listed in the Issue Explorer.

5. Resolve RHAMT issues by manually updating code or by using quick fixes when available.

6. Run RHAMT again as necessary. Use the drop down next to the Run button ( ) to run an existing configuration.

4.1. CREATE AN RHAMT RUN CONFIGURATION

RHAMT run configurations can be created using the RHAMT button ( ). A run configuration specifies the project to analyze, migration path, and additional options for the execution. You can create multiple run configurations, and each must have a unique name.

Input

Migration Path

Select a migration path, which determines which RHAMT rulesets are used. The migration path defaults to Anything to EAP 7, but can be changed to any supported migration path.

Projects

Select one or more projects to analyze. Hold the Ctrl key to select multiple projects in the list.

Packages

Select one or more packages to scan. It is recommended to select only those packages that you need to analyze to reduce the overall RHAMT execution time. If no packages are selected, all packages in the project will be scanned. Hold the Ctrl key to select multiple packages in the list.

Options

Report

Check the Generate Report checkbox if you want to generate the RHAMT HTML report. The report will be shown in the RHAMT Report tab and can be found in the Issue Explorer when you group by File.

Options

Set additional RHAMT options. Any option that is a boolean flag, such as enableTattletale, should use true as the value. See the RHAMT Command-line Arguments section of the CLI Guide for a description of each RHAMT argument.
4.2. EXECUTE RHAMT

Once a run configuration has been created, you can execute RHAMT using that configuration in one of the following ways:

- Select the run configuration from the Run Configurations dialog and click Run.
- Select a recent run configuration from the drop down next to the Run button ( ).

If the RHAMT server is not currently running, it will start once a run configuration is executed.

NOTE

If you do not plan on running RHAMT in the near future, it is recommended to stop the RHAMT server to conserve memory on your machine.

Once execution is complete, the Issue Explorer will be populated with RHAMT issues.

4.3. REVIEW RHAMT ISSUES

Use the Issue Explorer to review migration issues identified by RHAMT. Different icons indicate the issue’s severity and state.

Change how issues are grouped by adjusting the Group By selections: Severity, Migration Rule, and File.

Double-click the RHAMT issue in the Issue Explorer to open the associated line of code in an editor. Right-click and select Issue Details to view information about the RHAMT issue, including its severity and how to address it.

4.4. RESOLVE RHAMT ISSUES

You can resolve RHAMT issues by updating the code manually or by applying a quick fix when available.

4.4.1. Resolve an Issue Manually
Review the RHAMT issue details and additional resources and update the source code as necessary. When you update a line of code marked as an RHAMT issue, the RHAMT issue will be marked with the stale icon (❓) until the next time that RHAMT is run on the project.

You can also manually mark an RHAMT issue as fixed, which will mark the issue with the resolved icon (✔️) until the next time that RHAMT is run on the project. To mark an issue as fixed, right-click the RHAMT issue in the Issue Explorer and select Mark as Fixed.

### 4.4.2. Resolve an Issue Using a Quick Fix

Some RHAMT issues provide a quick fix, which assists in making the necessary edits to address the issue. See the icon legend to see the icons that indicate the RHAMT issue has a quick fix available.

**Preview a Quick Fix**

Right-click the issue and select Preview Quick Fix. This will bring up a window that allows you to preview the change. From here, you can apply the fix or close the window.

**Apply a Quick Fix**

Right-click the issue and select Apply Quick Fix. This will update the source code as required and will mark the RHAMT issue as resolved.
CHAPTER 5. ADD CUSTOM RULES

By default, the Eclipse plugin comes with a core set of system rules for identifying migration and modernization issues. You can browse the existing rules from the Eclipse plugin.

You can also create your own rules for identifying issues specific to your applications. You can either import an existing custom ruleset or create a custom ruleset directly in the Eclipse plugin.

5.1. BROWSE RULES

You can view both system and custom rules from the Eclipse plugin.

1. From the RHAMT perspective, open the Rulesets tab.
2. Expand the System item to view core system rules, or expand the Custom item to view custom rules.
   
   **NOTE**
   
   In order to view system rules, the RHAMT server must be started.

3. Expand the ruleset containing the rule you want to review.
4. Double-click the rule to open the rule in a viewer. You can select the Source tab to view the XML source of the rule.

5.2. IMPORT A CUSTOM RULESET

You can import an existing custom ruleset into the Eclipse plugin to use during analysis of your projects.

1. From the RHAMT perspective, open the Rulesets tab.
2. Click the import ruleset icon ( ).
3. Browse to and select the XML rule file to import.
   
   **NOTE**
   
   The XML rule file must use the .windup.xml or .rhamt.xml extension in order to be recognized as an RHAMT rule.

4. The custom ruleset is now shown under the Custom item in the Rulesets tab.

This custom ruleset can now be selected in run configurations when analyzing projects.

See the Rules Development Guide to learn more about creating custom XML rules.

5.3. CREATE A CUSTOM RULESET

You can create a new custom ruleset in the Eclipse plugin to use during analysis of your projects.

1. From the RHAMT perspective, open the Rulesets tab.
2. Click the create ruleset icon ( ).

3. Select the project and directory to save the new ruleset in.

4. Enter the file name for the ruleset file.

   **NOTE**
   
   The XML rule file must use the .windup.xml or .rhamt.xml extension in order to be recognized as an RHAMT rule.

5. Enter a ruleset ID, for example, `my-ruleset-id`.

6. Optionally, check the **Generate quickstart template** checkbox to add basic rule templates to the ruleset file.

7. Select **Finish**.

8. The new ruleset file opens in an editor and you can add and edit rules in the file. You can also select the **Source** tab to edit the XML source for the ruleset file.

This new ruleset can now be selected in run configurations when analyzing projects.

See the **Rules Development Guide** to learn more about creating custom XML rules.
APPENDIX A. REFERENCE MATERIAL

A.1. RHAMT ISSUE ICON LEGEND

In the Issue Explorer and file editors, RHAMT issues use an icon to indicate their severity level and status. The following table describes the meaning of the various icons.

Table A.1. RHAMT Issue Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✗</td>
<td>The issue is mandatory to fix for a successful migration.</td>
</tr>
<tr>
<td>☑</td>
<td>The issue is optional to fix for migration.</td>
</tr>
<tr>
<td>🟢</td>
<td>The issue may potentially be an issue during migration.</td>
</tr>
<tr>
<td>☑</td>
<td>The issue has been resolved.</td>
</tr>
<tr>
<td>❓</td>
<td>The issue is stale because the code marked as an issue has been modified since the last time that RHAMT was run on the project.</td>
</tr>
<tr>
<td>❗</td>
<td>A quick fix is available for this issue, which is mandatory to fix for a successful migration.</td>
</tr>
<tr>
<td>⚠</td>
<td>A quick fix is available for this issue, which is optional to fix for migration.</td>
</tr>
<tr>
<td>💡</td>
<td>A quick fix is available for this issue, which may potentially be an issue during migration.</td>
</tr>
</tbody>
</table>

Revised on 2018-04-04 12:21:15 EDT