Chapter 1. System requirements

Installing a Private Automation Hub instance requires the following:

Table 1.1. System Requirements

 Required

Subscription

Valid Red Hat Ansible Automation Platform

OS

Red Hat Enterprise Linux 7.7 or later 64-bit (x86) or 8.2 or later 64-bit (x86)

Ansible

version 2.9 required

RAM

4Gb minimum

CPUs

2 minimum

Disk

20Gb dedicated hard disk space

Dependent on size of collections stored

Browser

A currently supported version of Mozilla FireFox or Google Chrome

Database

PostgreSQL version 10

Note

You cannot install Ansible Tower and a Private Automation Hub instance on the same node. The inventory file can handle the installation of both Ansible Tower and Automation Hub. These instructions are only for the installation of Automation Hub.