Chapter 2. Deprecated and Removed Features

OpenWire JMS is the only OpenWire client that will continue to be supported in the next major release of AMQ

In the next major release of AMQ (AMQ 7.0), support for most of the OpenWire clients will be dropped. The only OpenWire client that will continue to be supported is OpenWire JMS.

Support for KahaDB and LevelDB will be dropped in the next major release of AMQ

In the next major release of AMQ (AMQ 7.0), both the KahaDB message store and the LevelDB message store will be dropped. JBoss AMQ 7 has its own message store implementation and data model.

The implementation of the JDBC persistence adapter will change in the next major release of AMQ

While JBoss AMQ 7 will support a JDBC adapter, the AMQ 6.x JBDC adapter will not be supported on JBoss AMQ 7. A new JDBC store will need to be created.

Support for Apache Karaf (OSGi) container will be dropped in the next major release of AMQ

In the next major release of AMQ (AMQ 7.0), the Apache Karaf (OSGi) container will be dropped. AMQ 7.0 will be packaged as a standalone application, without any container technology.

Support for Fabric8 1.x will be dropped in the next major release of AMQ

In the next major release of AMQ (planned as AMQ 7.0), Fabric8 version 1 will be dropped, to be replaced by Fabric8 version 2. The Fabric8 version 2 upgrade is a new generation of distributed container technology that is entirely cloud-based and leverages the OpenShift technology stack to provide the foundation for containerized AMQ applications.

bin/deletefabric8 script has been removed

The bin/deletefabric8 script has been removed in this release.

Tanuki based wrapper for installing AMQ as a service is deprecated

The Tanuki based wrapper scripts—generated using the wrapper:install Karaf console command—for installing AMQ as a service are deprecated since AMQ 6.3 and will be removed in a future release of AMQ. To install the Apache Karaf container as a service, it is recommended that you use the new karaf-service-*.sh scripts from the bin/contrib directory instead.

bin/patch script is deprecated

The bin/patch script (bin\patch.bat on Windows O/S) is deprecated and will be removed in a future release.

Spring Dynamic Modules (Spring-DM) is deprecated

Spring-DM (which integrates Spring XML with the OSGi service layer) is deprecated since 6.2.1 and you should use the Blueprint framework instead. Using Blueprint does not prevent you from using the Java libraries from the Spring framework: the latest version of Spring is compatible with Blueprint.

REST API is not supported

REST API is not supported in AMQ 6.x and never has been. The REST API described in the Apache ActiveMQ community documentation, http://activemq.apache.org/rest.html, is only a demonstration, not a fully-developed feature. It cannot be used with AMQ 6.x and has multiple gaps in its functionality that make it unsuitable for production use.