Chapter 6. Installing the Messaging Client Packages

Abstract

Red Hat AMQ provides messaging clients as individual packages that you download from the Red Hat Customer Portal.

6.1. Installing Clients on Red Hat Enterprise Linux

Required subscriptions

In order to install the A-MQ client packages on Red Hat Enterprise Linux (RHEL), you require subscriptions to both of the following Red Hat products:
  • Red Hat AMQ 6.3
  • RHEL 5, 6, or 7

Qpid JMS AMQP 1.0 Java client

To install the Qpid JMS AMQP 1.0 Java client, enter the following command (as a superuser):
# yum install qpid-jms-client qpid-jms-client-docs qpid-jms-client-examples qpid-jms-client-maven-repo

Qpid C++ client

To install the Qpid C++ client, enter the following command (as a superuser):
# yum install qpid-cpp-client qpid-cpp-client-devel
Important
The Qpid C++ client packages are currently not available for the following platform (processor) combinations: RHEL 5 (i686) and RHEL 6 (i686).

Python language bindings for Qpid Proton

To install the Python language bindings for the Qpid Proton messaging framework, enter the following command (as a superuser):
# yum install python-qpid-proton python-qpid-proton-doc

Compiling the Qpid C++ client from sources on RHEL 6

The Qpid C++ client cannot be compiled from sources through the Client or ComputeNode channels on RHEL 6 (due to a missing dependency on the package, nss-devel). In order to compile from sources, it is recommended that you install the Qpid C++ client through the Server channel instead.