Chapter 3. OpenShift Container Platform versions

AMQ Interconnect 1.10 is supported on OpenShift Container Platform versions 4.6, 4.7 or 4.8.

With OpenShift Container Platform 4.9, deprecated APIs are removed from OpenShift, requiring the following actions before upgrading:

  • You must update to AMQ Interconnect 1.10.2 before you can upgrade to OpenShift Container Platform version 4.9. If you attempt to upgrade to OpenShift Container Platform version 4.9 while an earlier version of the AMQ Interconnect Operator is installed in the cluster, an error is displayed.
  • The Red Hat Integration - AMQ Certificate Manager Operator is not supported on OpenShift Container Platform version 4.9 or later. If you attempt to upgrade to OpenShift Container Platform version 4.9 while the AMQ Certificate Manager Operator is installed in the cluster, an error is displayed. Migrating from the Red Hat Integration - AMQ Certificate Manager Operator is described in Deploying AMQ Interconnect on OpenShift.