Chapter 1. Long Term Support for AMQ Broker 7.8

AMQ Broker 7.8 has been designated as a Long Term Support (LTS) release version. Bug fixes and security advisories will be made available for AMQ Broker 7.8 in a series of micro releases (7.8.1, 7.8.2, and so on) for a period of at least 12 months.

This means that you will be able to get recent bug fixes and security advisories for AMQ Broker without having to upgrade to a new minor release.

Note the following important points about the LTS release stream:

  • The LTS release stream provides only bug fixes. No new enhancements will be added to this stream.
  • To remain in a supported configuration, you must upgrade to the latest micro release in the LTS release stream.
  • The LTS version will be supported for at least 12 months from the time of the AMQ Broker 7.8.0 GA release.

Support for Red Hat Enterprise Linux and OpenShift Container Platform

The AMQ Broker 7.8 LTS version supports:

  • Red Hat Enterprise Linux 6, 7, and 8
  • OpenShift Container Platform 3.11 and 4.5 and 4.6

Note the following important points about support for Red Hat Enterprise Linux and OpenShift Container Platform:

  • AMQ Broker 7.8 is the last version that will support Red Hat Enterprise Linux 6 and OpenShift Container Platform 3.11.
  • Red Hat does not guarantee that AMQ Broker 7.8 will be supported on future versions (that is, versions greater than 4.6) of OpenShift Container Platform.

For information about issues resolved in AMQ Broker 7.8 LTS micro releases, see AMQ 7 Broker - 7.8.x Resolved Issues.