Menu Close

Chapter 5. APIcast operator-based upgrade guide: from 2.10 to 2.11

Upgrading APIcast from 2.10 to 2.11 in an operator-based installation helps you use the APIcast API gateway to integrate your internal and external API services with 3scale.

Important

In order to understand the required conditions and procedure, read the entire upgrade guide before applying the listed steps. The upgrade process disrupts the provision of the service until the procedure finishes. Due to this disruption, make sure to have a maintenance window.

5.1. Prerequisites to perform the upgrade

To perform the upgrade of APIcast from 2.10 to 2.11 in an operator-based installation, the following required prerequisites must already be in place:

  • An OpenShift Container Platform (OCP) 4.6, 4.7, or 4.8 cluster with administrator access.

    • You must perform the upgrade of APIcast from 2.10 to 2.11 before upgrading to OCP 4.9
    • Note: If you upgrade OCP to 4.9 or greater before upgrading APIcast you will get a non-working installation.
  • APIcast 2.10 previously deployed via the APIcast operator.
  • Make sure the latest CSV of the threescale-2.10 channel is in use. To check it:

    • If the approval setting for the subscription is automatic you should already be in the latest CSV version of the channel.
    • If the approval setting for the subscription is manual make sure you approve all pending InstallPlans and have the latest CSV version.
    • Keep in mind if there is a pending install plan, there might be more pending install plans, which will only be shown after the existing pending plan has been installed.

5.2. Upgrading APIcast from 2.10 to 2.11 in an operator-based installation

Upgrade APIcast from 2.10 to 2.11 in an operator-based installation so that APIcast can function as the API gateway in your 3scale installation.

Procedure

  1. Log in to the OCP console using the account with administrator privileges.
  2. Select the project where the APIcast operator has been deployed.
  3. Click Operators > Installed Operators.
  4. In Subscription > Channel, select Red Hat Integration - 3scale APIcast gateway.
  5. Edit the channel of the subscription by selecting the threescale-2.11 channel and save the changes.

    This will start the upgrade process.

  6. Query the pods status on the project until you see all the new versions are running and ready without errors:

    oc get pods
    Note
    • The pods might have temporary errors during the upgrade process.
    • The time required to upgrade pods can vary from 5-10 minutes.
  7. Check the status of the APIcast objects and get the YAML content by running the following command:

    oc get apicast <myapicast> -o yaml
    • The new annotations with the values should be as follows:

      apicast.apps.3scale.net/operator-version: “0.5.0”

After you have performed all the listed steps, APIcast upgrade from 2.10 to 2.11 in an operator-based deployment is now complete.