5.2. Starting the Transaction Service tools

The way to start the transaction service tools differs on the operating system being used:
Windows

Double click on the ‘Start Tools’ link in the JBoss Transaction Service program group in the start menu.

Unix

Start a bash shell and type:

cd <JBossTS INSTALL DIRECTORY>
./run-tools.sh
Once you have done this the tools window will appear. This is the launch area for all of the tools shipped with the JBoss Transaction Service. At the top of the window you will notice a menu bar. This menu bar has four items:
Menu bar
The File Menu

 

Open JMX Browser
This displays the JMX browser window (see ***Using the JMX Browser for more information on how to use the JMX browser).
Open Object Store Browser
This displays the JBossTS Object Store browser window (see ***Using the Object Store Browser for more information on how to use the Object Store browser).
Settings
This option opens the settings dialog which lets you configure the different tools available.
Exit
This closes the tools window and exits the application, any unsaved/unconfirmed changes will be lost.
The Performance Menu

 

Open
This opens a performance window – see Section 5.3, “Using the Performance Tool” for more information on the performance tool.
Close All
this closes all of the currently open performance windows – see Section 5.3, “Using the Performance Tool” for more information on the performance tool.
The Window Menu

 

Cascade Windows
This arranges the windows in a diagonal line to you find a specific window.
1. XXXXXXX
For each window currently visible an extra menu option will be available here. Selecting this menu option will bring the associated window to the front of the desktop.
The Help Menu

 

About
This displays the about window containing the product information.