Red Hat JBoss Developer Studio 7.1

Installation Guide

Information for users installing JBoss Developer Studio

Red Hat Documentation Team

Legal Notice

Copyright © 2013, 2014 Red Hat, Inc.
This document is licensed by Red Hat under the Creative Commons Attribution-ShareAlike 3.0 Unported License. If you distribute this document, or a modified version of it, you must provide attribution to Red Hat, Inc. and provide a link to the original. If the document is modified, all Red Hat trademarks must be removed.
Red Hat, as the licensor of this document, waives the right to enforce, and agrees not to assert, Section 4d of CC-BY-SA to the fullest extent permitted by applicable law.
Red Hat, Red Hat Enterprise Linux, the Shadowman logo, JBoss, MetaMatrix, Fedora, the Infinity Logo, and RHCE are trademarks of Red Hat, Inc., registered in the United States and other countries.
Linux® is the registered trademark of Linus Torvalds in the United States and other countries.
Java® is a registered trademark of Oracle and/or its affiliates.
XFS® is a trademark of Silicon Graphics International Corp. or its subsidiaries in the United States and/or other countries.
MySQL® is a registered trademark of MySQL AB in the United States, the European Union and other countries.
Node.js® is an official trademark of Joyent. Red Hat Software Collections is not formally related to or endorsed by the official Joyent Node.js open source or commercial project.
The OpenStack® Word Mark and OpenStack Logo are either registered trademarks/service marks or trademarks/service marks of the OpenStack Foundation, in the United States and other countries and are used with the OpenStack Foundation's permission. We are not affiliated with, endorsed or sponsored by the OpenStack Foundation, or the OpenStack community.
All other trademarks are the property of their respective owners.

Abstract

This document details how to install and set up JBoss Developer Studio.

Preface

1. Document Conventions

This manual uses several conventions to highlight certain words and phrases and draw attention to specific pieces of information.

1.1. Typographic Conventions

Four typographic conventions are used to call attention to specific words and phrases. These conventions, and the circumstances they apply to, are as follows.
Mono-spaced Bold
Used to highlight system input, including shell commands, file names and paths. Also used to highlight keys and key combinations. For example:
To see the contents of the file my_next_bestselling_novel in your current working directory, enter the cat my_next_bestselling_novel command at the shell prompt and press Enter to execute the command.
The above includes a file name, a shell command and a key, all presented in mono-spaced bold and all distinguishable thanks to context.
Key combinations can be distinguished from an individual key by the plus sign that connects each part of a key combination. For example:
Press Enter to execute the command.
Press Ctrl+Alt+F2 to switch to a virtual terminal.
The first example highlights a particular key to press. The second example highlights a key combination: a set of three keys pressed simultaneously.
If source code is discussed, class names, methods, functions, variable names and returned values mentioned within a paragraph will be presented as above, in mono-spaced bold. For example:
File-related classes include filesystem for file systems, file for files, and dir for directories. Each class has its own associated set of permissions.
Proportional Bold
This denotes words or phrases encountered on a system, including application names; dialog-box text; labeled buttons; check-box and radio-button labels; menu titles and submenu titles. For example:
Choose SystemPreferencesMouse from the main menu bar to launch Mouse Preferences. In the Buttons tab, select the Left-handed mouse check box and click Close to switch the primary mouse button from the left to the right (making the mouse suitable for use in the left hand).
To insert a special character into a gedit file, choose ApplicationsAccessoriesCharacter Map from the main menu bar. Next, choose SearchFind… from the Character Map menu bar, type the name of the character in the Search field and click Next. The character you sought will be highlighted in the Character Table. Double-click this highlighted character to place it in the Text to copy field and then click the Copy button. Now switch back to your document and choose EditPaste from the gedit menu bar.
The above text includes application names; system-wide menu names and items; application-specific menu names; and buttons and text found within a GUI interface, all presented in proportional bold and all distinguishable by context.
Mono-spaced Bold Italic or Proportional Bold Italic
Whether mono-spaced bold or proportional bold, the addition of italics indicates replaceable or variable text. Italics denotes text you do not input literally or displayed text that changes depending on circumstance. For example:
To connect to a remote machine using ssh, type ssh username@domain.name at a shell prompt. If the remote machine is example.com and your username on that machine is john, type ssh john@example.com.
The mount -o remount file-system command remounts the named file system. For example, to remount the /home file system, the command is mount -o remount /home.
To see the version of a currently installed package, use the rpm -q package command. It will return a result as follows: package-version-release.
Note the words in bold italics above: username, domain.name, file-system, package, version and release. Each word is a placeholder, either for text you enter when issuing a command or for text displayed by the system.
Aside from standard usage for presenting the title of a work, italics denotes the first use of a new and important term. For example:
Publican is a DocBook publishing system.

1.2. Pull-quote Conventions

Terminal output and source code listings are set off visually from the surrounding text.
Output sent to a terminal is set in mono-spaced roman and presented thus:
books        Desktop   documentation  drafts  mss    photos   stuff  svn
books_tests  Desktop1  downloads      images  notes  scripts  svgs
Source-code listings are also set in mono-spaced roman but add syntax highlighting as follows:
static int kvm_vm_ioctl_deassign_device(struct kvm *kvm,
                 struct kvm_assigned_pci_dev *assigned_dev)
{
         int r = 0;
         struct kvm_assigned_dev_kernel *match;

         mutex_lock(&kvm->lock);

         match = kvm_find_assigned_dev(&kvm->arch.assigned_dev_head,
                                       assigned_dev->assigned_dev_id);
         if (!match) {
                 printk(KERN_INFO "%s: device hasn't been assigned before, "
                   "so cannot be deassigned\n", __func__);
                 r = -EINVAL;
                 goto out;
         }

         kvm_deassign_device(kvm, match);

         kvm_free_assigned_device(kvm, match);

out:
         mutex_unlock(&kvm->lock);
         return r;
}

1.3. Notes and Warnings

Finally, we use three visual styles to draw attention to information that might otherwise be overlooked.

Note

Notes are tips, shortcuts or alternative approaches to the task at hand. Ignoring a note should have no negative consequences, but you might miss out on a trick that makes your life easier.

Important

Important boxes detail things that are easily missed: configuration changes that only apply to the current session, or services that need restarting before an update will apply. Ignoring a box labeled “Important” will not cause data loss but may cause irritation and frustration.

Warning

Warnings should not be ignored. Ignoring warnings will most likely cause data loss.

2. Getting Help and Giving Feedback

Do You Need Help?
If you experience difficulty with a procedure described in this documentation, visit the Red Hat Customer Portal at http://access.redhat.com. Through the customer portal, you can:
  • search or browse through a knowledgebase of technical support articles about Red Hat products.
  • submit a support case to Red Hat Global Support Services (GSS).
  • access other product documentation.
Red Hat also hosts a large number of electronic mailing lists for discussion of Red Hat software and technology. You can find a list of publicly available mailing lists at https://www.redhat.com/mailman/listinfo. Click on the name of any mailing list to subscribe to that list or to access the list archives.
Give us Feedback
If you find a typographical error or have a suggestion for improving this documentation, we would love to hear from you. Submit a report in JIRA against the project Documentation for JBoss Tools and Developer Studio (TOOLSDOC). The following link will take you to a pre-filled bug report for this product: https://issues.jboss.org.
Fill out the following template in JIRA's Description field. Be as specific as possible when describing the issue; this will help ensure that we can fix it quickly.
Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Be sure to give us your name so that you can receive full credit for reporting the issue.

Chapter 1. Introduction to Red Hat JBoss Developer Studio

1.1. About Red Hat JBoss Developer Studio

Red Hat JBoss Developer Studio is a set of Eclipse-based development tools. It contains plug-ins that integrate with Eclipse to extend the existing functionality of the integrated development environment (IDE).
JBoss Developer Studio is designed to increase your productivity when developing applications. You can focus on building, testing and deploying your applications because JBoss application development tools are integrated in one IDE. Furthermore, JBoss Developer Studio can assist your application development with its unique features in the following ways:
  • Develop new applications using the wizards and project examples of JBoss Central
  • Add powerful functionality to applications with minimal effort using Forge Tools
  • Build web interfaces with ease using the visual editing and drag-and-drop utilities of Visual Web Tools and Mobile Web Tools
  • Experience browsers automatically refreshing in response to modified application resources with LiveReload Tools
  • Incorporate JSF, Seam, JAX-RS, Hibernate, CDI and other popular APIs into applications with simplicity using the tool-driven interface
  • Preview and test mobile web applications on a variety of simulation mobile devices using BrowserSim
  • Create, build and test Cordova-based hybrid mobile applications for iOS and Android platforms using Hybrid Mobile Tools and CordovaSim
  • Deploy applications to JBoss runtime servers and the cloud using JBoss Server Tools and OpenShift Tools
JBoss Developer Studio comes built around Eclipse and packaged with all of the necessary dependencies and third-party plug-ins for simplified installing. For developers already running Eclipse, JBoss Developer Studio can also be installed through Eclipse Marketplace. For distinction, this latter JBoss Developer Studio installation is called JBoss Developer Studio BYOE (Bring Your Own Eclipse).

1.2. Use Cases of JBoss Developer Studio

JBoss Developer Studio assists JEE developers by integrating JBoss technology and APIs in a single development environment. Here are a few ways that JBoss Developer Studio makes the work of a developer easier:
Web applications
JBoss Central provides wizards that generate skeleton and sample projects, enabling you to focus on developing the functionality of your applications. The wizards create web applications based on different APIs and technologies, showing the usage and advantages of each. JBoss Developer Studio also offers project file templates in a range of popular programming languages, including HTML, XHTML, and JSF.
Palettes in JBoss Developer Studio give access to the core elements of the JSF, Richfaces and Seam APIs, for use in developing the user interfaces of your applications. Elements of these APIs can be dragged and dropped directly into your project so that you can create richer user interfaces quickly. Visual Web Tools offers graphical and source viewing of files and defaults to dedicated editors for different file types. JBoss Developer Studio supports the Java EE specification and provides tools for JAX-RS, Hibernate, and CDI APIs so you can develop the server-side components of your applications effortlessly.
LiveReload Tools automatically refreshes browsers of local or deployed applications as you modify project resources to save you from needing to manually refresh. You can even experience automatic refreshing when viewing applications in browsers on external and mobile devices, with application web addresses easy to navigate to with QR codes.
Web applications optimized for mobile devices
Mobile Web Tools provides support for HTML5 and jQuery Mobile to enable you to create web applications optimized across desktop and mobile clients. The HTML5 Project wizard in JBoss Central generates a sample application using HTML5 and jQuery Mobile technologies and, together with HTML5 and jQuery Mobile project file templates, helps you to get up and running with these APIs and technologies quickly. HTML5 and jQuery Mobile widgets can be dragged from the jQuery Mobile palette into your project files and, in conjunction with the widget wizards, enable you to effortlessly develop customized user interfaces for your mobile web applications.
BrowserSim allows you to view your web applications on a variety of simulated mobile devices so that you can ensure they will be correctly formatted. LiveReload also extends to BrowserSim allowing you to experience automatic browser refreshing as you develop your mobile web applications. The integration of Firebug Lite and Weinre capabilities with BrowserSim assists you to inspect the page source of web pages with familiar tools.
Hybrid mobile applications
Hybrid Mobile Tools provides support for developing and building Cordova-based hybrid mobile applications for iOS and Android platforms. The Hybrid Mobile application wizard assists you to quickly generate new projects, while the Cordova Configuration Editor and Cordova Plug-in Discovery wizard help you to efficiently modify the capabilities of your projects. Hybrid Mobile Tools provides actions that simplify your workflow, for example calling your system installed Android and iOS SDKs from within the IDE to emulate or run your hybrid mobile applications. With wizards to export workspace projects to Cordova-enabled native projects or ready-to-sign applications, you can quickly be ready to share your hybrid mobile projects and applications.
CordovaSim enables you to view and test your hybrid mobile applications on Android and iOS simulated mobile devices so that you can ensure they look and work as expected. You can interact with your mobile applications through BrowserSim and use the device input panel to provide sample data to your applications for device functions like cameras and accelerometers. An advantage of CordovaSim is that it does not require native SDKs to be installed on your system, unlike native SDK emulators. Additionally, by teaming the device control panel with BrowserSim, you get all of the great functionality of BrowserSim, such as skins and LiveReload, while simulating your hybrid mobile applications.
Applications for cloud deployment
OpenShift Tools deploys your applications directly to the cloud on the Red Hat OpenShift platform. You can create and manage your OpenShift account and manage the deployment of applications in your OpenShift domains from within the IDE. In addition to using the OpenShift Application wizard to create new applications for deployment to OpenShift, OpenShift Tools can import applications already deployed on OpenShift so that you can further develop them and manage their deployment from the comfort of the IDE.

Chapter 2. System Requirements

2.1. System Requirements Overview

The aim of this section is familiarize you with the system requirements necessary for JBoss Developer Studio to function optimally:
  • A variety of operating system and architecture combinations are generally supported but some tools have additional requirements.
  • A minimum amount of RAM and hard disk space are required to install and run JBoss Developer Studio.
  • A variety of operating systems and Java developer kit combinations are supported.

2.2. Supported Operating Systems and Architectures

JBoss Developer Studio 7.1 is supported on the operating systems listed in the table below.

Table 2.1. Supported Operating Systems

Operating System Chip Architecture
Red Hat Enterprise Linux 6 x86, x86_64
Microsoft Windows XP, Windows 7 and Windows 8 x86, x86_64
OS X Lion (10.7) [a], OS X Mountain Lion (10.8) and OS X Mavericks (10.9) [b] x86_64
Fedora 18 and Fedora 19 x86, x86_64
Ubuntu 12.04.2 LTS and Ubuntu 13.04 x86, x86_64
[a] OS X Lion (10.7) is supported by JBoss Developer Studio 7.1.0 only.
[b] OS X Mavericks (10.9) is supported by JBoss Developer Studio 7.1.1 only.
As JBoss Developer Studio 7.1 is based on Eclipse Kepler (4.3), the system requirements of Eclipse Kepler also apply to JBoss Developer Studio 7.1. For example, GTK is required as the windowing system on Linux distributions, Win32 on Microsoft Windows operating systems and Cocoa on OS X operating systems. For more information about Eclipse Kepler system requirements see http://www.eclipse.org/eclipse/development/readme_eclipse_4.3.html on the Eclipse website.
The Visual Page Editor and BrowserSim tools have additional Java developer kit requirements and restrictions:
  • The visual component of the Visual Page Editor, which depends on XULRunner, does not operate in the 64-bit version of JBoss Developer Studio on OS X and Microsoft Windows operating systems. To work around this restriction on 64-bit OS X and Microsoft Windows operating systems, you must install a 32-bit version of JBoss Developer Studio with a 32-bit Java developer kit.
  • BrowserSim, which depends on WebKit, requires Apple Safari to be installed on Microsoft Windows operating systems. Only a 32-bit version of Apple Safari is available for Microsoft Windows operating systems. To work around this restriction for 64-bit Microsoft Windows operating systems running 64-bit versions of JBoss Developer Studio, you must set BrowserSim to use a 32-bit JVM by editing the BrowserSim preferences from within the IDE. Note that 32-bit JVM choice is limited to Oracle 32-bit JRE 1.6, JDK 1.6, or JDK 1.7 on Microsoft Windows operating systems because Oracle 32-bit JRE 1.7 is incompatible with Apple Safari.

2.3. Computer Memory

To install and run JBoss Developer Studio 7.1, the following memory requirements are recommended:
  • 4 GB RAM
  • 1.5 GB of hard disk space
The minimum memory requirements are 2 GB RAM and 750 MB of hard disk space.

2.4. Compatible Java Developer Kits

JBoss Developer Studio 7.1 requires a Java developer kit of version 1.6 or later. This release of JBoss Developer Studio is supported on the operating system and Java developer kit combinations listed in the table below.

Table 2.2. Supported Combinations of Operating Systems and Java Developer Kits

Operating System Java Developer Kit
Red Hat Enterprise Linux 6 OpenJDK 1.6, OpenJDK 1.7, Oracle JDK 1.6 and Oracle JDK 1.7
Microsoft Windows XP Oracle JDK 1.6
Microsoft Window 7 and Windows 8 Oracle JDK 1.6 and Oracle JDK 1.7
OS X Lion (10.7) [a], OS X Mountain Lion (10.8) and OS X Mavericks (10.9) [b] Apple JDK 1.6 and Oracle JDK 1.7 (64-bit only)
Fedora 18 and Fedora 19 OpenJDK 1.6 and OpenJDK 1.7
Ubuntu 12.04.2 LTS and Ubuntu 13.04 OpenJDK 1.6 and OpenJDK 1.7
[a] OS X Lion (10.7) is supported by JBoss Developer Studio 7.1.0 only.
[b] OS X Mavericks (10.9) is supported by JBoss Developer Studio 7.1.1 only.
Before installing JBoss Developer Studio you must identify which Java developer kit you have installed. If it is not listed above, you must install a compatible one before proceeding.

Important

You must use a 32-bit Java developer kit to install a 32-bit version of JBoss Developer Studio and a 64-bit Java developer kit to install a 64-bit version of JBoss Developer Studio.

Chapter 3. Install JBoss Developer Studio

3.1. Install Options

JBoss Developer Studio can be installed in a number of different ways.
You can install JBoss Developer Studio, packaged with Eclipse and dependent third-party plug-ins, with a universal installer for all operating systems. A second version of the universal installer is available that additionally contains Red Hat JBoss Enterprise Application Platform and installs both JBoss Developer Studio and JBoss EAP.
Alternatively, if you already have Eclipse on your system you may prefer to install JBoss Developer Studio BYOE. This option installs JBoss Developer Studio in Eclipse.
The primary installation method for JBoss Developer Studio and JBoss Developer Studio BYOE is via the interactive user interfaces of the universal installer and Eclipse, respectively. For information about the secondary scripted installation method see Section B.2, “Install JBoss Developer Studio by Script”.

3.2. Install JBoss Developer Studio

A universal installer .jar file is provided for installing JBoss Developer Studio and it is available from the Customer Portal. A second version of the universal installer for installing both JBoss Developer Studio and JBoss EAP is also available from the Customer Portal. The procedure below guides you though obtaining the universal installers and the installation process.
Alternatively, the source code is available as a .zip file at the same location. You can use this source code to build the universal installer yourself and then use that to install JBoss Developer Studio. For instructions for building the universal installer see Section B.1, “Build the Universal Installer from Source”.

Procedure 3.1. Install with the Universal Installer

  1. Log into the Customer Portal at https://access.redhat.com.
  2. From the menu bar click Downloads.
  3. Under Red Hat JBoss Middleware, click Download Software.
    Log in to the Customer Portal at https://access.redhat.com. From the menu bar click Downloads. Under Red Hat JBoss Middleware, click Download Software.

    Figure 3.1. Download Red Hat JBoss Middleware Software on the Customer Portal

  4. Under Software Downloads, select the following options:
    • From the Product list, select JBoss Developer Studio.
    • From the Version list, select 7.1.x.
  5. From the table, click Download for one of the following:
    • For the JBoss Developer Studio universal installer, click Download for the Red Hat JBoss Developer Studio 7.1.x Stand Alone Universal Binary download file.
    • For the JBoss Developer Studio and JBoss EAP universal installer, click Download for the Red Hat JBoss Developer Studio 7.1.x Universal Binary with JBoss EAP download file.
    This downloads a universal installer .jar file.
  6. On the command line, navigate to path/to/.jar and enter
    java -jar jbdevstudio-product-universal-version.jar
    or
    java -jar jbdevstudio-product-eap-universal-version.jar
    as appropriate for the downloaded universal installer, where version is substituted to match the name of the .jar file.

    Note

    Alternatively, to start the installer you may be able to double-click the .jar file.
  7. When the Installer window opens, click Next.
  8. After reading and agreeing to the terms of the End User License Agreement, click I accept the terms of this license agreement and click Next.
  9. In the Select the installation path field, type the path where you want JBoss Developer Studio to be installed or click Browse to navigate to the location. When the Select the installation path field shows the correct path, click Next. When you are prompted about the specified location being created or overwritten, review the message and, if satisfied, click OK or Yes as appropriate.
    In the Select the installation path field, type the path where you want JBoss Developer Studio to be installed or click Browse to navigate to the desired location. When the Select the installation path field shows the correct path, click Next.

    Figure 3.2. Installation Step 3: Select Target Folder

  10. In the Select Java VM step, Default Java VM is automatically selected. Ensure that the disabled text field contains the path of the Java developer kit you want to use. This is based on the default Java developer kit of your system. To change the specified Java developer kit, click Specific Java VM and type the path of the Java developer kit in the text field or use the Browse button to locate the Java developer kit. When the text field shows the correct Java developer kit path, click Next.

    Important

    You must specify a Java developer kit with a 32-bit JRE to install a 32-bit version of JBoss Developer Studio and a 64-bit JRE to install a 64-bit version of JBoss Developer Studio. To change the bit version of the Java developer kit to be used for installing JBoss Developer Studio, complete the appropriate step for your operating system:
    • On OS X operating systems, from the Installation type list click the appropriate bit version.
    • On Linux distributions and Microsoft Windows operating systems, in the text field type the path to the appropriate bit version of the Java developer kit.
    In the Select Java VM step, Default Java VM is automatically selected. Ensure that the disabled text field contains the path of the Java developer kit you want to use. This is based on the default Java developer kit of your system. To change the specified Java developer kit, click Specific Java VM and type the path of the Java developer kit in the text field or use the Browse button to locate the Java developer kit. When the text field shows the correct Java developer kit path, click Next.

    Figure 3.3. Installation Step 4: Select Java VM

  11. If installing from the universal installer that includes JBoss EAP, you are asked if you want to install JBoss EAP. This option installs JBoss EAP in a subdirectory under JBoss Developer Studio and generates a complete server definition within the IDE with which to manage the runtime server and deployed applications. Click Yes or No as appropriate.
  12. To make use of automatic runtime detection for finding already installed application servers, click Add. In the Location field, type the path from which recursive scanning for application servers is to commence or click Browse to navigate to the location:
    • To detect a specific application server, select the install directory for that application server.
    • To detect multiple application servers, select a directory higher up the directory tree. Alternatively, this can be achieved by adding multiple locations for scanning.
    To scan the specified path for new application servers each time JBoss Developer Studio starts, select the Scan every start check box. Click OK to close the Add Location window and click Next.
    Type the path from which recursive scanning for application servers is to commence or click Browse to navigate to the path. For this path to be scanned for new application servers each time JBoss Developer Studio starts, select the Scan every start check box. Click OK to close the Add Location window.

    Figure 3.4. Add Location Window for Runtime Detection

  13. Review the details in the Summary Information window and, if they are correct, click Next. Installation commences.
  14. When the Pack installation progress bar shows Finished, click Next. The installation process is now complete.
    When the Pack installation progress bar shows Finished, click Next.

    Figure 3.5. Installation Step 7: Installation Progress in Finished State

  15. To create shortcuts for starting JBoss Developer Studio, select the Create shortcuts in the Start-Menu and Create additional shortcut on the desktop check boxes and click Next.
  16. To automatically start JBoss Developer Studio when the Installer window closes, select the Run JBoss Developer Studio after installation check box. Click Done to close the Installer window.

Important

Linux distributions have a maximum number of files that a process can have open at one time. If this maximum number of files is set too low, JBoss Developer Studio will not start. You must open the /etc/security/limits.conf file and ensure that the soft nofile and hard nofile variables have values of 9216 at a minimum. If the variables have smaller values, the values must be increased to 9216. If the variables are not specified, the following lines must be added to the file:
* soft nofile 9216
* hard nofile 9216

3.3. Install JBoss Developer Studio BYOE

You can obtain JBoss Developer Studio BYOE from Eclipse Marketplace or use the update .zip file available from the Red Hat Customer Portal or Red Hat JBoss Developer Studio Update website. The latter option provisions for online and offline installation modes; Eclipse can install directly from the online .zip file or you can download the .zip file first and then Eclipse can install from this local copy.
Select one of the procedures below, which will guide you through the JBoss Developer Studio BYOE installation process.

Procedure 3.2. Install from Eclipse Marketplace

  1. Start Eclipse Kepler.
  2. Click HelpEclipse Marketplace.
  3. In the Find field of the Search tab, enter Red Hat JBoss Developer Studio.
  4. Locate Red Hat JBoss Developer Studio (Kepler) and click Install.
    Click Help→Eclipse Marketplace. In the Find field of the Search tab, enter JBoss Developer Studio. Locate Red Hat JBoss Developer Studio (Kepler) and click Install.

    Figure 3.6. Install JBoss Developer Studio BYOE via Eclipse Marketplace

  5. Ensure the Red Hat JBoss Developer Studio (Kepler) check box is selected and click Confirm.
    Ensure the Red Hat JBoss Developer Studio (Kepler) check box is selected and click Confirm.

    Figure 3.7. Confirm Selected Features Window

  6. After reading and agreeing to the licenses, click I accept the terms of the license agreements and click Finish.
    After reading and agreeing to the licenses, click I accept the terms of the license agreements and click Finish.

    Figure 3.8. Review Licenses Window

  7. During the installation process you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied click OK to continue with the installation.
    During the installation process you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied click OK to continue with the installation.

    Figure 3.9. Warning Prompt for Installing Unsigned Content

  8. Once installing is complete, you are prompted to restart Eclipse. Click Yes to restart now and No if you need to save any unsaved changes to open projects. Note that IDE changes do not take effect until Eclipse is restarted.

Procedure 3.3. Install from Update .zip File

Note

To install JBoss Developer Studio BYOE in offline mode, you must first download the update .zip file. You can download the update .zip file from https://access.redhat.com on the Customer Portal or https://devstudio.jboss.com/updates/7.0/ on the Red Hat JBoss Developer update website.
  1. Start Eclipse Kepler.
  2. Click HelpInstall New Software.
  3. Complete the appropriate step for your chosen install mode:
    • For online mode, in the Work with field enter https://devstudio.jboss.com/updates/7.0/.
      For online mode, in the Work with field enter https://devstudio.jboss.com/updates/7.0/.

      Figure 3.10. Work from an Online Website

    • For offline mode, in the Work with field enter the path of the update .zip file. Alternatively, click Add and click Archive to locate the file.
      For offline mode, in the Work with field enter the absolute file path of the update .zip file.

      Figure 3.11. Work from a Local Copy of the Update .zip File

  4. From the table of components, select JBoss Developer Studio 7.x - Bring Your Own Eclipse and click Next.
    From the table of components comprising the update .zip file, select JBoss Developer Studio 7.x - Bring Your Own Eclipse and click Next.

    Figure 3.12. Available Software Window Listing JBoss Developer Studio 7.x - Bring Your Own Eclipse

  5. Review the details of the component to be installed and click Next.
  6. After reading and agreeing to the licenses, click I accept the terms of the license agreements and click Finish.
    After reading and agreeing to the licenses, click I accept the terms of the license agreements and click Finish.

    Figure 3.13. Review Licenses Window

  7. During the installation process you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied click OK to continue with the installation.
    During the installation process you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied click OK to continue with the installation.

    Figure 3.14. Warning Prompt for Installing Unsigned Content

  8. Once installing is complete, you are prompted to restart Eclipse. Click Yes to restart now and No if you need to save any unsaved changes to open projects. Note that IDE changes do not take effect until Eclipse is restarted.

Chapter 4. Set Preferences on First Launch after Installing

4.1. Preferences Options

The aim of this section is to guide you in setting preferences for the JBoss Developer Studio features encountered on the first IDE start after installing:
  • Select a workspace for your projects
  • Choose whether to enable JBoss Developer Studio to collect usage information for compiling product-wide statistics
  • Decide whether to define servers for application servers that runtime detection found on IDE start
  • Activate the JBoss perspective to provide easy access to common views, menus and toolbars for working with JBoss technologies

4.2. Select a Workspace Location

When the IDE starts, you are asked to choose the workspace folder for the session. The workspace is where your projects are stored.
When the IDE starts, you are asked to choose the workspace folder for the session. In the Workspace field, type the path for a new or existing workspace or use Browse to navigate to the workspace location. If you do not want to be asked to choose a workspace folder each time the development environment starts, select the Use this as the default and do not ask again check box.

Figure 4.1. Select a Workspace Window

To set the workspace location, follow these steps:
  1. In the Workspace field, type the path for a new or existing workspace or use Browse to navigate to the workspace location.
  2. If you do not want to be asked to choose a workspace folder each time the IDE starts, select the Use this as the default and do not ask again check box.
  3. Click OK.
The workspace location prompting behavior can be altered at any time by clicking WindowPreferences. Expand GeneralStartup and Shutdown and select Workspaces. Select or clear the Prompt for workspace on startup check box to alter the behavior as appropriate.

4.3. Set Usage Reporting

JBoss Developer Studio has usage reporting. At the first start of the IDE after installing, you are asked if you allow the collection of anonymous usage statistics by JBoss Developer Studio.
At the first start of the IDE after installing, you are asked if you allow the collection of anonymous usage statistics by JBoss Developer Studio. To agree to this anonymous information being collected, click Yes when prompted.

Figure 4.2. Prompt for Anonymous Usage Statistics

The information collected enables Red Hat to understand how and where JBoss Developer Studio is being used. Specifically, information about operating systems and system display resolution assists in continually improving JBoss Developer Studio.
The following information is collected:
  • Version of JBoss Developer Studio
  • Installed components of JBoss Developer Studio
  • JBoss Central enabled
  • Origin of Eclipse product
  • Version of Eclipse
  • Operating system
  • Operating system version
  • Linux distribution and version, if appropriate
  • Screen colors
  • Screen resolution
  • Version of Java
  • Internet connection type
  • Location (continent, country, city) and language
  • User type (new or returning)
  • Number of times JBoss Developer Studio has been started
  • Date of first usage reported
  • Date of last usage reported
  • Date of current usage reported
If enabled, the usage reporting plug-in uses Google Analytics to track data as though you visited a page under https://devstudio.jboss.com/usage.
To agree to this anonymous information being collected, click Yes when prompted.
The usage reporting behavior can be changed at any time by clicking WindowPreferences. Expand JBoss Tools and select Usage Reporting. Select or clear the Please allow Red Hat Inc. to receive anonymous usage statistics for this JBoss Developer Studio installation check box to alter the behavior as appropriate.

4.4. Define Servers for Application Servers Found by Runtime Detection

If you set up runtime detection during the installation process, at the first start of the IDE you are prompted with the results of the runtime detection scan. Depending on whether any application servers are found, follow the appropriate step:
  • If no new application servers are found or if new application servers are found but you do not want to create any server runtime environments for them, click Cancel.
    If no new application servers are found, click Cancel.

    Figure 4.3. No New Application Servers Found by Runtime Detection

  • If new application servers are found and you want to generate server runtime environments for them, select the check boxes of the appropriate application servers and click OK.
    If new application servers are found, you can generate server runtime environments for them. Select the check boxes of the application servers for which you want to generate server runtime environments and click OK.

    Figure 4.4. One New Application Server Found by Runtime Detection

Note

If you did not set up runtime detection during the installation process or you installed JBoss Developer Studio BYOE, you can set up runtime detection in Preferences under JBoss ToolsJBoss Runtime Detection.

4.5. Set the Perspective to JBoss

JBoss Developer Studio has the JBoss perspective. This perspective displays views, toolbars and menu items most often used by developers using JBoss.
When you start JBoss Developer Studio, this perspective is set as the default and it is automatically displayed.
When you start Eclipse after installing JBoss Developer Studio BYOE, this perspective is not automatically displayed. To show the JBoss perspective, click WindowOpen PerspectiveOther, select JBoss and click OK.
To set the JBoss perspective as the default perspective, click WindowPreferences. Expand General and select Perspectives. From the Available perspectives list, select JBoss and click Make Default. Click Apply and click OK to close the Preferences window.
To set the JBoss perspective as the default perspective, click Window→Preferences. Expand General and select Perspectives. From the Available perspectives list, select JBoss and click Make Default. Click Apply and click OK to close the Preferences window.

Figure 4.5. Make JBoss the Default Perspective in the Preferences Window

Chapter 5. Upgrade from Previous Versions of JBoss Developer Studio

5.1. Upgrade Methods

The method for upgrading JBoss Developer Studio depends on the version of JBoss Developer Studio from which you are upgrading.

Warning

Before upgrading, you are advised to back up your workspace. In addition to your project files, your workspace contains meta-data about customized setting and preferences for the IDE. To back up your workspace, either copy the workspace directory to a backup location or save it as a compressed file.

5.2. Upgrade from JBoss Developer Studio 6.x and Earlier

It is not possible to upgrade an existing JBoss Developer Studio 6.x or earlier installation to JBoss Developer Studio 7.1 because they are based on different versions of Eclipse. For example, JBoss Developer Studio 6.0 is based on Eclipse Juno (4.2) but JBoss Developer Studio 7.1 is based on Eclipse Kepler (4.3).
To use JBoss Developer Studio 7.1, you must do one of the following:
  • For JBoss Developer Studio, download and run the JBoss Developer Studio 7.1 universal installer available from https://access.redhat.com on the Red Hat Customer Portal.
  • For JBoss Developer Studio BYOE, upgrade to Eclipse Kepler (4.3) and install JBoss Developer Studio 7.1 BYOE from one of the following options: Eclipse Marketplace, the update .zip file available from the Red Hat Customer Portal or from https://devstudio.jboss.com/updates/7.0/ on the Red Hat JBoss Developer Studio Update website.

Note

You can use different versions of JBoss Developer Studio or JBoss Developer Studio BYOE alongside each other by installing them in different directories or installing them onto different Eclipse installations, respectively.

5.3. Upgrade from JBoss Developer Studio 7.0

It is possible to upgrade an existing JBoss Developer Studio 7.0 installation to JBoss Developer Studio 7.1 because they are based on the same version of Eclipse, namely Kepler (4.3).
You may be automatically notified by the IDE when the JBoss Developer Studio 7.1 upgrade is available, depending on your IDE settings for automatic updates. Alternatively, the upgrade method stated here is applicable to JBoss Developer Studio and JBoss Developer Studio BYOE.
To manually initiate the upgrade to JBoss Developer Studio 7.1, in the IDE click HelpCheck for Updates. The Contacting Software Sites window opens and searches for updates to apply. If any updates are found they are listed in the Available Updates window. Ensure the check box for JBoss Developer Studio 7.1.0 is selected and click Next. After reading and agreeing to the licenses, click I accept the terms of the license agreements and click Finish.
During the installation process you may receive warnings about installing unsigned content. If this is the case, review the details of the content and if satisfied click OK to continue with the installation. Once installing is complete, you are prompted to restart the IDE. Click Yes to restart now and No if you need to save any unsaved changes to open projects. Note that IDE changes do not take effect until the IDE is restarted.

Note

If you are expecting updates but none are found, check that the IDE is aware of the URL where JBoss Developer Studio updates are located. Click WindowPreferences, expand Install/Update and click Available Software Sites. In the table of Available Software Sites the URL https://devstudio.jboss.com/updates/7.0/ must be listed. If it is not listed, click Add and in the Location field type the URL. Click OK to close the Add Site window and click OK to close the Preferences window.

Important

If you have installed additional plug-ins from JBoss Central and updated versions of these plug-ins are available with this release of JBoss Developer Studio, you must upgrade the plug-ins independently after first upgrading JBoss Developer Studio. To install the updated version of an already installed plug-in, from the JBoss Central Software/Update tab select to install the plug-in as if it is new and follow the installation wizard instructions.

Chapter 6. Uninstall JBoss Developer Studio

6.1. Uninstall Methods

There are two uninstall methods for JBoss Developer Studio. The method you use depends on whether you are using JBoss Developer Studio or JBoss Developer Studio BYOE.

6.2. Uninstall JBoss Developer Studio

Procedure 6.1. Uninstall with the Uninstaller

  1. Ensure JBoss Developer Studio is not running.
  2. On the command line, navigate to path/to/JBoss Developer Studio/Uninstaller.
  3. On the command line, enter
    java -jar uninstaller.jar

    Note

    Alternatively, to start the uninstaller you may be able to double-click the uninstaller.jar file.
  4. To remove the entire JBoss Developer Studio installation directory, select the Force the deletion check box. If this is not selected, JBoss Developer Studio is uninstalled but some files are left behind in the installation directory.
  5. Click Uninstall.
  6. Once the progress bar shows Finished, click Quit to close the Uninstaller window.
    Once the progress bar shows Finished, click Quit to close the Uninstaller window.

    Figure 6.1. Uninstaller in Finished State

6.3. Uninstall JBoss Developer Studio BYOE

JBoss Developer Studio BYOE can be uninstalled with the procedure below regardless of whether it was installed via Eclipse Marketplace or the update .zip file.

Procedure 6.2. Uninstall via Eclipse Marketplace

  1. Start Eclipse Kepler.
  2. Click HelpEclipse Marketplace.
  3. In the Find field of the Search tab, enter Red Hat JBoss Developer Studio.
  4. Locate Red Hat JBoss Developer Studio (Kepler) and click Uninstall.
    Click Help→Eclipse Marketplace. In the Find field of the Search tab, enter JBoss Developer Studio. Locate Red Hat JBoss Developer Studio (Kepler) and click Uninstall.

    Figure 6.2. Uninstall JBoss Developer Studio via Eclipse Marketplace

  5. Ensure the Red Hat JBoss Developer Studio (Kepler) check box is selected and click Confirm.
  6. Ensure the Red Hat JBoss Developer Studio (Kepler) check box is selected and click Finish.
    Ensure the Red Hat JBoss Developer Studio (Kepler) check box is selected and click Finish.

    Figure 6.3. Confirm Selected Features Window

  7. Once installing is complete, you are prompted to restart Eclipse. Click Yes to restart immediately and No if you need to save any unsaved changes to open projects. Note that IDE changes do not take effect until Eclipse is restarted.

Java Developer Kits

It is important to use a Java developer kit that is supported by this release of JBoss Developer Studio. The aim of this section is to assist you to do the following:
  • Determine the Java developer kit used by your system
  • Install a supported Java developer kit

A.1. Determine Default Java Developer Kit of the System

To determine if your system has a Java developer kit set up for use and the version, follow the procedure below which is suitable for all operating systems.

Procedure A.1. Determine Default Java Developer Kit of the System

  1. On the command line, enter javac -version. The output shows the version of the Java compiler being used as the default of the system and indicates that the system has a Java developer kit set up for use.

    Important

    If a message to the effect of javac not found is returned, the system does not have a Java compiler set up for use. This indicates that either the system does not have a Java developer kit installed or that the installed Java developer kit is not set up for use.
  2. On the command line, enter java -version. The output preceding Runtime Environment identifies which Java distribution is being used as the default Java runtime environment (JRE) and the output after java version identifies the version number of the JRE.

    Important

    If the version numbers of the Java compiler and JRE are different, the system is using a Java compiler and JRE from different Java distributions as the default. This should be rectified so that the Java compiler and JRE are from the same Java developer kit.
Sample output for various Java developer kits is displayed below.

Example A.1. Sample Output from Identifying the Default Java Developer Kit of the System

Output for OpenJDK Java developer kit 1.7.0:
$ javac  -version
javac 1.7.0_09
$ java -version
java version "1.7.0_09-icedtea"
OpenJDK Runtime Environment (fedora-2.3.5.fc17-x86_64)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)
Output for Oracle JDK 1.6.0:
$ javac -version
javac 1.6.0_38
$ java -version
java version "1.6.0_38"
Java(TM) SE Runtime Environment (build 1.6.0_38-b05)
Java HotSpot(TM) 64-Bit Server VM (build 20.13-b02, mixed mode)
Output for OpenJDK JRE 1.7.0 (no Java compiler):
$ javac -version
bash: /usr/bin/javac: No such file or directory
$ java -version
java version "1.7.0_09-icedtea"
OpenJDK Runtime Environment (fedora-2.3.5.fc17-x86_64)
OpenJDK Server VM (build 23.2-b09, mixed mode)

A.2. Install a Java Developer Kit

The procedures given here guide you through how to install a new Java developer kit, either OpenJDK or Oracle.

Important

Each Java developer kit has its own system requirements and these must be checked before starting the installation process.

Procedure A.2. Install a OpenJDK Java developer kit

  • Complete the appropriate step for your operating system:
    • For Red Hat Enterprise Linux and Fedora, on the command line enter
      sudo yum install java-1.7.0-openjdk-devel
    • For Ubuntu, on the command line enter
      sudo apt-get install openjdk-7-jdk

Procedure A.3. Install a Oracle JDK

  1. To download a JDK, go to http://www.oracle.com/technetwork/java/javase/downloads/index.html on the Oracle website. Identify the Java SE version you want and follow the instructions to download the appropriate file for your operating system and architecture.

    Note

    For Linux distributions, both a .rpm and a .tar.gz file will be available for download. Installing with an RPM binary (.rpm) file requires root access but the archive binary (tar.gz) file can be installed by all users.
  2. To install the JDK from the downloaded file, complete the appropriate steps for your operating system:
    • For Linux distributions and the .tar.gz file:
      1. Move the .tar.gz file to the directory where you want to install the JDK. For example, Java distributions are typically stored in /usr/java/.
      2. On the command line, navigate to the location of the .tar.gz file and enter
        tar zxvf jdk-<version>-linux-<architecture>.tar.gz
        replacing <version> and <architecture> as appropriate.
      3. Once complete, the .tar.gz file can be deleted to save disk space.
    • For Linux distributions and the .rpm file:
      1. On the command line, navigate to the location of the .rpm file and enter
        sudo rpm -ivh jdk-<version>-linux-<architecture>.rpm
        replacing <version> and <architecture> as appropriate.
      2. Once complete, the .rpm file can be deleted to save disk space.
    • For OS X operating systems:
      1. Double-click the .dmg file.
      2. In the open Finder window, double-click the package icon and follow the installer instructions.
      3. Once complete, the .dmg file can be deleted to save disk space.
    • For Microsoft Windows operating systems:
      1. Double-click the .exe and follow the installer instructions.
      2. Once complete, the .exe file can be deleted to save disk space.

Supplementary Installation Procedures

B.1. Build the Universal Installer from Source

A source code .zip file is provided for building the JBoss Developer Studio universal installer and it is available from the Red Hat Customer Portal. The procedure below guides you through obtaining the source code and the build process.

Important

Maven must be installed to build the universal installer from the source code. To obtain Maven see http://maven.apache.org/.

Procedure B.1. Build the Universal Installer from Source

  1. Log into the Customer Portal at https://access.redhat.com.
  2. From the menu bar click Downloads.
  3. Under Red Hat JBoss Middleware, click Download Software.
    Log in to the Customer Portal at https://access.redhat.com. From the menu bar click Downloads. Under Red Hat JBoss Middleware, click Download Software.

    Figure B.1. Download Red Hat JBoss Middleware Software on the Customer Portal

  4. Under Software Downloads, select the following options:
    • From the Product list, select JBoss Developer Studio.
    • From the Version list, select 7.1.x.
  5. From the table, click Download for the Red Hat JBoss Developer Studio 7.1.x Source Code download file. This downloads the sources .zip file.
  6. On the command line, navigate to path/to/.zip and enter
    unzip jbdevstudio-product-sources-version.zip
    where version is substituted to match the name of the downloaded file. The archive is extracted to a devstudio directory.
  7. To build the universal installer, on the command line navigate to devstudio/product and enter
    mvn clean install
    Building takes some time to complete, after which the universal installer .jar file is located in the installer/target/ directory.

B.2. Install JBoss Developer Studio by Script

A scripted method is available for use when installing JBoss Developer Studio using the universal installer. The scripted installation method removes the need to step through the universal installer GUI for every installation, enabling simplified repeat installations or installations in bulk. The procedure below details how you can install JBoss Developer Studio stepping through the universal installer GUI once and then use a generated script for subsequent installations.

Note

To install JBoss Developer Studio using scripts, you must first download the universal installer .jar file. You can download the .jar file from https://access.redhat.com on the Red Hat Customer Portal.

Procedure B.2. Install JBoss Developer Studio via Script

  1. To run the universal installer GUI, on the command line enter
    java -jar jbdevstudio-*.jar
    This generates a InstallConfigRecord.xml file in the directory where JBoss Developer Studio is installed.
  2. To perform repeat installations without stepping through the universal installer GUI, on the command line enter
    java -jar jbdevstudio-*.jar InstallConfigRecord.xml
    This creates an identically configured JBoss Developer Studio installation.

    Note

    The generated InstallConfigRecord.xml file is machine-specific, using the Java developer kit and installation paths of your system. To use the InstallConfigRecord.xml file for systems with different operating systems, Java developer kits or paths, you must manually modify the file.

Revision History

Revision History
Revision 7.1.1-2Wed Nov 05 2014Michelle Murray
TOOLSDOC-540: Fixed typos
Revision 7.1.1-1Thu Mar 13 2014Michelle Murray
TOOLSDOC-457: Supported operating systems updated
Revision 7.1.0-7Tue Dec 10 2013Michelle Murray
Published for 7.1.0.GA
Revision 7.1.0-6Fri Nov 08 2013Michelle Murray
Published for 7.1.0.Beta
Revision 7.1.0-5Wed Nov 06 2013Michelle Murray
TOOLSDOC-416: Screen captures updated for UI changes
Revision 7.1.0-4Tue Nov 05 2013Michelle Murray
TOOLSDOC-392, TOOLSDOC-414: Scripted installations information added, screen captures updated
Revision 7.1.0-3Thu Oct 24 2013Michelle Murray
TOOLSDOC-413: JIRA links added for bug reporting
Revision 7.1.0-2Thu Oct 10 2013Michelle Murray
TOOLSDOC-393: Universal installer with JBoss EAP information added
Revision 7.1.0-1Wed Oct 09 2013Michelle Murray
First draft