2.4. Deprecated Functionalities

qpid-cpp

995039 - Remove the old client API

The Old Qpid Client C++ API (in namespace qpid::client) has been removed from the developer packages. This API is now old, not actively maintained, brings in some undesirable dependencies, and is therefore not recommended for new code. The Qpid Messenging API (in namespace qpid::messaging) has equivalent functionality and can be used instead. All new C++ messagaing code should use the Qpid Messaging API. Previous code written using the Qpid Client code may require modification to use the Qpid Messaging API.