7.188. sapconf

An updated sapconf package that fixes several bugs and adds two enhancements is now available for Red Hat Enterprise Linux 6.
The sapconf package contains a script that checks the basic installation of Red Hat Enterprise Linux and modifies it according to SAP requirements. The script ensures that all necessary packages are installed and that configuration parameters are set correctly to run SAP software.

Bug Fixes

BZ#1158407
Prior to this update, the sapconf package was not updated to reflect the changes made to the profiles of the tuned daemon for SAP NetWeaver. As a consequence, As a consequence, the activation of a tuned profile searched for the deprecated "sap" profile, and therefore failed. With this update, using the sapconf script installs the tuned-profiles-sap package if it is not already installed. In addition, the TUNED_SAP_PROFILE variable has been changed to "sap-netweaver". As a result, sapconf now properly uses the "sap-netweaver" profile, and activating a tuned profile proceeds as expected.
BZ#1168422
Previously, the sapconf script set an incorrect value for the MAX_MAP_COUNT_MIN variable. The value has been changed, and sapconf now matches the recommended value from SAP Red Hat Enterprise Linux 6.x Installation Guide.
BZ#1173861
In the SELinux permissive mode, the parameter with the path to the configuration file was missing. As a consequence, the sapconf script was waiting for the user input, which led to sapconf becoming unresponsive. The underlying source code has been fixed, and sapconf no longer hangs in the aforementioned situation.

Enhancements

BZ#1123917
The sapconf manual page has been edited to contain more accurate information.
BZ#1174321
With this update, the output of the sapconf script contains also the information about the version of sapconf, which is practical to know for SAP installation or updates.
Users of sapconf are advised to upgrade to this updated package, which fixes these bugs and adds these enhancements.