8.204. rsh

Updated rsh packages that fix several bugs are now available for Red Hat Enterprise Linux 6.
The rsh packages contain programs which allow users to run commands on remote machines, log in to other machines, copy files between machines (rsh, rlogin and rcp), and provide an alternate method of executing remote commands (rexec). All of these programs are run by the xinetd daemon and can be configured using the Pluggable Authentication Modules (PAM) system and configuration files in the /etc/xinetd.d/ directory.

Bug Fixes

BZ#749283
Previously, the rshd daemon performed redundant calls of the setpwent() and endpwent() functions. As a consequence, rshd queried Network Information Security (NIS) servers on every remote shell (rsh) access. With this update, these redundant calls have been removed and rshd no longer contacts NIS servers unnecessarily.
BZ#802367
Prior to this update, the maximum number of command line arguments for the rsh application was not limited. However, the volume of data buffer allocated to the arguments is always finite. Consequently, rshd terminated unexpectedly when it attempted to allocate the buffer to commands with a vast number of arguments. This update implements a limit for command-line arguments in rsh, and the described rshd crash no longer occurs.
BZ#1098955
Previously, the pam_close_session() function was not called when a remote copy (rcp) connection completed. As a consequence, the PAM session did not terminate correctly. With this update, pam_close_session() is called and the PAM session terminates as intended.
BZ#1094360
Prior to this update, the rsh application was optimized through strict aliasing rules, even though it is not a performance-sensitive application. As a consequence, the GNU compiler collection (GCC) generated warning messages about breaking the strict-aliasing rules, despite correct functionality being the priority for rsh. With this update, strict aliasing has been disabled for rsh. Therefore, GCC now ignores the strict aliasing rules and no longer interrupts rsh processes with warning messages. However, this may also lead to a slight decrease in performance.
Users of rsh are advised to upgrade to these updated packages, which fix these bugs.