8.182. polkit-gnome

Updated polkit-gnome packages that fix one bug are now available for Red Hat Enterprise Linux 6.
The polkit-gnome packages provide an authentication agent for the polkit authentication manager, which is an application-level toolkit for defining and handling the policy that allows non-privileged processes communicate with privileged ones.
* Due to a bug in the source code, the authentication dialog of the polkit GNOME authentication manager could send an invalid time stamp to the window manager when the dialog was displayed for the first time. Consequently, the dialog did not receive focus for keyboard input, and the input was sent to the previously-focused window instead. This bug has been fixed, and valid time stamps are now obtained and sent to the window manager. As a result, keyboard input is always sent to the displayed authentication dialog as expected. (BZ#872918)

Bug Fix

BZ#872918
Due to a bug in the source code, the authentication dialog of the polkit GNOME authentication manager could send an invalid time stamp to the window manager when the dialog was displayed for the first time. Consequently, the dialog did not receive focus for keyboard input, and the input was sent to the previously-focused window instead. This bug has been fixed, and valid time stamps are now obtained and sent to the window manager. As a result, keyboard input is always sent to the displayed authentication dialog as expected.
Users of polkit-gnome are advised to upgrade to these updated packages, which fix this bug.