8.174. perl-Crypt-SSLeay

Updated perl-Crypt-SSLeay packages that fix one bug are now available for Red Hat Enterprise Linux 6.
The perl-Crypt-SSLeay packages contain Perl modules that provide support for the HTTPS protocol under Library for WWW in Perl (LWP) so that LWP::UserAgent can make HTTPS GET, HEAD, and POST requests. The perl-Crypt-SSLeay packages contain Net::SSL module, which is automatically loaded by requests from the LWP::Protocol::https module, and provide the necessary SSL glue for the module to work.

Bug Fix

BZ#1059992
The perl-Crypt-SSLeay packages included their own certification authority's (CA) certificates bundle. As a consequence, the content provided by the /usr/share/doc/perl-Crypt-SSLeay-0.57/ca-bundle.crt file became out of date. With this update, /usr/share/doc/perl-Crypt-SSLeay-0.57/ca-bundle.crt has been replaced with a symbolic link to the /etc/pki/tls/certs/ca-bundle.crt file, which is a system-wide storage file for trusted CA certificates. As a result, the perl-Crypt-SSLeay documentation does not contain a bundle of CA certificates that is out of date and could confuse the user.
Users of perl-Crypt-SSLeay are advised to upgrade to these updated packages, which fix this bug.