1.200. pam_pkcs11

An updated pam_pkcs11 package that fixes various bugs is now available for Red Hat Enterprise Linux 6.
The pam_pkcs11 package allows X.509 certificate-based user authentication. It provides access to the certificate and its dedicated private key with an appropriate PKCS (Public Key Cryptographic Standards) #11 module.
Bug Fixes
The system returned the following debug message to standard error when you logged in with a smart card from the command line and "require smart card login" was enabled:
      ERROR: pam_pkcs11.c:334: no suitable token available
With this update, the message is no longer returned.
The system returned the following spurious message to standard error when you entered an incorrect personal identification number (PIN) when logging in from the command line with a smart card:
      ERROR: pam_pkcs11.c:445: open_pkcs11_login() failed: Login incorrect
With this update, only the message "Login incorrect" is displayed and the error details are logged.
All users of pam_pkcs11 are advised to upgrade to this updated package, which resolves these issues.