2.4. General Information

This section contains general information not specific to any other section of this document.
Red Hat Enterprise Linux Deployment Guide
This release of Red Hat Enterprise Linux includes a fairly comprehensive Deployment Guide. To access it, go to System (on the top panel) => Documentation => Red Hat Enterprise Linux Deployment Guide.
It is the intention of Red Hat to provide fully localized versions of the Deployment Guide for all supported languages. If you have installed a localized version of the Deployment Guide, it is recommended that you update it when a new version becomes available through Red Hat Network.
Web Server Packaging Changes
Red Hat Enterprise Linux 5 now includes version 2.2 of the Apache HTTP Server. This release brings a number of improvements over the 2.0 series, including:
  • improved caching modules (mod_cache, mod_disk_cache, mod_mem_cache)
  • a new structure for authentication and authorization support, replacing the authentication modules provided in previous versions
  • support for proxy load balancing (mod_proxy_balancer)
  • support for handling large files (namely, greater than 2GB) on 32-bit platforms
The following changes have been made to the default httpd configuration:
  • The mod_cern_meta and mod_asis modules are no longer loaded by default.
  • The mod_ext_filter module is now loaded by default.
If you are upgrading from a previous release of Red Hat Enterprise Linux, the httpd configuration will need to be updated for httpd 2.2. For more information, refer to http://httpd.apache.org/docs/2.2/upgrading.html.
Note that any third-party modules compiled for httpd 2.0 must be rebuilt for httpd 2.2.
php
Version 5.1 of PHP is now included in Red Hat Enterprise Linux 5, which includes a number of changes to the language along with significant performance improvements. Some scripts might need to be edited for use with the new version; please refer to the link below for more information on migrating from PHP 4.3 to PHP 5.1:
The /usr/bin/php executable is now built using the CLI command-line SAPI, rather than the CGI SAPI. Use /usr/bin/php-cgi for CGI SAPI. The php-cgi executable also includes FastCGI support.
The following extension modules have been added:
  • the mysqli extension, a new interface designed specifically for MySQL 4.1 (included in the php-mysql package)
  • date, hash, Reflection, SPL and SimpleXML (built-in with the php package)
  • pdo and pdo_psqlite (in the php-pdo package)
  • pdo_mysql (in the php-mysql package)
  • pdo_pgsql (in the php-pgsql package)
  • pdo_odbc (in the php-odbc package)
  • soap (in the php-soap package)
  • xmlreader and xmlwriter (in the php-xml package)
  • dom (replacing the domxml extension in the php-xml package)
The following extension modules are no longer included:
  • dbx
  • dio
  • yp
  • overload
  • domxml
The PEAR Framework
The PEAR framework is now packaged in the php-pear package. Only the following PEAR components are included in Red Hat Enterprise Linux 5:
  • Archive_Tar
  • Console_Getopt
  • XML_RPC
Encrypted Swap Partitions and Non-root File Systems
Red Hat Enterprise Linux 5 now provides basic support for encrypted swap partitions and non-root file systems. To use these features, add the appropriate entries to /etc/crypttab and reference the created devices in /etc/fstab.
Below is a sample /etc/crypttab entry:
my_swap /dev/hdb1 /dev/urandom swap,cipher=aes-cbc-essiv:sha256
This creates the encrypted block device /dev/mapper/my_swap, which can be referenced in /etc/fstab.
Below is a sample /etc/crypttab entry for a file system volume:
my_volume /dev/hda5 /etc/volume_key cipher=aes-cbc-essiv:sha256
The /etc/volume_key file contains a plaintext encryption key. You can also specify none as the key file name; this configures the system to ask for the encryption key during boot instead.
It is recommended to use LUKS (Linux Unified Key Setup) for setting up file system volumes. To do this, follow these steps:
  1. Create the encrypted volume using cryptsetup luksFormat.
  2. Add the necessary entry to /etc/crypttab.
  3. Set up the volume manually using cryptsetup luksOpen (or reboot).
  4. Create a file system on the encrypted volume.
  5. Add the necessary entry to /etc/fstab.
mount and umount
The mount and umount commands no longer directly support NFS; a built-in NFS client no longer exists. A separate nfs-utils package, which provides /sbin/mount.nfs and /sbin/umount.nfs helpers, must be installed for this.
CUPS Printer Browsing
CUPS printer browsing over a local subnet can be configured using the graphical tool system-config-printer. It can also be done using the CUPS web interface, http://localhost:631/.
To use directed broadcasts for printer browsing between subnets, open /etc/cups/cupsd.conf on the clients and replace BrowseAllow @LOCAL with BrowseAllow ALL.
ATI and R500 Support
ATI graphics cards based on the R500 chipset are supported for the vesa driver only, and are not supported by Red Hat Enterprise Linux 5 on external monitors, LCD projectors or accelerated 3D support.
up2date and yum
up2date is being deprecated in favor of yum (Yellowdog Updater Modified). As such, it is advisable that you revise any up2date-dependent scripts your system is using accordingly. For more information about yum, consult its man page with the command man yum; you can also consult the installed documentation under the directories /usr/share/doc/yum-<version> and /usr/share/doc/yum-metadata-parser-<version> (replace <version> with the corresponding version of yum and yum-metadata-parser installed).
OpenLDAP Server and Red Hat Directory Server
Red Hat Directory Server is an LDAP-based server that centralizes enterprise and network data into an OS-independent, network-based registry. It is set to replace OpenLDAP server components, which will be deprecated after Red Hat Enterprise Linux 5. For more information about Red Hat Directory Server, refer to http://www.redhat.com/software/rha/directory/.
i810 Driver and i830 Support
The i810 driver supports all integrated Intel graphics chipsets, from i810 to i965. However, the support for i830 (and newer) chipsets is limited; the i810 driver can only set modes listed in the video BIOS. If your machine has an i830 or newer chipset installed, run the following command to determine what the available modes are:
grep Mode: /var/log/Xorg.0.log
Modes marked with an asterisk (*) are available for selection.
Many laptop video BIOSes do not supply a mode that matches the native panel size. Therefore the chosen mode may appear stretched, distorted, or with black borders. As such, if your chosen mode does not display properly, you need a BIOS update from your hardware vendor for the native panel size to work correctly.
Intel PRO/Wireless 3945ABG Network Connection Support
This release of Red Hat Enterprise Linux 5 includes support for the ipw3945 (Intel PRO/Wireless 3945ABG Network Connection) adapter. The Red Hat Enterprise Linux 5 Supplementary disc contains the driver, regulatory daemon and firmware needed to support this adapter.
To enable support for the ipw3945 wireless adapter, search the Red Hat Enterprise Linux 5 Supplementary disc for packages with filenames containing "3945" and install them.
rawio
rawio is a deprecated interface; however, Red Hat Enterprise Linux 5 still includes support for it. If you have an application that performs device access using rawio, it is highly recommended that you modify your application to open the block device with the O_DIRECT flag. The rawio interface will remain throughout the life of Red Hat Enterprise Linux 5, but is a candidate for removal in a future release.
Currently, AIO (Asynchronous I/O) on file systems is only supported in O_DIRECT or non-buffered mode. Further, note that the asynchronous poll interface is no longer present, and that AIO on pipes is no longer supported.
ctmpc
ctmpc is a deprecated driver; however, it will still be included throughout the life of Red Hat Enterprise Linux 5. Note that it is a candidate for removal from future releases.
Policy Modules and semanage Support
Red Hat Enterprise Linux 5 now supports policy modules and semanage. Policy modules simplify the creation and distribution of policy customizations and third-party policies through the use of the semodule and checkmodule tools.
The semanage tool is a policy management tool that modifies the SELinux configuration. It also allows you to configure file contexts, networking component labeling, and user mappings for Linux-to-SELinux.
raw Device Mapping
The raw devices interface has been deprecated in Red Hat Enterprise Linux 5; raw device mapping is now configured via udev rules.
To configure raw device mapping, add the appropriate entries to /etc/udev/rules.d/60-raw.rules in the following formats:
  • For device names:
    ACTION=="add", KERNEL="<device name>", RUN+="raw /dev/raw/rawX %N"
    
  • For major / minor numbers:
    ACTION=="add", ENV{MAJOR}="A", ENV{MINOR}="B", RUN+="raw /dev/raw/rawX %M %m"
    
Replace <device name> with the name of the device you need to bind (for example, /dev/sda1). "A" and "B" are the major / minor numbers of the device you need to bind, and X is the raw device number that you want the system to use.
If you have a large, pre-existing /etc/sysconfig/rawdevices file, convert it with the following script:
#!/bin/sh

grep -v "^ *#" /etc/sysconfig/rawdevices | grep -v "^$" | while read dev major minor ; do
	if [ -z "$minor" ]; then
		echo "ACTION==\"add\", KERNEL==\"${major##/dev/}\", RUN+=\"/usr/bin/raw $dev %N\""
	else
		echo "ACTION==\"add\", ENV{MAJOR}==\"$major\", ENV{MINOR}==\"$minor\", RUN+=\"/usr/bin/raw $dev %M %m\""
	fi
done
QLogic Support
Red Hat Enterprise Linux 5 supports the QLogic family of iSCSI HBA (Host Bus Adapters). At present, only the iSCSI interface to these boards are supported (using the qla4xxx driver).
In addition, Red Hat does not currently support these boards as Ethernet NIC, as this capability requires the qla3xxx driver. This issue will be addressed in an upcoming minor release of Red Hat Enterprise Linux 5.
IBM System z Instruction Set
In order to optimally exploit the IBM System z instruction set for 31-bit applications, it is recommended that you use the gcc option -march=z900. For 64-bit applications, the gcc will exploit the IBM System z instruction set by default.
iSeries Access for Linux
The iSeries ODBC Driver for Linux has been replaced by the iSeries Access for Linux, which can be downloaded at the following link:
The iSeries Access for Linux offers Linux-based access to iSeries servers, and allows you to:
  • Access the DB2 UDB (Universal Database) for iSeries using its ODBC Driver
  • Establish a 5250 session to an iSeries server from a Linux client
  • Access the DB2 UDB via the EDRS (Extended Dynamic Remote SQL) driver
  • Support 32-bit (i386 and PowerPC) and 64-bit (x86-64 and PowerPC) platforms
IBM Power4 iSeries
Red Hat Enterprise Linux no longer supports the IBM Power4 iSeries.