2.2.6. Installing on Red Hat Enterprise Linux

This section describes how to install the OpenShift Online client tools on Red Hat Enterprise Linux operating systems.

2.2.6.1. Prerequisites

  • Red Hat Enterprise Linux 6 or later
  • Sudoer or root access
  • Ruby and RubyGems installed (including rubygem-json and rubygem-parseconfig)

Note

The sudo command only works if the particular user is listed in the sudoers file. As an alternative to sudo access, you can activate a root terminal with the su command and the root password. If you activate a root terminal, omit sudo from the commands shown in the examples. Be sure to close the root terminal after the installation completes.
If the RubyGems package is not already installed, you must enable the Red Hat Enterprise Linux optional repository channel. By enabling the optional channel, the RubyGems package dependencies are automatically resolved during the client tools installation process.
If you are using the Certificate-Based Red Hat Network (RHN) tooling, use the following command to enable the optional channel:
$ sudo yum-config-manager --enable rhel-6-[architecture]-[operating_system]-optional-6
If you are using the classic RHN subscription, use the following command to enable the optional channel:
$ sudo rhn-channel --add --channel=rhel-[architecture]-[operating_system]-optional-6
  • architecture: your system architecture. Enter either i386 or x86_64.
  • operating system: type of operating system installed. Enter either workstation or server.
For example, if you have Red Hat Enterprise Linux Workstation 6 or later installed on a 64-bit x86 computer, and you are using the classic Red Hat Network subscription, run the following command to enable the optional repository:
$ sudo rhn-channel --add --channel=rhel-x86_64-workstation-optional-6