Content View Import Failing

Latest response


I am importing the base content into my disconnected Satellite instance and am getting an error when importing. The error is "authentication credentials were not provided".

I have my hammer credentials set and I am running the import as root. I have other Satellite instances in disconnected environments that do not have this issue. Any suggestions?

---- Update ----
It looks like the disconnected Satellite server is attempting to connect to the CDN. I have subscription connection set to disabled. Has anyone run into this?


Welcome to the club. Content - Subscriptions - Manage Manifest set to Export Sync or Custom CDN

Appreciate the reply. I do currently have it set to Export Sync, still having issues. I suppose I could try custom but am unsure of what URL to configure.

Custom CDN is required only if you do repo syncable format import.
Btw, "authentication credentials were not provided" error is cause missing credential in your foreman.yml, check following file. ~/.hammer/cli.modules.d/foreman.yml

Yeah that is what I first thought of when I saw this issue. That file exists and has the correct credentials set in it.

Hmn.. I'd suggest running "satellite-installer" to make sure everything is intact first.

I have also tried that. To my knowledge, I have tried just about all of the basic steps you might think are indicative of the issue. But nothing has worked. Do you think it could be a problem with processes or applications running on the OS? This satellite instance is configured the same as all of my other offline servers, so I am wondering if the problem lies elsewhere.

Odd, try supplying the username and password in your hammer command line, and validate the credential with WebUI. If still have problem, I'd submit a ticket to RH support.