Sync incomplete in content -> Sync Status

Latest response

Hi all,
During synchronization repos (satellite) some files cannot be downloaded and finally the job stopped with Sync complete.

Here're the message on job:

   "progress_report": {
          "yum_importer": {
            "content": {
              "items_total": 11,
              "state": "FINISHED",
              "error_details": [
                {
                  "url": https://dl.fedoraproject.org/pub/epel/8/Everything/source/tree/Packages/g/ghc-attoparsec-0.13.2.2-1.el8.src.rpm,
                  "errors": [
                    "ruleengineerror"
                  ]
                },
                {
                  "url": https://dl.fedoraproject.org/pub/epel/8/Everything/source/tree/Packages/p/perl-File-Type-0.22-35.el8.src.rpm,
                  "errors": [
                    "MediaTypeBlocked"
                  ]
                },
                {
                  "url": https://dl.fedoraproject.org/pub/epel/8/Everything/source/tree/Packages/c/cabextract-1.9-7.el8.src.rpm,
                  "errors": [
                    "ruleengineerror"
                  ]
                },
                {
                 "url": https://dl.fedoraproject.org/pub/epel/8/Everything/source/tree/Packages/p/perl-Image-Size-3.300-16.el8.src.rpm,
                  "errors": [
                    "MediaTypeBlocked"
                  ]
                },
                {
                  "url": https://dl.fedoraproject.org/pub/epel/8/Everything/source/tree/Packages/p/python-pymediainfo-4.2.1-1.el8.src.rpm,
                  "errors": [
                    "MediaTypeBlocked"
                  ]
                },

I don't understand this error messages and how can I troubleshooting these?
Are any logs that give me more informations?
As anyone any idea or more informations about that?

Thank you and best regards

Responses

Did you check /var/log/messages?

Right, I see these errors there but I don't see much more.

Any error messages apart those you mention? They may exist in other log files.
Tip: Check logs with tail -fn 0 /var/log/*.log /var/log/*/*.log, then start the sync. If nothing there, try tail -fn 0 $(find /var/log/ -type f ! -name "*.gz"). It seems our servers logs Pulp downloading in syslog (/var/log/messages). If you don't see any, you may need to enable some more logging: https://access.redhat.com/solutions/1155573.
Other thoughts: Which version? Fresh install or upgrade? Upgrade from beta? Pulp 2 or 3? File systems large enough and ok while downloading? Refresh the manifest (EPEL, I know, but..)? Web proxy or direct connection? Remove repo and then add it again?