Selinux Package Problem

Latest response

Maybe someone can help right quick with this.

Sat 6.10; RHEL 7.9
Connected/ Disconnected SAT

Rebuilding disconnected sat.

Step:
At >> 2.3. Installing the Satellite Packages from the Offline Repositories

Error:
Error: Package: candlepin-selinux-4.0.16-1.el7sat.noarch (satellite-local)
Requires: selinux-policy >= 3.13.1-268.el7_9.2
Installed: selinux-policy-3.13.1-268.el7.noarch (@anaconda/7.9)
selinux-policy = 3.13.1-268.el7

Followed:
2.4. Resolving Package Dependency Errors
and still having problems; output of it below:

selected the xx.noarch.rpm below:

[root@xxxxxxx updates]# yum localinstall selinux-policy-3.13.1-268.el7_9.2.noarch.rpm
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager

This system is not registered with an entitlement server. You can use subscription-manager to register.

Repository InstallMedia is listed more than once in the configuration
Examining selinux-policy-3.13.1-268.el7_9.2.noarch.rpm: selinux-policy-3.13.1-268.el7_9.2.noarch
Marking selinux-policy-3.13.1-268.el7_9.2.noarch.rpm as an update to selinux-policy-3.13.1-268.el7.noarch
Resolving Dependencies
--> Running transaction check
---> Package selinux-policy.noarch 0:3.13.1-268.el7 will be updated
--> Processing Dependency: selinux-policy = 3.13.1-268.el7 for package: selinux-policy-targeted-3.13.1-268.el7.noarch
--> Processing Dependency: selinux-policy = 3.13.1-268.el7 for package: selinux-policy-targeted-3.13.1-268.el7.noarch
---> Package selinux-policy.noarch 0:3.13.1-268.el7_9.2 will be an update
--> Finished Dependency Resolution
Error: Package: selinux-policy-targeted-3.13.1-268.el7.noarch (@anaconda/7.9)
Requires: selinux-policy = 3.13.1-268.el7
Removing: selinux-policy-3.13.1-268.el7.noarch (@anaconda/7.9)
selinux-policy = 3.13.1-268.el7
Updated By: selinux-policy-3.13.1-268.el7_9.2.noarch (/selinux-policy-3.13.1-268.el7_9.2.noarch)
selinux-policy = 3.13.1-268.el7_9.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@xxxxxxx updates]#

Somehow I can't update (yum localinstall selinux-policy-3.13.1-268.el7_9.2.noarch.rpm)

any ideas why?
Downloaded selinux-policy-3.13.1-268.el7_9.2.noarch.rpm fresh.

==========================

Maybe this helps to find what's wrong.:

I ran:
rpm -i /tmp/selinux-policy-3.13.1-268.el7_9.2.noarcg.rpm

output:
file /usr/lib/rpm/macros.d/macros.selinux-policy from install of selinux-policy-3.13.1-268.el7_9.2.noarch.rpm conflicts with the file from package selinux-policy-3.13.1-268.el7_9.2.noarch

Responses

.

Have you tried 'yum clean all'?

yes. still failed.

But I just found out that >> yum install *.rpm << instead of >> yum install selinux-policy-3.13.1-268.el7_9.2.noarch.rpm << did the trick.