SCP Data transfer got stuck in 90% for a 30-40 seconds

Latest response

When transferring data node1 to node2 got stuck in 90% for a 30-40 seconds connected on same 40G Swtich.

platform: RHEL 8.6

Responses

Hi Rezaul Karim,

  • I am curious, what version of RHEL you are using?
  • Did someone make undisclosed-to-you network changes someplace from the originating system, including the switch (or switches, plural), or the system you are sending the data to?
  • While this specific link is an old solution, please examine it
  • Is there sufficient space on the target server you are performing the scp command to? Is the file system filling up during the send of data and failing--I've seen this happen in other situations)
  • Have you tried an rsync command instead? Also, have you tried an IP address instead of the hostname?
  • Just in general, make sure your /etc/resolv.conf is good so that if you are using hostnames, DNS works right to resolve your host (sure, you get to 90%).
  • Can you on the system you wish to send data to - perform write speed tests from one filesystem to another (without scp, without rsync, namely, a write speed test within the system itself to see how that goes?
  • Evaluate how this goes if you attempt the rsync or scp from a different originating system?
  • Double check the /var/log/messages on both systems during/after this occurs in case something else is happening.
  • Is the target file system a storage appliance, or a RAID system, or just a normal traditional file system?
  • Is the target file system a virtual (i.e. VMware, or RHEV) or physical system? see this https://access.redhat.com/solutions/3409921
  • Double check the network configuration on both systems?
  • Do a tcpdump during transfer and evaluate the results in wireshark for the stalled areas

Has this worked before and this time it is not?

Regards,
RJ

See this previous discussion https://access.redhat.com/discussions/1366583 which while a while ago, has some things you should evaluate. Also see this https://access.redhat.com/discussions/1173853.