Import Content on Disconnected Satellite Server

Latest response

Copied the content from the connected satellite to the disconnected satellite.

Entered the command:
hammer content-import version --organization-id=10 --path=/.../../
returns
Could not import the archive.:
Unable to authenticate user xxx

Reviewed solutions online but nothing seems to work. Not sure how to resolve this.

Responses

Dennis,

Just curious, which form of content did you import, ISO files or a content-view export? If the former, then make sure to validate the steps in appendix E mentioned in a different discussion you started, if using a content view export, see paragraph 8.8. However...

I suspect you are going to have to submit a case with Red Hat, they will likely want an sosreport

You probably have to populate ~/.hammer/cli_config.yml appropriately. That file needs to be populated with the satellite account you've created within the satellite itself, that has been granted appropriate permissions within the satellite web user interface So if you are logged in with a Linux (not satellite) account of regularuser, you need to populate the cli_config.yml file mentioned above with the appropriate satellite account

Regarding satellite users - this link at Red Hat Content Management guide, just before paragraph 2.1, it says... New Users

    If a new user is not assigned a default organization, their access is limited. To grant systems rights to users, assign them to a default organization. The next time the user logs on to Satellite, the user’s account has the correct system rights. 

In the same link, paragraph 8.3, it mentions: The user importing the content must have the Content Importer Role.

  • Have you ingested your manifest? (paragraph 4.1, same link as above)
  • I imagine you've been through chapter 5 of the same guide, link above?
  • Chapter 13 and 14 cover ingesting for ISOS or Content view (not sure which one you picked) of the link above.
  • Have you set up the ingest point in your satellite? (covered in the Content Management guide) - so your satellite knows where to look?

Kind Regards,
RJ

I went the content-view export route.
~/.hammer/cli_config.yml setting were the same on both (connected and disconnected satellite), default organization and location and user rights were also matching up.

I was able to resolve it by editing the foreman.yml >> use_sessions: enabled. This forces hammer to ask for the credentials.

Glad you are making progress Dennis.

Kind Regards,
RJ