satellite-change-hostname script: Error smart_proxy not found

Latest response

Hello!

I am trying to change my hostname of my satellite server (satellite Version 6.10, build 6.10.3).

I have changed it manually but found out that in doing do, it messes up everything moving forward.

I have reverted snapshots and am now attempting to change it via the satellite-change-hostname script.

The error I get is when i run it, is:

Updating default Capsule
Error: smart_proxy not found.

Couldn't find default Capsule id
Failed 'LANG=en_US.UTF-8 hammer -u user -p password --output json capsule info --name localhost.localdomain' with exit code 70

I have searched this error and the solution to this problem is to use hostnamectl set-hostname to revert back to a old hostname.
Link to the rhel solution document i followed: https://access.redhat.com/solutions/3260561

I looked inside /root/anaconda-ks.cfg to find the original hostname which is localhost.localdomain.
I set the hostname back with: hostnamectl set-hostname localhost.localdomain
then: systemctl reboot
And then used: satellite-change-hostname new_FQDN --username user --password password

and i still get the above error just with a different hostname that I think was the old hostname.

Is there a way to find out which "default Capsule id" or hostname the error is referring to, so i can change my hostname?

Thank you!

Responses

I have this issue also.