VDSM not starting, RHEL 6.3 and RHEV3.0

Latest response

I opened up a support Ticket but wanted to see if there was any folks having similar issues - 


I installed the hypervisor software on RHEL and everything went successfully. When the server was rebooted vdsmd did not start. Upon some troubleshooting I tried to start it on my own and got the following message. We are using RHEV3.0 and RHEV on RHEL6.3 cvlqrhevnwm5:/root #


service vdsmd start

vdsm: libvirt already configured for vdsm [ OK ]

Starting iscsid:

vdsm: Failed to define network filters on libvirt [FAILED]


From /var/log/messages - 

Feb 8 17:58:51 cvlqrhevnwm5 init: libvirtd main process ended, respawning

Feb 8 17:58:52 cvlqrhevnwm5 init: libvirtd respawning too fast, stopped

Feb 8 17:58:58 cvlqrhevnwm5 abrt: detected unhandled Python exception in '/usr/share/vdsm/nwfilter. pyc'

Feb 8 17:58:58 cvlqrhevnwm5 abrtd: New client connected

Feb 8 17:58:58 cvlqrhevnwm5 abrtd: Directory 'pyhook-2013-02-08-17:58:58-7022' creation detected

Feb 8 17:58:58 cvlqrhevnwm5 abrt-server[7189]: Saved Python crash dump of pid 7022 to /var/spool/ab rt/pyhook-2013-02-08-17:58:58-7022


Joseph - did you review your iptables configuration?  

I would not be surprised that restarting any single service in the stack may produce undesired results. /var/log/libvirtd.log might shed some light along with /var/log/messages.

You can also try to re-install the Hypervisor manager software (I believe) by selecting your Hypervisor Node from the Web Admin portal and put it in maintenance mode.  Otherwise, you can re-add the Hypervisor as well.

reinstalling the hypervisor software via the web-gui didn't resolve it. I also disabled iptables and it still will not start. 

I had issues installing the RHEV "stack" depending on whether I had patched the 6.3 node, or not.  My procedure now includes a clean install (a few tweaks for our environment), install RHEV, then update.


However - I had to do the following to my RHEL 6.3 hosts which I converted to Hypervisors

Try adding using visudo on your RHEL box.


and restarting the node.

No Luck with the sudo entry; I added the include file like on my other hosts and it still didn't work. I am not suder why the include statement was missing. 

It looks like you will need to open a support case for this one, attach a sosreport from this host as well please

So I figured it out on my own, Redhat Support but ultimatley I had to start from scratch and test component by component with our post configuration. 


It seems that VDSMD needs the messagebus service to start. As soon as I enabled it and started vdsmd it worked. It would be helpful to know the required services needed to start, or the installer start the service and enable chkconfig it. 


Or this was a bug and it shouldn't need this service. 

Outstanding work troubleshooting that.  For clarification, did your post-install updates disable messagebus, or was it not enabled by default on a "stock build"?

Thanks for the update!

Our post install disables most non essential services. I did a clean install on another machine and the vdsm install started without issue. After I ran the post script I could  no longer start vdsm. The most tedious part was going through each service one by one.