Error whil creating DB on rhevm

Latest response

 i had to reinstall rhevm and was planing to resotre the db. but now I can't finsh the rhevm-setup ... it givme me error in creating db step. AdminPassword to ********

 

 

 

prep/sysprep.2k3 --cver=general -p /usr/share/rhevm/conf/rhevm-config-install.properties'
2012-07-31 16:46:58::DEBUG::common_utils::195::root:: output =
2012-07-31 16:46:58::DEBUG::common_utils::196::root:: stderr =
2012-07-31 16:46:58::DEBUG::common_utils::197::root:: retcode = 0
2012-07-31 16:46:58::DEBUG::common_utils::411::root:: updating vdc option ConfigDir to: /etc/rhevm
2012-07-31 16:46:58::DEBUG::common_utils::188::root:: Executing command --> '/usr/share/rhevm/rhevm-config/rhevm-config -s ConfigDir=/etc/rhevm --cver=general -p /usr/share/rhevm/conf/rhevm-config-install.properties'
2012-07-31 16:46:59::DEBUG::common_utils::195::root:: output =
2012-07-31 16:46:59::DEBUG::common_utils::196::root:: stderr =
2012-07-31 16:46:59::DEBUG::common_utils::197::root:: retcode = 0
2012-07-31 16:46:59::DEBUG::common_utils::411::root:: updating vdc option SignScriptName to: SignReq.sh
2012-07-31 16:46:59::DEBUG::common_utils::188::root:: Executing command --> '/usr/share/rhevm/rhevm-config/rhevm-config -s SignScriptName=SignReq.sh --cver=general -p /usr/share/rhevm/conf/rhevm-config-install.properties'
2012-07-31 16:47:00::DEBUG::common_utils::195::root:: output =
2012-07-31 16:47:00::DEBUG::common_utils::196::root:: stderr =
2012-07-31 16:47:00::DEBUG::common_utils::197::root:: retcode = 0
2012-07-31 16:47:00::DEBUG::common_utils::411::root:: updating vdc option AdminPassword to: ********
2012-07-31 16:47:00::DEBUG::common_utils::188::root:: Executing command --> '/usr/share/rhevm/rhevm-config/rhevm-config -s AdminPassword=******** --cver=general -p /usr/share/rhevm/conf/rhevm-config-install.properties'
2012-07-31 16:47:01::DEBUG::common_utils::195::root:: output =
2012-07-31 16:47:01::DEBUG::common_utils::196::root:: stderr = Error setting AdminPassword's value. No such entry with version general.

2012-07-31 16:47:01::DEBUG::common_utils::197::root:: retcode = 1
2012-07-31 16:47:01::DEBUG::rhevm-setup::1960::root:: *** The following params were used as user input:
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: override-iptables: yes
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: http-port: 8080
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: https-port: 8443
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: mac-range: 00:1A:4A:0A:0A:00-00:1A:4A:0A:0A:FF
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: host-fqdn: ltrhevmhq01.corp.librarytech.ae
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: auth-pass: ********
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: db-pass: ********
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: org-name: librarytech
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: default-dc-type: NFS
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: config-nfs: yes
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: nfs-mp: /backup
2012-07-31 16:47:01::DEBUG::rhevm-setup::1964::root:: iso-domain-name: biso
2012-07-31 16:47:01::ERROR::rhevm-setup::2295::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-setup", line 2289, in <module>
    main(confFile)
  File "/usr/bin/rhevm-setup", line 2126, in main
    runMainFunctions(conf)
  File "/usr/bin/rhevm-setup", line 2043, in runMainFunctions
    runFunction([_createDB,  _updateVDCOptions], output_messages.INFO_CREATE_DB)
  File "/usr/bin/rhevm-setup", line 1397, in runFunction
    raise Exception(instance)
Exception: Failed updating configuration parameter: Error: failed updating configuration field AdminPassword to ********

Responses

If you are planning a complete reinstall, did you do rhevm-cleanup before trying to re-install?

Please note that if you re-install and restore earlier database, then you should have to remove all hypervisors and re-register them to RHEV-M for the to be UP and Active.

I sucssed, to recovery the database or rhevm ... it was so pain in neck

Mohamed,

 

Is the RHEV-M up and running right now? You should have to re-register hypervisors after removing them.

 

Can you please also update the case opened with us?