Failed to start podman.socket

Latest response

Hello,

i'm working on RHEL 8.4. I installed podman-docker (with sudo yum intall podman-docker) and container-tools (with sudo yum module install container-tools).
Next i tried to call sudo systemctl start podman.socket but it returns

Failed to start podman.socket: Unit podman.socket not found.

I checked ls /usr/lib/systemd/system/io.podman.* which listed podman.services and podman.socket.

How can i start podman.socket?
And another thing i wonder is, if i run podman --version it returns version 1.4.2-stable3 which is according to podman.io very old...

Thanks

Responses

Hi Dominik,

Please upgrade your system to the latest stable edition RHEL 8.5 - which (currently) provides the podman version 3.3.1 ! :)

$ sudo dnf upgrade --refresh
$ sudo reboot

$ podman --version
podman version 3.3.1

$ systemctl list-unit-files | grep podman
podman-auto-update.service                 disabled 
podman-restart.service                     disabled 
podman.service                             disabled 
podman.socket                              disabled 
podman-auto-update.timer                   disabled 

$ sudo systemctl enable --now podman.socket
Created symlink /etc/systemd/system/sockets.target.wants/podman.socket → /usr/lib/systemd/system/podman.socket.

$ systemctl status podman.socket
● podman.socket - Podman API Socket
   Loaded: loaded (/usr/lib/systemd/system/podman.socket; enabled; vendor preset: disabled)
   Active: active (listening) since Tue 2021-11-23 12:12:03 CET; 18s ago
     Docs: man:podman-system-service(1)
   Listen: /run/podman/podman.sock (Stream)
   CGroup: /system.slice/podman.socket

Nov 23 12:12:03 cl-rs-02 systemd[1]: Listening on Podman API Socket.  

Regards,
Christian

Hi Christian, that sounds like a valid solution. Thanks! But is there a solution if i want/ have (corporate rules) to stay at RHEL 8.4? Or is this a known Problem?

Regards

Hi Dominik,

Besides that it is recommended to always use the latest stable edition for various reasons ...
Something seems to be generally wrong with your system - podman.socket is available, and
the latest available podman version for RHEL 8.4 is version 3.2.3 - maybe you have installed
an older module ? The default would be Stream : rhel8, that provides this podman version. :)

$ sudo dnf module list --installed

Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)
Name            Stream       Profiles
container-tools rhel8 [d][e] common  

Regards,
Christian

There should be something more recent even on RHEL 8.4. dnf module list container-tools should tell you what is available