Kickstart - Install RH8 from bootable USB device

Posted on

Hello,

I see some of you already afced the same problem but the solutions proposed don't work for me.
Context: 2 USB sticks
- 1 USB with the RH8 iso burned on it
- 1 USB stick containing the ks.cfg file

I update the boot sequence to use the bootable USB and I update the command to pass inst.ks parameter with the ks.cfg file.
Then the installation starts.
When the "checking storage configuration" finished, the result is
- Installation source => error setting up software source
- Software selection => error checking software selection

These errors only appear with RH8 because of the reorganisation of the packages.
The bootable USB is automatically mounted on /run/install/repo.
With RH7, packages are in /run/install/repo/Packages.
With RH8, packages are in /run/install/repo/BaseOS/Packages and /run/install/repo/AppStream/Packages.

I tried a lot of config differents to define the BaseOS/Packages repo. I tried url, repo, hardrive, ...
No way.

Does someone already succeeded to install RH8 with kickstart and bootable USB?

Thanks in advance
Rachel