Installing OpenShift 4 with Code Ready Containers

Latest response

I'm installing OpenShift 4 with Code Ready Containers (v 1.29) on Apple M1 architect. But during the setup process, I was faced with this problem:

"CodeReady Containers is unsupported on Apple M1 hardware."

Any advice?

Would you mind sharing any experiences and solutions?

Responses

Hello Farzad Ghavam,

As per the Code Ready Containers Operating system requirements page:

On macOS, CodeReady Containers requires macOS 10.12 Sierra or newer. CodeReady Containers does not work on earlier versions of macOS.

Reference: https://access.redhat.com/documentation/en-us/red_hat_codeready_containers/1.0/html/getting_started_guide/getting-started-with-codeready-containers_gsg

Not sure if "Apple M1" is supported.

Hope this helps!

Hello Sadashiva Murthy M,

Thank you for your response.

Unfortunately, the M1 architecture does not support it, and this is not a small problem.

I hope it will be resolved asap.