No user to login into

Latest response

Suddenly when I start the computer and choose the kernel I want to boot, no user to login into is available. I tried 'boot repair' but that did not fix it.

Responses

I will assume you had kernel panic or you've been boot to dracut shell, can you access your files ?

Your boot proccess might not be correct. Have you changed you're hard disk label or name lately ?

All I have is 'e' for edit and 'c' for a grub prompt.

I did install Ansible, but I forgot if it was involved with changing / adding label names.

Alright, it seems like you made something before you shut down/reboot of your system that has impact the boot process, I had this issue once. It was easy fix, I just had to press e and update two params with the new name.

Hope that helps!

The host name I added to the host file for Ansible was ansible@localhost

How do I update the system ? How do I make the original hostname be used always ?

I bet it's not Ansible !

Perhaps you made new space as storage or could be something similar, sorry couldn't help much! It might be action you made before Ansible installation and that depends what was your system uptime before the installation of Ansible. If it's more than 24 hours that means it might be days ago before the installation.

Hello Paul Gureghian, and welcome here.

You mentioned:

Suddenly when I start the computer and choose the kernel I want to boot, no user to login into is available. I tried 'boot repair' but that did not fix it.

Please let us know which if these apply:

  • Are you using Red Hat Linux version 8.x?
  • Are you using Red Hat Linux version 7.x?
  • Are you using a server or workstation build? (generally "workstation" means a graphical environment).
  • When did you load your system?
  • Did you make any changes to your system recently, like recent updates?
  • Dumb question, are all your cable connections tight?
Request Clarification:
  • When you say in your description "no user to login", do you really mean that when you boot the system, you have a blank screen and no login prompt whatsoever, just completely blank?? If yes, then consider this:
    • Reboot your system, do not pick a kernel, just let it boot without selecting a kernel. THEN after a few minutes, press "ctrl-alt-f3" or "ctrl-alt-f4" simultaneously. AFTER THAT - do you see a basic prompt? Yes no? If so, attempt a login that way. If this is the case, then maybe you need to install NVIDIA or some other graphics driver for your computer... maybe.
  • If this is the case, then please consider rebooting the system into the previous kernel and see how this goes.
Another possibility??
  • When you say in your description "no user to login", do you really mean that when you boot the system, you have a basic login prompt and it does not go into a graphical mode and you do not see a list of users as usual?? If yes, then consider this article:

Please let us know the details above so we can help you better.

Kind Regards,
RJ

Version 8.3 (Ootpa) and kernel 5.4.115.e18.elrepo.x86_64 I have Gnome and I did install Ansible and made an edit in /etc/hosts right before it bricked.

When GRUB would load I would choose the kernel I want and boot it and be presented with a login screen where all users on the system could be chosen, now I get no options. not a completely blank screen, there is a Red Hat logo, but that's it.

I will try your fixes. thanks.

The fixes did not seem to do anything. pretty sure it has to do with Ansible and the Ansible host name. I tried the troubleshooter in the USB installer but that did not work. And I don't think 'e' for edit on the GRUB screen or 'c' for GRUB prompt will work either.

Consider this Paul Gureghian,

Use a non-graphical login as I've mentioned previously, and below. Boot the system, bypass the hope of a graphical environment for now and use "ctrl-alt-f3" simultaneously to go to a pseudo terminal and consider reinstalling GNOME with this.

Before beginning this, is this system just a RHEL 8 system? You aren't running OpenShift or something different than just Linux, right? If you're running OpenShift or some non-typical program, consider opening a case with Red Hat.

yum groupinstall 'GNOME Desktop'

Log into the system pressing these 3 simultaneously: "ctrl-alt-f3" or f4, which is a pseudo-terminal (non-graphical) and then become root. Type in hostname -s. That displays what the system has it's current hostname set as.

If you want to set your hostname, simply run (as root) hostnamectl set-hostname paulsworkstation1.local but change "paulsworkstation.local" to something appropriate for you.

Dig through the /var/log/messages and other relevant logs. What playbook did you run?? What did it do? Just curious. The existence of Ansible doesn't break things, I imagine you're aware of that. What you can run with Ansible can break about anything.

Please give us more detail on what is going on behind what you've said about Ansible? Act like we don't know what you mean and need you to provide us the detail so we can assess what happened. Thanks.

Regards,
RJ

I edited my post above.

thanks but I can't get a login or terminal with ctrl-alt-f3 , f4 to even try the fixes / workarounds you listed. all I did with ansible was I installed it, made an edit in /etc/hosts and tested it.

Paul,

Can you ssh to the system, become root and change /etc/hosts to default?

Perhaps boot into a rescue environment such as in this article https://www.redhat.com/sysadmin/recover-root-passwd. Only the focus here is to get onto the system to edit /etc/hosts, not to change the root password. Pay attention to the guidance on SELinux.

I am surprised that editing /etc/hosts did this to you. If you manage to get on the system using the article above, I'd recommend temporarily running this:

systemctl set-default multi-user.target

Then after you edit and restore your /etc/hosts file, reboot the system, you will have NO users to select from when going to multi-user.target, but you WILL be able to run the other yum groupinstall command to restore your graphics if needed.

Have you ever done rescue boots into either Red Hat or CentOS previously? Are you familiar with interrupting the boot process and editing the grub menu to go to non-graphical? I still believe there is a chance you may need to do the yum groupinstall command I mentioned. Try this first. If this doesn't work, consider a ticket with Red Hat or reloading the system.

Regards,
RJ

I can't see me recovering back to where I was, probably need to reinstall. thanks.

Paul,

I wish you well with this matter. Welcome to the discussion forums

Kind Regards,
RJ