RHEL 7 TimeZone lost after reboot

Latest response

Hello community, I'm facing a strange behaviour on Red Hat 7.2

cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 (Maipo)

I setup the TimeZone as:
timedatectl set-timezone Europe/Rome
timedatectl
Local time: Fri 2021-06-18 14:55:27 CEST
Universal time: Fri 2021-06-18 12:55:27 UTC
RTC time: Fri 2021-06-18 12:55:27
Time zone: Europe/Rome (CEST, +0200)
NTP enabled: yes
NTP synchronized: no
RTC in local TZ: no
DST active: yes

That's ok. But after reboot I have:
timedatectl
Local time: Fri 2021-06-18 12:59:44 UTC
Universal time: Fri 2021-06-18 12:59:44 UTC
RTC time: Fri 2021-06-18 12:59:44
Time zone: UTC (UTC, +0000)
NTP enabled: yes
NTP synchronized: no
RTC in local TZ: no
DST active: n/a

So, TimeZone is lost. Could someone can drive me since I'm getting crazy?
Thank you
Lucas

Responses

Hello Sfewfew and welcome here,

I can't find a solution that encompasses RHEL 7, but please see the below, (after this line) older Red Hat solution seems outdated (see remainder of this post).

Also, check this article https://access.redhat.com/solutions/1449713 for use of timedatectl.

It seems from your output that NTP is enabled, but not synchronizing.

  • Please see [this Red Hat solution on. chrony](https://access.redhat.com/solutions/3073261,
  • and also examine this article and set up either chronyd or NTP to work.

Check to see if you have any failed services (namely, time-related) with systemctl | grep fail

If. you have ntpd or chronyd running and it's in a failed state, examine the service using things such as:

systemctl status -l ntpd.service
systemctl status -l chronyd.service

One of these (not both) should be enabled and configured properly and running. Red Hat generally. recommends using chrony now, but ntp works too.

Make sure you have proper directives set for the /etc/chronyd.conf file if you are using chronyd or /etc/ntp.conf if you are using ntpd. NOTE: Make sure to configure either chrony or ntpd - input reasonable time sources perhaps from this link If the service is failed, run things such as:

systemctl status -l chronyd.service
journalctl -xeu ntpd # if it is ntpd running
journalctl -xeu chronyd.service # if it is chronyd running

(note, replace "chronyd" with "ntpd" if you happen to be using ntpd instead of chrony)

It seems you've already taken the steps to configure your time zone, based on the timedatectl commands you mentioned.

Please check the articles above, and the BIOS clock for your system. Make sure the BIOS battery is good if needed too. If needed, submit a case with Red Hat too,.

Post back here if needed, someone should chime in.

Regards,
RJ

Thank you, after some research I found the root cause. It's openstack that for some reason change the TZ at boot time. I have to investigate why OS do that.

Ok, that makes more sense, thanks Lucas. We didn't know you had OpenStack involved in this.

Regards,
RJ