wrong ELF class: ELFCLASS32

Latest response

In rhel. 6 i am getting this error
/bin/sh: error while loading shared libraries: libdl.so.2: wrong ELF class: ELFCLASS32

help required

Note: In 64 bit linux machince installed 32 bit linux libraries .

Responses

Hi Palanivel,

Without providing us the full details of all the errors, an educated guess is that you have wrong architecture of libraries and the incorrect version of libraries.

One example of similar problem to yours:

https://www.linuxquestions.org/questions/linux-newbie-8/error-while-loading-shared-libraries-wrong-elf-class-elfclass32-4175491402/

It would be good to share with us what exactly you were trying to do.

Regards,

Dusan Baljevic (amateur radio VK2COT)