HP Printer Not Detected

Latest response

when I entered hp-info in terminal i got this message. Redhat 8.3 not detecting my printer. I have installed hplip from yum.

HP Linux Imaging and Printing System (ver. 3.18.4)
Device Information Utility ver. 5.2

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: No device found that support this feature.

Responses

IDK if it will help, but here is what I do for my printer (HP M426):

$ yum -y install foomatic hplip

$ lpinfo -m | grep "M426" lsb/usr/HP/hp-laserjet_mfp_m426_m427-ps.ppd.gz HP LaserJet Pro MFP M426-M427 Postscript

$ lpadmin -p M426fdw -m lsb/usr/HP/hp-laserjet_mfp_m426_m427-ps.ppd.gz -v socket://192.168.7.41/ -E

Then delete old printer install.

https://access.redhat.com/solutions/21432

Thank you Michael for your quick response.

My Printer is HP LaserJet Professional P1606dn. I have installed yum -y install foomatic hplip. After searching my printer it shows

root@localhost cls]# lpinfo -m | grep 1606 drv:///hp/hpijs.drv/hp-laserjet_professional_p1606dn-hpijs.ppd HP LaserJet Professional p1606dn hpijs, 3.18.4, requires proprietary plugin drv:///hp/hpcups.drv/hp-laserjet_professional_p1606dn.ppd HP LaserJet Professional p1606dn, hpcups 3.18.4, requires proprietary plugin lsb/usr/HP/hp-laserjet_professional_p1606dn.ppd.gz HP LaserJet Professional p1606dn, hpcups 3.18.4, requires proprietary plugin [root@localhost cls]#

What i want to do next. please help

Now my printer is detected. But it is not Printing.

[root@localhost cls]# lpstat -a P1606dn accepting requests since Sun 28 Mar 2021 07:11:26 PM IST

Thank you Michael. Your code works perfectly. After restarting the PC the printer issue is solved. But only single side printing is working. Duplex printing not working. Can you please help me for that.

I actually have the same problem when I try to print from a browser. The only way 2-sided printing works from me is to print as a pdf first, then print the pdf. For some reason 2-sided works when printing a pdf.

Does 2-sided printing work for you if you print as a pdf, then print the pdf?

Yes, Michael, for pdf duplex printing works. But i had a new issue tody. Yesterday i have configured the printer and it works perfectly and i have turned off that. But today the printer is not responding. I have once again added the printer using your commands. But it is not responding. I am unable to take prints. I dont know why this happened.

Britto,

Do you have a print server you might have to reset? Or the printer itself, will it print from another system? Perhaps revisit the steps you were given previously by Michael Millson?

Regards,
RJ

Thank you for your suggestion. I have once again configured my printer. [root@localhost britto]# lpstat -v device for P1606dn: socket://192.168.7.41/ [root@localhost britto]# lpstat -a P1606dn accepting requests since Wed 31 Mar 2021 09:40:02 AM IST [root@localhost britto]# systemctl status cups ● cups.service - CUPS Scheduler Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset> Active: active (running) since Wed 2021-03-31 09:35:20 IST; 10min ago Docs: man:cupsd(8) Main PID: 978 (cupsd) Status: "Scheduler is running..." Tasks: 6 (limit: 15356) Memory: 17.1M CGroup: /system.slice/cups.service ├─ 978 /usr/sbin/cupsd -l ├─2886 /usr/lib/cups/notifier/dbus dbus:// ├─2887 /usr/lib/cups/notifier/dbus dbus:// ├─2888 /usr/lib/cups/notifier/dbus dbus:// ├─3004 /usr/lib/cups/notifier/dbus dbus:// └─3014 socket://192.168.7.41/ 14 britto Test Page 1 job-uuid=urn:uui>

Mar 31 09:41:52 localhost.localdomain cupsd[978]: Connection error: Connection > Mar 31 09:41:52 localhost.localdomain cupsd[978]: The printer is unreachable at> Mar 31 09:42:37 localhost.localdomain cupsd[978]: Connection error: Connection > Mar 31 09:42:37 localhost.localdomain cupsd[978]: The printer is unreachable at> Mar 31 09:43:28 localhost.localdomain cupsd[978]: Connection error: Connection > Mar 31 09:43:28 localhost.localdomain cupsd[978]: The printer is unreachable at> Mar 31 09:44:23 localhost.localdomain cupsd[978]: Connection error: Connection > lines 1-23

While restarting the system the printer is detected (running siund is produced for some time). But while printing it is not printing. When i checked the status it is displaying processing in printer queue