Error installing software updates

Latest response

From the Web Console on Red Hat Enterprise Linux 8.3 (Ootpa), when I click "Install All Updates" I'm getting the following error:

Multiple matches of fuse-overlayfs;1.3.0-2.module+el8.3.1+9857+68fb1526;x86_64;rhel-8-for-x86_64-appstream-rpms

Need help to solve this situation. Any hints?

Responses

Hi Eduardo,

Web console runs PackageKit under the hood ... it is recommended to use the DNF CLI to manage system updates instead !
Please provide us with the output from sudo dnf list --showduplicates fuse-overlayfs so we can try to help you. :)

Regards,
Christian

Hi Eduardo,

Besides what I asked you to do ... please execute sudo dnf upgrade --refresh- it possibly may solve the problem.
In case you receive the same error notification as in the web console, we need the output from the command above. :)

Regards,
Christian

This solved the issue, thanks a lot!

I understand your recommendation about updating from the CLI but every option on the web console should work. Shouldn't it?

FYI after updating the system, I re-run the sudo dnf list --showduplicates fuse-overlayfs command and the output was exactly the same as before.

You're welcome, Eduardo ! I'm glad that you could solve the problem. :)

Regards,
Christian

[ereyes@s7 ~]$ sudo dnf list --showduplicates fuse-overlayfs
Updating Subscription Management repositories.
Last metadata expiration check: 2:19:47 ago on Tue 23 Mar 2021 12:44:56 PM EDT.
Installed Packages
fuse-overlayfs.x86_64         1.1.2-3.module+el8.3.0+8221+97165c3f         @AppStream                      
Available Packages
fuse-overlayfs.x86_64         0.3-2.module+el8.0.0.z+3525+56c076c3         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.3-2.module+el8.0.0+2958+4e823551           rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.3-2.module+el8.0.0+4017+bbba319f           rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.3-2.module+el8+2769+577ad176               rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.4.1-1.module+el8.1.0+4081+b29780af         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.7.2-1.module+el8.1.1+5259+bcdd613a         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.7.2-5.module+el8.1.1+6114+953c5a57         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.7.2-5.module+el8.2.0+6060+9dbc027d         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         0.7.2-5.module+el8.2.0+6368+cf16aa14         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         1.0.0-2.module+el8.2.1+6465+1a51e8b6         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         1.1.2-3.module+el8.3.0+8221+97165c3f         rhel-8-for-x86_64-appstream-rpms
fuse-overlayfs.x86_64         1.3.0-2.module+el8.3.1+9857+68fb1526         rhel-8-for-x86_64-appstream-rpms

Hi Eduardo,

Please execute sudo dnf module install container-tools:rhel8 - and afterwards sudo dnf upgrade.
Not sure if that lets you update the module ... on my machines/systems it did ... modularity is a complex thing. :)

Regards,
Christian

Hi Eduardo,

Some additional information ... the main reason why PackageKit is installed is that GNOME Software depends on it. Many users
like to have a GUI, so Red Hat provides the "Software Center GUI" additionally. But DNF is the main package manager, and also
responsible for managing modules. So, it's best practice to stick with the command line in order to have a flawless experience. :)

Regards,
Christian