Upgrade RHEL7.2 to last 7.x

Latest response

Hello, i have a Red Hat Enterprise Linux Workstation release 7.2 (Maipo) and i want to upgrade to the last 7.x (7.9 i guess)

i tried : yum upgrade

but i have dependencies error and I don't know if it's the right procedure to upgrade while staying on a 7 version.

Responses

Hi Jérôme,

Well, generally it should work that way ... as you didn't provide details, I assume you have packages from external repositories
installed. I recommend to uninstall these packages, disable those 3rd party repos, and then upgrade the system - afterwards
you can re-enable the repos and reinstall the applications. :)

Regards,
Christian

Hi, this is the error:

Erreur : Paquet : gnome-getting-started-docs-fr-3.14.1.0.2-1.el7.noarch (@anaconda/7.2) Requiert : gnome-getting-started-docs = 3.14.1.0.2-1.el7 Suppression  : gnome-getting-started-docs-3.14.1.0.2-1.el7.noarch (@anaconda/7.2) gnome-getting-started-docs = 3.14.1.0.2-1.el7 Mis à jour par : gnome-getting-started-docs-3.28.2-1.el7.noarch (rhel-7-workstation-rpms) gnome-getting-started-docs = 3.28.2-1.el7 Disponible : gnome-getting-started-docs-3.8.3.0.2-3.el7.noarch (rhel-7-workstation-rpms) gnome-getting-started-docs = 3.8.3.0.2-3.el7 Disponible : gnome-getting-started-docs-3.14.1.0.2-3.el7.noarch (rhel-7-workstation-rpms) gnome-getting-started-docs = 3.14.1.0.2-3.el7 Disponible : gnome-getting-started-docs-3.22.0-1.el7.noarch (rhel-7-workstation-rpms) gnome-getting-started-docs = 3.22.0-1.el7

yum can be configured to try to resolve such errors by temporarily enabling disabled repos and searching for missing dependencies. To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf

Hi Jérôme,

Please run this command, so the output is in English:

LANG=C yum -y update

When providing the output here start and end the output block with a line that only contains ~~~

That makes it easier to read.

Regards,

Jan Gerrit Kootstra

**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: gnome-getting-started-docs-fr-3.14.1.0.2-1.el7.noarch (@anaconda/7.2)
           Requires: gnome-getting-started-docs = 3.14.1.0.2-1.el7
           Removing: gnome-getting-started-docs-3.14.1.0.2-1.el7.noarch (@anaconda/7.2)
               gnome-getting-started-docs = 3.14.1.0.2-1.el7
           Updated By: gnome-getting-started-docs-3.28.2-1.el7.noarch (rhel-7-workstation-rpms)
               gnome-getting-started-docs = 3.28.2-1.el7
           Available: gnome-getting-started-docs-3.8.3.0.2-3.el7.noarch (rhel-7-workstation-rpms)
               gnome-getting-started-docs = 3.8.3.0.2-3.el7
           Available: gnome-getting-started-docs-3.14.1.0.2-3.el7.noarch (rhel-7-workstation-rpms)
               gnome-getting-started-docs = 3.14.1.0.2-3.el7
           Available: gnome-getting-started-docs-3.22.0-1.el7.noarch (rhel-7-workstation-rpms)
               gnome-getting-started-docs = 3.22.0-1.el7
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.5.0-21.el7_4.1.2.x86_64 has installed conflicts freeipa-client: ipa-client-4.5.0-21.el7_4.1.2.x86_64
ipa-client-4.5.0-21.el7_4.1.2.x86_64 has installed conflicts freeipa-admintools: ipa-client-4.5.0-21.el7_4.1.2.x86_64
ipa-client-common-4.5.0-21.el7_4.1.2.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.5.0-21.el7_4.1.2.noarch
ipa-common-4.5.0-21.el7_4.1.2.noarch has installed conflicts freeipa-common: ipa-common-4.5.0-21.el7_4.1.2.noarch
ipa-python-compat-4.5.0-21.el7_4.1.2.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.5.0-21.el7_4.1.2.noarch

Hi Jérôme,

Remove the conflicting packages : sudo yum remove gnome-getting-started-docs* freeipa-*
In case that isn't sufficient and still doesn't work, remove ipa packages as well : sudo yum remove ipa-*
Then upgrade the system : sudo yum upgrade ... afterwards you can reinstall the freeipa and ipa packages. :)

Regards,
Christian

Thanks Christian

You're welcome, Jérôme ! I wish you good luck - and success. :)

Regards,
Christian