I can't find redhat 8 releases when i list the releases avilable

Latest response

Im trying to upgrade from redhat 7 to redhat 8 using leap.
i keep facing the next error:
'--enablerepo', u'rhel-8-for-x86_64-appstream-rpms', '--enablerepo', u'rhel-8-for-x86_64-baseos-rpms', 'dnf'] failed with exit code 1.

when i tried to enable the repo it failed with next:
subscription-manager repos --enable rhel-8-for-x86_64-appstream-rpms
Error: 'rhel-8-for-x86_64-appstream-rpms' does not match a valid repository ID. Use "subscription-manager repos --list" to see valid repositories.

i tried to list all available releases and couldnt find any entries for redhat8

root@localhost ~]# subscription-manager release --list
+-------------------------------------------+
Available Releases
+-------------------------------------------+
7.0
7.1
7.2
7.3
7.4
7.5
7.6
7.7
7.8
7.9
7Server

My current subscription:
[root@localhost ~]# subscription-manager list
+-------------------------------------------+
Installed Product Status
+-------------------------------------------+
Product Name: Red Hat Enterprise Linux Server
Product ID: 69
Version: 7.9
Arch: x86_64
Status: Subscribed
Status Details:
Starts: 10/29/2020
Ends: 11/15/2021

Can i enable redhat 8 or do the company needs to pay for it?

Thanks,

Responses

Hi Ahmed,

Although upgrading from one major edition to the next is not exactly recommended - it is possible to upgrade from RHEL 7.9 to
RHEL 8.2
using the leapp method. If you followed the instructions (step-by-step) and are facing issues, please contact Red Hat
Customer Service
. Your company does not have to pay for using RHEL 8.2 because this is covered by your RHEL subscription. :)

Regards,
Christian

I have already opened a case however we have to open a case with a third party vendor 1st which takes wastes time.

also since its normal to not see redhat 8 versions since im running redhat 7.9 i guess the issue is else where.

The error i keep receive is:

[ERROR] Actor: target_userspace_creator
Message: Unable to install RHEL 8 userspace packages.
Summary:
    Details: Command ['systemd-nspawn', '--register=no', '--quiet', '-D', '/var/lib/leapp/scratch/mounts/root_/system_overlay', '--bind=/etc/hosts:/etc/hosts', '--setenv=LEAPP_NO_RHSM=0', '--setenv=LEAPP_EXPERIMENTAL=0', '--setenv=LEAPP_COMMON_TOOLS=:/etc/leapp/repos.d/system_upgrade/el7toel8/tools', '--setenv=LEAPP_COMMON_FILES=:/etc/leapp/repos.d/system_upgrade/el7toel8/files', '--setenv=LEAPP_UNSUPPORTED=0', '--setenv=LEAPP_EXECUTION_ID=d76845f2-cc7d-489f-99b6-4e2f140b1c90', '--setenv=LEAPP_HOSTNAME=localhost.viva.com.kw', 'dnf', 'install', '-y', '--nogpgcheck', '--setopt=module_platform_id=platform:el8', '--setopt=keepcache=1', '--releasever', u'8.2', '--installroot', '/el8target', '--disablerepo', '*', '--enablerepo', u'rhel-8-for-x86_64-baseos-rpms', '--enablerepo', u'rhel-8-for-x86_64-appstream-rpms', '--enablerepo', u'rhel-8-for-x86_64-baseos-rpms', '--enablerepo', u'rhel-8-for-x86_64-appstream-rpms', '--enablerepo', u'rhel-8-for-x86_64-appstream-rpms', '--enablerepo', u'rhel-8-for-x86_64-baseos-rpms', 'dnf'] failed with exit code 1.
    Stderr: Failed to create directory /var/lib/leapp/scratch/mounts/root_/system_overlay//sys/fs/selinux: Read-only file system
            Failed to create directory /var/lib/leapp/scratch/mounts/root_/system_overlay//sys/fs/selinux: Read-only file system
            Host and machine ids are equal (58bad9c0db364678b65590b045ea5d0d): refusing to link journals

However the below article stated that i can safely ignore the " Failed to create directory " part https://bugzilla.redhat.com/show_bug.cgi?id=1747444

Hi Ahmed,

Is your server registered to CDN of Red Hat or to a RH Satellite of your company?

this can be found in /etc/rhms/rhms.conf

Regards,

Jan Gerrit

under " /etc/rhsm/rhsm.conf" i found hostname = subscription.rhsm.redhat.com . We don't have RH Satellite.

Has this ever been resolved?