LightWorks does not work in rhel workstation 8.2

Latest response

how to install dependency so that lightworks works on rhel 8.2 workstation

sudo dnf install lightworks_2020.1.1_r124942.rpm

                    OUTPUT-

Updating Subscription Management repositories.
Last metadata expiration check: 1:17:13 ago on Fri 16 Oct 2020 02:41:22 PM IST.
Error:
Problem: conflicting requests
- nothing provides libcxx needed by lightworks-2020.1.1-1.x86_64
- nothing provides libm.so.6(GLIBC_2.29)(64bit) needed by lightworks-2020.1.1-1.x86_64
- nothing provides libstdc++.so.6(GLIBCXX_3.4.26)(64bit) needed by lightworks-2020.1.1-1.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages).

how to fix this ?

Responses

Hi Shiva,

As you can see in the installation guide - RHEL is not among the officially supported operating systems.
The output you've provided tells us that the matching dependency package versions are not available. :)

What you can try is, if the versions are available from a third party repository, execute these commands :

sudo dnf install https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
sudo dnf install https://download1.rpmfusion.org/free/el/rpmfusion-free-release-8.noarch.rpm
sudo dnf install https://download1.rpmfusion.org/nonfree/el/rpmfusion-nonfree-release-8.noarch.rpm

sudo dnf upgrade
sudo dnf install lightworks*.rpm

Not sure if this works (I never installed and used Lightworks), but possibly it does ... just give it a try ... :)

Regards,
Christian

i tried the above steps but it did not work getting the same error said above.

Thanks for your feedback, Shiva ! Okay, we have to accept it. Was just an idea ... :)

Hi Shiva,

Additional information about supported systems - and other requirements - from the release notes ->

Linux 64-bit  
RPM Distros:  

● Fedora 30 and higher
● Fedora is only supported when enabling Xorg. There is no support for Wayland (default) currently.
● Fedora installs fail if using Mesa drivers.
● There is no QuickTime Movie/MPEG4 export option.
● There is no .WMV import.
● ATI and Nvidia cards are supported. EditShare recommends Nvidia for the best performance.
● Fraps AVIs do not import.
● There is no FX plug-in support.
● No audio imported from OMFs (that do have embedded audio).
● Relaunch button does not work after the application crashes.
● Audio may not be present on some Uncompressed AVIs.
● Do not use linux default GFX driver.  

If you experience the viewer playing at a reduced size then the Linux default graphics driver is installed.  
Make sure the Nvidia driver is loaded and that the system is restarted.  

RHEL 8 is based on fedora 28 ... but with the repositories mentioned above, it might work. Good luck. :)

Regards,
Christian

i think i have to run fedora 32 "the only option left for me as i have already paid for 3 years subscription" anyway thanks for your response,take care.

You're welcome, Shiva ! Well, if Lightworks is mandatory, fedora is probably the best choice. :)