RHEL 6.4 to 6.5: GPG keys not correct?

Latest response

Dear all,

I'm trying to update a RHEL 6.4 system to 6.5 using "yum update", but get an error:

[root@srv-linux01 ~]# yum update

[... ]

Transaction Summary
================================================================================
Install      17 Package(s)
Upgrade     410 Package(s)
Remove        2 Package(s)

Total download size: 645 M
Is this ok [y/N]: y

[...]

Total                                           5.0 MB/s | 645 MB     02:10     
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release


The GPG keys listed for the "Red Hat Enterprise Linux 6 Server (RPMs)" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

I've added a few non-RHEL repositories (adobe-linux, epel, rpmfusion) and enabled a redhat.repo entry (rhel-6-server-cf-tools-1-rpms). Minor upgrades (6.2 -> 6.3 -> 6.4) always went smoothly.

However, I see old redhat-repo files in /etc/yum.repos.d/. One from Feb 28 2012 with different "sslclientkey" and "sslclientcert" entries, and one from Feb 25 2013 without "ui_repoid_vars = releasever basearch" lines. Experimenting with these files, however, yielded the same error.

I would be very glad with some help.

Responses

Dear all,

Ah, just starting a discussion topic already helps! ;)

Apparently, something was changed: Two hours later, "yum update" ran successfully, upgrading two packages less than before.

Hey Kris, I'd like to think we had something to do with this successful outcome- but I'm not certain of that. :)

Thanks for posting your follow-up!

Same thing here. Issue seems resolved, as I did a few successful upgrades.

Just wanted to point out, that RHN Classic Systems' Repositories apparently weren't affected.

Hi,

I still get the error, however, I'm installing from a repo on a local system that I do a "reposync" from every morning. Would there be any packages that need to be manually deleted from my local repo that are causing the problem? When I do a reposync, I always use the "-d" option to remove obsoletes, but that doesn't seem to make a difference here. Do we know what the "two packages" are that are not being updated anymore? Is this a case where doing a "yum upgrade" rather than a "yum update" would make a difference?

Thanks.

Not sure exactly what caused my problems, but I ended-up getting it to work by creating a brand new local repo and completely re-syncing everything from scratch. Not sure if this was a one-time fluke, or if I'll have to re-do the local repo from scratch with every point release. 6.4 was our first use of RHEL6, since we stuck with RHEL5 for awhile, so 6.4->6.5 is my first point release update experience with RHEL6. I never had to do this with my RHEL5 local repos. In any case, I've now successfully updated two systems after re-building my local repo from scratch.